[launcher] System Testing and Printers don't display proper menus when launched by command line

Bug #717134 reported by Ugo Riboni on 2011-02-11
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
BAMF
Medium
Unassigned
Unity
Fix Released
Medium
Jason Smith
unity-2d
Medium
Unassigned
bamf (Ubuntu)
Medium
Unassigned
Natty
Medium
Unassigned
Oneiric
Medium
Unassigned
unity (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

The System Testing application from Gnome Control Center doesn't work properly with the unity-2d launcher

Test case:
1. open a terminal
2. launch system-config-printer
3. check that a menu appears in the panel

------------
To reproduce:
- launch gnome-control-center
- click on the "System Testing" icon in g-c-c
- mouse over the System Testing icon in launcher

Expected result: "System Testing" appears in the label that pops up
Current result: " --log-level=debug" appears in that label

- right click over the System Testing icon in launcher

Expected result: there should be a "Keep in Launcher" item in the menu
Current result: there's no such item

The same problem happens also for the Printing application from g-c-c (even though the label is "System-config-printer.py")

Ugo Riboni (uriboni) wrote :

This was tested in up-to-date natty in a VM

summary: - [launcher] System Testing doesn't display proper menus
+ [launcher] System Testing and Printers don't display proper menus
description: updated

This is clearly an issue in bamf, it seems to fail to match an application with a desktop file when it is launched with e.g. "/usr/bin/python /some/script.py". I believe it is a duplicate of bug #641337, which I reported quite some time ago.

Changed in unity-2d:
status: New → Confirmed
importance: Undecided → Medium
Robert Sajdok (ris) wrote :

@Olivier Tilloy
I tested this bug and yes, this is exactly bug in the bamf.

Changed in bamf:
status: New → Confirmed
Didier Roche (didrocks) on 2011-04-22
Changed in unity:
status: New → Confirmed
Changed in bamf (Ubuntu):
status: New → Confirmed
Robert Sajdok (ris) wrote :

It seems that it works well after today's upgrading in the Unity-2d

Olivier Tilloy (osomon) wrote :

This is indeed partly fixed in unity-2d. However it’s still not possible to keep those applications in the launcher, so the bug persists in bamf.

Didier Roche (didrocks) on 2011-04-26
Changed in unity:
milestone: none → 3.8.14
assignee: nobody → Jason Smith (jassmith)
importance: Undecided → Medium
Changed in bamf:
importance: Undecided → Medium
Changed in bamf (Ubuntu):
importance: Undecided → Medium
Didier Roche (didrocks) on 2011-04-27
summary: - [launcher] System Testing and Printers don't display proper menus
+ [launcher] System Testing and Printers don't display proper menus when
+ launched by command line
description: updated
Changed in unity:
status: Confirmed → Fix Released
Changed in bamf:
status: Confirmed → Fix Released

Accepted bamf into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in bamf (Ubuntu Natty):
status: Confirmed → Fix Committed
tags: added: verification-needed
Changed in unity-2d:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bamf - 0.2.90-0ubuntu3

---------------
bamf (0.2.90-0ubuntu3) natty-proposed; urgency=low

  * Cherry-pick from upstream:
    - System Testing and Printers don't display proper menus when launched by
      command line (LP: #717134)
    - Unity Min,Max,Close buttons not available in Libreoffice when opened by
      double-clicking a file (LP: #728927)
 -- Didier Roche <email address hidden> Wed, 27 Apr 2011 17:07:18 +0200

Changed in bamf (Ubuntu Natty):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied to oneiric as well.

Changed in bamf (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bamf (Ubuntu Quantal):
status: New → Confirmed
Adolfo Jayme (fitojb) on 2014-01-11
no longer affects: bamf (Ubuntu Quantal)
Changed in unity (Ubuntu):
status: New → Fix Released
Rolf Leggewie (r0lf) wrote :

natty has seen the end of its life and is no longer receiving any updates. Marking the natty task for this ticket as "Won't Fix".

Changed in unity (Ubuntu Natty):
status: New → Won't Fix
Rolf Leggewie (r0lf) wrote :

oneiric has seen the end of its life and is no longer receiving any updates. Marking the oneiric task for this ticket as "Won't Fix".

Changed in unity (Ubuntu Oneiric):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers