[workspace switcher] Broken with compiz

Bug #715244 reported by Andrew Hayzen on 2011-02-08
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
unity-2d
High
Felix Krull
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

Hi

Description: Ubuntu 10.10
Release: 10.10
unity-2d-default-settings:
  Installed: 0.1.33~bzr50
  Candidate: 0.1.33~bzr50
  Version table:
 *** 0.1.33~bzr50 0
        500 http://ppa.launchpad.net/unity-2d-team/unity-2d-daily/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status
unity-2d-launcher:
  Installed: 0.4-0ubuntu1~bzr395
  Candidate: 0.4-0ubuntu1~bzr395
  Version table:
 *** 0.4-0ubuntu1~bzr395 0
        500 http://ppa.launchpad.net/unity-2d-team/unity-2d-daily/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status
unity-2d-panel:
  Installed: 0.4-0ubuntu1~bzr395
  Candidate: 0.4-0ubuntu1~bzr395
  Version table:
 *** 0.4-0ubuntu1~bzr395 0
        500 http://ppa.launchpad.net/unity-2d-team/unity-2d-daily/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status

What happens:
When I click on the 'workspaces' button nothing happens at all.

What I expected to happen:
When I clicked the 'workspaces' button for it to show the availible workspaces, much like expo.

Please note that I am running compiz on 'normal' settings on my PC if this helps to debug.

Andy

Related branches

summary: - workspacer switcher doesn't actually do anything with compiz enabled
+ [workspacer switcher] Broken with compiz
Changed in unity-2d:
status: New → Confirmed
summary: - [workspacer switcher] Broken with compiz
+ [workspace switcher] Broken with compiz
Revision history for this message
Christian Schendel (doppelhelix) wrote :

I have Compiz enabled and it's a bit different for me:
Clicking on the Workspaces-button will bring up the expo screen. But only one screen in the upper left, showing all windows across all workspaces. 3/4 of the screen remains black.
Clicking will zoom the screen to full, still with all windows. then I can decide which window to activate.

Revision history for this message
Aritchie (aritchie) wrote :

Well I cannot comment on how it works for me with compiz because I am using metacity and it seems to work fine with it but of course metacity does not have all the bells and whistles that compiz has.

Revision history for this message
Andrew Hayzen (ahayzen) wrote :

Hi

unity-2d-default-settings:
  Installed: 0.4-0ubuntu1~bzr400
  Candidate: 0.4-0ubuntu1~bzr400
  Version table:
 *** 0.4-0ubuntu1~bzr400 0
        500 http://ppa.launchpad.net/unity-2d-team/unity-2d-daily/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status
unity-2d-launcher:
  Installed: 0.4-0ubuntu1~bzr400
  Candidate: 0.4-0ubuntu1~bzr400
  Version table:
 *** 0.4-0ubuntu1~bzr400 0
        500 http://ppa.launchpad.net/unity-2d-team/unity-2d-daily/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status
unity-2d-panel:
  Installed: 0.4-0ubuntu1~bzr400
  Candidate: 0.4-0ubuntu1~bzr400
  Version table:
 *** 0.4-0ubuntu1~bzr400 0
        500 http://ppa.launchpad.net/unity-2d-team/unity-2d-daily/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status

Now after restarting and updating unity-2d my workspace switcher acts the same ways as Christian.

When I click on the workspace switcher it only shows 1 workspace and the rest remain either black or not shown. Then when i click on the workspace it zooms in to fill the screen, with all the windows shown, I can then click on the window that I want to focus on.

Andy

Revision history for this message
Sebastian Szperling (zebaszp) wrote :

I believe that's because of the different ways compiz handles workspaces/viewports. I installed compiz 0.9.2.1 on Maverick. If I choose the first or second options regarding workspaces (Virtual Horizontal/Vertical Size), these can be used with the cube and other compiz effects. If I choose the bottom one (Number of Desktops), these are incompatible with the effects, but usable with the workspace switcher.
Please note I use a spanish locale, so the options may be named differently, I just tried to translate them.

Revision history for this message
Sebastian Szperling (zebaszp) wrote :

This is what I was talking about. With this, I managed to fix the switcher. Please note that although I selected all options, these don't work together, so if I move a window to another virtual viewport, I will show in the workspace switcher as placed in the same workspace as before.

Revision history for this message
anonymous815 (anonymous815-deactivatedaccount) wrote :

hmm, I can't actually change this option. The up arrow is greyed out and typing in or dragging doesn't respond/do anything.
Seems like they are locked for some completely separate reason to unity, meaning I can't fix this.

Revision history for this message
Sebastian Szperling (zebaszp) wrote :

It also used to be locked for me. But I updated via an external PPA to 0.9.2.1 (version in Maverick repos is 0.8.6, I think).

Changed in unity-2d:
importance: Undecided → High
Changed in unity-2d:
assignee: nobody → Felix Krull (fkrull)
milestone: none → 3.10
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2011-05-31
Changed in unity-2d (Ubuntu):
status: New → Fix Committed
Changed in unity-2d:
milestone: 3.10 → 3.8.6
Changed in unity-2d:
status: Fix Committed → Fix Released
Changed in unity-2d (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers