[backend] Logging should be done through libunity-2d logging facilities

Bug #711724 reported by Aurélien Gâteau on 2011-02-02
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
unity-2d
Medium
Richard Dale
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

libunity-2d provide some logging facilities which features a few advantages over standard q(Debug|Warning):

- Print the class and method name of their caller.

- Get colored output (conditional in a branch I have not yet published)

- Handy way to debug a variable: UQ_VAR(foo) will output the following:
  foo=<value-of-foo>

- Handy glib-like RETURN_IF_FAIL and RETURN_VALUE_IF_FAIL macros

- Handy (not yet published) way to print the time since startup (togglable with an environment variable)

This should be cleaned up and we should start using it instead of q(Debug|Warning)

Changed in unity-2d:
status: New → Confirmed
importance: Undecided → Medium
Revision history for this message
Richard Dale (rdale) wrote :

The attached patch changes all instances of qDebug() to UQ_DEBUG, and all instances of qWarning() to UQ_WARNING

Changed in unity-2d:
assignee: nobody → Richard Dale (rdale)
Olivier Tilloy (osomon) on 2011-04-26
Changed in unity-2d:
status: Confirmed → In Progress
Changed in unity-2d:
milestone: none → 3.10
Revision history for this message
Aurélien Gâteau (agateau) wrote :

Thanks Richard, just applied your patch.

Changed in unity-2d:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-05-31
Changed in unity-2d (Ubuntu):
status: New → Fix Committed
tags: added: patch
Changed in unity-2d:
milestone: 3.10 → 3.8.6
Changed in unity-2d:
status: Fix Committed → Fix Released
Changed in unity-2d (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers