Long delay closing unity-2d session, something hang

Bug #706248 reported by Lucazade on 2011-01-22
48
This bug affects 7 people
Affects Status Importance Assigned to Milestone
unity-2d
High
Bill Filler

Bug Description

When I try to restart pc or to logout unity-2d session there is a long delay,
it seems panel or launcher hang.
Haven't found a way to debug or to identify problematic component.

Related branches

Lucazade (lucazade) wrote :
Changed in unity-2d:
importance: Undecided → High
milestone: none → 3.4
Lucazade (lucazade) wrote :

I think I've found which Unity-2d processes are hanging at session logout
* unity-2d-places
* unity-applications-daemon
* unity-files-daemon

launcher, panel and spread always close quickly.. places and these 2 daemons sometimes hangs for 5/10 seconds.

I took a screenshot when this happen, terminal is still alive during session shut down so I was able to "ps -ax | grep unity"

Lucazade (lucazade) wrote :

errata corrige:

I've removed executable bit (chmod a-x) to places, application-daemon and files-daemon (so are not loaded at session startup)
but session still hang at logout.

:(

Florian Boucault (fboucault) wrote :

So with the executable bit removed, what is the output of ps -ax | grep unity?

Lucazade (lucazade) wrote :

the output is empty, no unity-* process found
but there is anyway something else that hang.

Florian Boucault (fboucault) wrote :

That's annoying :)

Maybe it could be useful to get the entire list of programs running.

$ ps aux

would be great

Lucazade (lucazade) wrote :

ps aux output
(sorry for very small font!)

Lucazade (lucazade) wrote :
Florian Boucault (fboucault) wrote :

Lucazade: on your screenshots we see unity-* processes running.

Lucazade (lucazade) wrote :

yes, I enabled them because they make no differences. :)

Lucazade (lucazade) wrote :

ok... i removed exec bit again to places and daemon and tried to logout
(no unity-* process but hangs)
hope this could help :)

Lucazade (lucazade) wrote :
Florian Boucault (fboucault) wrote :

oki doki, just to confirm, you are running Maverick + the daily PPA, right?

Lucazade (lucazade) wrote :

yep! maverick + daily ppa

Florian Boucault (fboucault) wrote :

We have seen that issue before, confirming.

Changed in unity-2d:
status: New → Confirmed
Lucazade (lucazade) wrote :

Before the session is completely closed I can see a small window called "Unknown"..
maybe it is related to this issue.

I get this window popping out in both Maverick and Natty.

Lucazade (lucazade) wrote :

It is too quick to detect window with xprop, unfortunately.

Florian Boucault (fboucault) wrote :

It looks like a windowed panel to me.
@Aurélien: thoughts?

Changed in unity-2d:
milestone: 3.4 → 3.8
Florian Boucault (fboucault) wrote :

Similar to #716167

Changed in unity-2d:
assignee: nobody → Bill Filler (bfiller)
Bill Filler (bfiller) wrote :

please see comments in bug #716167 as it's quite related to this.

Lucazade (lucazade) wrote :

@Bill Filler
Thanks for pointing this out!

Changed in unity-2d:
status: Confirmed → Fix Committed
Bill Filler (bfiller) wrote :

ran into problem again, proposed a new merge request with fix.

Changed in unity-2d:
status: Fix Committed → In Progress
Changed in unity-2d:
status: In Progress → Fix Committed
Changed in unity-2d:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers