[panel] application name cut when menu bar visible should use a fade

Bug #704615 reported by Andrew Hayzen on 2011-01-18
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
unity-2d
Low
Aurélien Gâteau
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

When the application name is too long and the menu bar is visible, the last letter looks cut. It would be nice if there is a little fade there.

Fix bug #694924 at the same time.

Related branches

Andrew Hayzen (ahayzen) wrote :
Simon Bull (simon-d-bull) wrote :

Hi Andrew

I can confirm that this bug affects me, and can be re-produced.
To confirm this, I have attached a screen shot of RhythmBox, which I have noticed has its name cut-off.

Regards
Simon Bull

Changed in unity-2d:
status: New → Confirmed
Andrew Hayzen (ahayzen) on 2011-01-18
summary: - menu bar overlaps application name when not in maximised
+ Menu bar overlaps application name when the window is not in maximised
summary: - Menu bar overlaps application name when the window is not in maximised
+ [panel] menu bar overlaps application name when not in maximised

@Mark: I believe that the fact this bug was reported makes the choice between a straight cut of the title (unity-2d) and a smoother fade out (unity) more clear. What do you think?

The goal is a proximity transition, till then a mouseover is acceptable.
It won't change pre-Natty.

Mark

@Mark: I understand that in the future (post-Natty) we will implement a proximity transition where the menu fades in and the end of the application name fades out. My question is about which one of the visual cuts should be chosen. I am attaching the 2 options (Unity 2D/Unity 3D) to make it clearer.

Florian Boucault (fboucault) wrote :

@Mark: I understand that in the future (post-Natty) we will implement a proximity transition where the menu fades in and the end of the application name fades out. My question is about which one of the visual cuts should be chosen. I am attaching the 2 options (Unity 2D/Unity 3D) to make it clearer.

Florian Boucault (fboucault) wrote :

Ah, thanks Florian that clarifies the question nicely.

I think the unity-3d version is best for now. I'm not SO certain of it
that I won't change my mind later, though, so with apologies I would ask
you to make the change for Natty knowing we might change it again later.

Mark

summary: - [panel] menu bar overlaps application name when not in maximised
+ [panel] application name cut when menu bar visible should use a fade
description: updated
Changed in unity-2d:
importance: Undecided → Low
importance: Low → Medium
tags: added: delta-with-3d
Changed in unity-2d:
importance: Medium → Low
tags: added: bitesize
Didier Roche (didrocks) on 2011-05-31
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Changed in unity-2d:
status: Confirmed → In Progress
Didier Roche (didrocks) on 2011-06-24
Changed in unity-2d (Ubuntu):
status: Confirmed → In Progress
Changed in unity-2d:
assignee: nobody → Aurélien Gâteau (agateau)
milestone: none → 3.8.12
Changed in unity-2d:
status: In Progress → Fix Committed
Changed in unity-2d (Ubuntu):
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-07-28
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (3.5 KiB)

This bug was fixed in the package unity-2d - 3.8.12-0ubuntu1

---------------
unity-2d (3.8.12-0ubuntu1) oneiric; urgency=low

  [ Florian Boucault ]
  * Upstreamed patch 01_build_with_new_indicator.patch
  * do not run pkgbinarymangler to convert images to 8bit since this breaks
    the launcher icon background handling. (LP: #809205)
    (QT upstream bug: http://bugreports.qt.nokia.com/browse/QTBUG-4459)
  * debian/unity-2d.install:
    - install GSettings schemas into usr/share/glib-2.0/schemas
    - install GConf to GSettings conversion into usr/share/GConf/gsettings
  * debian/gconf/schemas/unity-2d.schemas:
    - remove GConf schema for /desktop/unity-2d/launcher/super_key_enable
    - remove GConf schema for /desktop/unity-2d/launcher/favorites
  * debian/20_unity-2d-gconf-default:
    - remove default value for /desktop/unity-2d/launcher/super_key_enable
    - remove default value for /desktop/unity-2d/launcher/favorites
  * debian/control:
    - add dependency on libdconf-qt-dev
    - add dependency on libnux-1.0-dev

  [ Didier Roche ]
  * New upstream release:
    - [dash] preferred applications are not stored in GConf anylonger
      (LP: #805063)
    - [launcher] Tiles background is white/grey instead of the color of the
      icon (oneiric only) (LP: #809205)
    - [dash] Keyboard navigation not implemented as specified (LP: #608132)
    - Unity 2D should use dconf instead of gconf (LP: #692965)
    - [launcher] KDE3 Applications do not appear in launcher (LP: #719983)
    - ubuntu-bug showing that I am running unity-2D, when reporting from
      Compiz Unity interface (LP: #712343)
    - Apps pinned in launcher not retained between 2D and 3D Unity versions
      (LP: #746823)
    - [dash] Cannot have KDE4 applications as shortcuts on home screen
      (LP: #750081)
    - [panel] F10 shortcut does not navigate from application menu to
      indicators (LP: #772061)
    - [panel] F10 shortcut does not show application menu (LP: #777993)
    - [dash] Wine applications are not launched (LP: #794471)
    - [spread] GnomeBackground needs to use dconf to retrieve image path
      (LP: #805393)
    - [dash] transparency broken and graphical artifacts when using opengl
      backend (LP: #806019)
    - [dash] Enter no longer launches first item (LP: #811673)
    - [panel] navigation between application menus temporarily gives focus
      back to the application (LP: #717682)
    - [panel] Empathy's emotes not visible in panel menus (LP: #742822)
    - pgadmin3 not handled by unity-2d (LP: #800710)
    - [dash] slow rendering of background with opengl engine (LP: #806122)
    - [spread] Wallpaper is shifted by the width of the launcher (LP: #808712)
    - [launcher] Migrate gconf key /desktop/unity-2d/launcher/super_key_enable
      to dconf (LP: #810509)
    - [panel] application name cut when menu bar visible should use a fade
      (LP: #704615)
    - [panel] Window title could use a little fade (LP: #694924)
    - [launcher] Codeblocks doesn't appear in the list of applications
      (LP: #716524)
  * Fix typo in trigger (debian/unity-2d.triggers): (LP: #807358)
  * Install the apport hook in the right directory so that it's not laun...

Read more...

Changed in unity-2d (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers