[launcher] can't add java programs as favorites

Bug #704046 reported by Christian Schendel on 2011-01-17
140
This bug affects 57 people
Affects Status Importance Assigned to Milestone
BAMF
Medium
Marco Trevisan (Treviño)
GNOME Shell
New
Undecided
Unassigned
Unity
Fix Released
Medium
Marco Trevisan (Treviño)
unity-2d
High
Unassigned
bamf (Ubuntu)
Undecided
Marco Trevisan (Treviño)
unity (Ubuntu)
Undecided
Unassigned

Bug Description

 By starting a java program like freemind, the "Keep in Launcher" option is missing

Related branches

Florian Boucault (fboucault) wrote :

Thanks for the bug report Christian!

@Olivier: this is another example of bamf not able to find the desktop file.

summary: - [launcher] can't add java programs
+ [launcher] can't add java programs as favorites
Changed in unity-2d:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Olivier Tilloy (osomon)
Changed in unity-2d:
milestone: none → 3.8
Changed in unity-2d:
assignee: Olivier Tilloy (osomon) → nobody
milestone: 3.8 → none
Changed in unity-2d:
milestone: none → 3.10
Alex Launi (alexlauni) wrote :

I just very successfully added a java app to the unity launcher

Changed in unity:
status: New → Invalid
Florian Boucault (fboucault) wrote :

Thanks for the confirmation Alex. Just so that I can reproduce it here, what Java app was it?

Olivier Tilloy (osomon) wrote :

So I can confirm that freemind cannot be kept in the launcher. This is because bamf is unable to find the matching desktop file.

I also tested in unity, and found an interesting behaviour, confirmed by reading the code: every tile in the launcher can be "kept", regardless of whether the launcher knows the corresponding desktop file. But when the desktop file is unknown, the application is not actually added to the favorites (can be checked with `gsettings list-recursively com.canonical.Unity.Launcher`). I also guess the "favorite" won’t be persistent across sessions. Moreover, if the application is exited, it cannot be re-launched from the icon in the launcher (no desktop file associated…), which renders the functionality rather useless.

In short: the issue is with bamf, and there doesn’t seem to be a real discrepancy between unity-2d and unity.

Changed in unity:
status: Invalid → Confirmed
Didier Roche (didrocks) on 2011-04-05
Changed in bamf:
status: New → Confirmed
Changed in bamf (Ubuntu):
status: New → Confirmed

Same problem with Jedit - a powerful editor written in Java. I can open Jedit, however I cannot (right-click) add it to my favourites. So I guess this is just a duplicate?
Did I understand that to fix the bug on has to fix bamf? Or should I report a bug upstream for the desktop file?

Olivier Tilloy (osomon) wrote :

@Christian: this is indeed the same issue you are observing, no need for another bug report.

Changed in unity-2d:
milestone: 3.10 → none
mporten (mathias-porten) wrote :

I can confirm this bug, with JabRef 2.6 and for unity-2d, for unity, it seems to work (on my other computer).

Florian Boucault (fboucault) wrote :

Mathias, can you check again in Unity: the option "keep in launcher" is probably there but if you select it and then log out and back in again the application might be gone from the launcher.

mporten (mathias-porten) wrote :

Florian, no option "keep in launcher" is there, so I cannot select it.

This is a problem in gnome-shell as well: I just tested using Ubuntu 11.10 and jEdit does not show "Add to Favorites" like other apps do.

Valeriy (tverdohleb) wrote :

Same with Netbeans, eclipse, etc. Tested in gnome shell (3.2 — 3.3.90)
It's annoying :(

Changed in bamf:
importance: Undecided → Medium
Changed in unity:
status: Confirmed → In Progress
importance: Undecided → Medium
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
milestone: none → 7.1.1
Changed in bamf:
milestone: none → 0.5.0
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity-2d:
status: Confirmed → Won't Fix
Changed in bamf (Ubuntu):
status: Confirmed → In Progress
Changed in bamf:
status: Confirmed → In Progress
Changed in bamf (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in bamf (Ubuntu):
status: In Progress → Fix Committed
Changed in bamf:
status: In Progress → Fix Committed
Changed in bamf (Ubuntu):
status: Fix Committed → Fix Released
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity at revision 3458, scheduled for release in unity, milestone 7.1.1

Changed in unity:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.1.0+13.10.20130812.1-0ubuntu1

---------------
unity (7.1.0+13.10.20130812.1-0ubuntu1) saucy; urgency=low

  [ Brandon Schaefer ]
  * Add ibus.py to the tests/autopilot/unity/emulators from
    lp:autopilot. (LP: #1210661)
  * Don't make the ScopeView/DashView/ScrollView Visible on start up
    (bool wise, causing things to think its ok to render). (LP:
    #1201631)
  * Adds the ability to use the mouse in the switcher. (LP: #824965)

  [ Andrea Azzarone ]
  * Add edge barriers to unity::panel::PanelView. (LP: #931384)

  [ Marco Trevisan (Treviño) ]
  * ApplicationLauncherIcon: Create a local desktop file when sticking
    an app that has not Also make icon sticky only if both the icon
    itself and the inner app is sticky as well. (LP: #1209320, #753305,
    #765466, #754334, #704046)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 3462
 -- Ubuntu daily release <email address hidden> Mon, 12 Aug 2013 06:49:01 +0000

Changed in unity (Ubuntu):
status: New → Fix Released

Fix Released in Bamf BAMF 0.5.0.

Changed in bamf:
status: Fix Committed → Fix Released
Stephen M. Webb (bregma) wrote :

Fix Released in Nux Unity 7.1.1.

Changed in unity:
status: Fix Committed → Fix Released
Bastien Ho (bastienho) wrote :

Sorry, but the bug seems to be still here in unity 7.3.2

Eleni Maria Stea (hikiko) wrote :

Could you please give us some information on how you reproduced in unity 7.3.2? Thank you!

Also, please let me know if you get any information when doing:
 - xprop | grep PID

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers