Unity-2D SRU-1 needs releasing

Bug #1060262 reported by Łukasz Zemczak on 2012-10-02
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
unity-2d
Medium
Łukasz Zemczak
unity-2d (Ubuntu)
Wishlist
Unassigned
Precise
Wishlist
Unassigned

Bug Description

[ Description ]

This is the master bug for a Unity 2D SRU into 12.04 LTS. Please see the individual bugs for verification (from the changelog).

[ Original description ]

The last SRU-1 release got rejected, we removed the offending commit and wish to re-submit the package for release once again.
The branch for releasing: lp:unity-2d .

Previous description:

Since a long time, many Unity-2D fixes are waiting in trunk for an SRU-1 (5.14) release. These changes are well tested and green, just waiting for a pick-up from distro.

The testing document for this:
https://docs.google.com/a/canonical.com/document/d/1DGRLRtUviohgdPfXQALGDdqmvUHyHmpzzcAf38Wusu0/edit

Once the changelog branch gets merged in, lp:unity-2d should be ready for release. All bugs for this release are SRU compatible. Asking for sponsorship!

Re-submitting the release.

Related branches

description: updated
Changed in unity-2d:
status: New → Fix Committed
affects: unity (Ubuntu) → unity-2d (Ubuntu)
Changed in unity-2d (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
status: Confirmed → Invalid
Changed in unity-2d (Ubuntu Precise):
importance: Undecided → Wishlist
status: New → Triaged
Didier Roche (didrocks) wrote :

handled directly and ready to be pushed.

Changed in unity-2d (Ubuntu Precise):
status: Triaged → Fix Released
description: updated
Changed in unity-2d (Ubuntu Precise):
status: Fix Released → Fix Committed
description: updated
Didier Roche (didrocks) wrote :

This one is released

Changed in unity-2d (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in unity-2d:
status: Fix Committed → Fix Released
Changed in unity-2d (Ubuntu Precise):
status: Fix Released → Fix Committed
Dimitri John Ledkov (xnox) wrote :

There is no unity-2d in -proposed pocket, nor in the precise unapproved queue.

Was this uploaded? Or was this SRU fully released to -updates already, and this bug simply needs fix released?

I am trying to clean the subscribed Ubuntu Sponsors queue.

Łukasz Zemczak (sil2100) wrote :

Hi xnox. No, sadly this version of unity-2d is *still* not released. All those changes are waiting for release since half a year now... before the holidays it got to the stage of getting picked up by a sponsor, but it never made it to -proposed as it got bumped because of one non-SRUable commit. We removed that commit and re-submitted the version for sponsoring again.

Please, I would be really grateful if someone could finally release this to the precise users. Unity-2D is maybe not supported by future versions, but it's still used by the LTS users - and they would probably be happy to see some of the old issues finally fixed.

Iain Lane (laney) on 2013-01-22
Changed in unity-2d (Ubuntu Precise):
status: Fix Committed → In Progress
Iain Lane (laney) wrote :
description: updated
Marc Deslauriers (mdeslaur) wrote :

Since this was uploaded, I'm unsubscribing ubuntu-sponsors, and subscribing the SRU team for processing.

description: updated

Hello Łukasz, or anyone else affected,

Accepted unity-2d into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity-2d/5.14.0-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity-2d (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 5.14.0-0ubuntu1

---------------
unity-2d (5.14.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release (LP: #1060262):
    - [Launcher] [Multi-monitor] Removing a non running app tile from a
      launcher should remove it from all (LP: #988739)
    - Panel Titlebar double click is emitted for any mouse button (LP: #736491)
    - Launcher does not hide if shown while dragging a file (LP: #1002308)
    - icon isn't reset when clearing the search query (LP: #973225)
    - Issue when ejecting busy device from the Unity 2D Shell (LP: #997786)
    - Sticky edges don't work in RTL (LP: #984092)
    - pips are not correctly updated when plugin in a second monitor
      (LP: #1003943)
    - [dash] Unable to maximize (LP: #918648)
    - all panels have same window focus on multiple monitors unity2d
      (LP: #930147)
    - Dash will not open files under Greek folders (LP: #1002710)
    - Launcher does not respond to changes in icon theme (LP: #605475)
    - [panel] Invisible items in systray (LP: #703389)
    - [panel] Ignores "enabled" property on top-level menus (LP: #850017)
  * Reverted some quantal-specific commits which are no longer relevant
 -- Lukasz 'sil2100' Zemczak <email address hidden> Tue, 30 Oct 2012 09:59:49 +0100

Changed in unity-2d (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers