Dash will not open files with accentuated, Greek or Russian characters in their name or path

Reported by eumetaxas on 2012-05-22
56
This bug affects 15 people
Affects Status Importance Assigned to Milestone
unity-2d
Medium
Unassigned
unity-2d (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

[Test Case]
1. Have a folder with greek characters like Παράδειγμα
2. Have a file called THIS_IS_A_TEST_FOR_GREEK_CHARS inside that folder
3. Open that file from nautilus so it will show up in the files dash
4. Open Dash
5. Go to the files dash
6. Type THIS_IS_A_TEST_FOR_GREEK_CHARS
7. Open the file from the dash
   -> Verify the file really opens

[Regression Potential]
Dash not opening some files or all possible files at all.

Original description:

Since I have upgraded from 11.10 to 12.04 64bit i cannot open from dash folders with Greek names or files located under folders with Greek names (the name of the file does not matter). I click on them, the dash disappears but nothing happens. If i open them from nautilus it's ok, they are then listed in Dash in recent files but still will not open. If i rename the folder from eg Παράδειγμα to Example (Greek to Latin) and open it from Nautilus then i can normally open it from Dash. The folder is not encrypted and i checked permissions. This happens with all file types. At first i thought that it was Dropbox fault but apparently is not.

eumetaxas (eumetaxas) wrote :

After messing around with my system i realised that the problem was Unity 2d. I thought i was using 3d but it was actually 3d. I updated my on board Intel graphics card, finally got Unity 3d and the problem is gone.

Michal Hruby (mhr3) on 2012-05-23
affects: unity-lens-files → unity-2d
Changed in unity-2d:
status: New → Confirmed
importance: Undecided → Medium
Changed in unity-2d:
assignee: nobody → Albert Astals Cid (aacid)
status: Confirmed → Triaged
Changed in unity-2d:
milestone: none → 5.14
status: Triaged → In Progress

I get the same issue with french folder names with accent.

Changed in unity-2d:
status: In Progress → Fix Committed
description: updated
Gerry Boland (gerboland) on 2012-05-30
Changed in unity-2d:
milestone: 5.14 → 5.12.1
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-2d (Ubuntu Precise):
status: New → Confirmed
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Pierre van Male (vmalep) wrote :

Same as Frédéric Hoogstoel: a file with accent in its name will not open. It will once I have removed the accent (like "réponse" -> "reponse").

My installation is up to date.

vmalep@T420-12:~$ apt-cache policy unity-lens-files
unity-lens-files:
  Installed: 5.10.0-0ubuntu1
  Candidate: 5.10.0-0ubuntu1
  Version table:
 *** 5.10.0-0ubuntu1 0
        500 http://es.archive.ubuntu.com/ubuntu/ precise/main i386 Packages
        100 /var/lib/dpkg/status

Changed in unity-2d:
milestone: 5.12.1 → 5.14
Changed in unity-2d (Ubuntu):
status: Confirmed → Fix Released

This bug might have other duplicates than bug #1003820: bugs #1013386 and #992717.

Is there any chance for this bug to be fixed in Ubuntu 12.04? The fix has been committed to Unity 2D 5.14 if I understand correctly, but Ubuntu 12.04 uses Unity 2D 5.12, and no new version of Unity 2D has been released since 5.12 in April.

Sorry if it's a newb question but it's very unclear to me whether 5.14 will be available for Ubuntu 12.04, what with Unity 2D being discontinued in Ubuntu 12.10 and whatnot. Thanks for any clarification.

Adding to Frédéric's comment #2 and Pierre's comment #5, I can confirm that this bug happens wherever the accentuated character occurs in the file's full path, i.e.:

  /home/nael/testdir/testsubdir/téstfile.txt
  /home/nael/testdir/téstsubdir/testfile.txt
  /home/nael/téstdir/testsubdir/testfile.txt

cannot be opened from the Dash in Unity 2D 5.12.

I can also confirm that this bug affects files who have Greek or Russian characters (accentuated or not) in their name or path. And I'm modifying the bug name to better describe this.

tags: added: accents dash russian
removed: lens
summary: - Dash will not open files under Greek folders
+ Dash will not open files with accentuated, Greek or Russian characters
+ in their name or path
Łukasz Zemczak (sil2100) wrote :

This fix has landed in 5.14 which still didn't get properly released. It's still waiting in the unapproved queue - I was hoping this would be since long released, but there seem to be some heavy delays. I apologize for that.

I hope soon 5.14 will FINALLY land in precise-proposed for your testing convenience.

Changed in unity-2d (Ubuntu Precise):
status: Confirmed → In Progress
Changed in unity-2d:
assignee: Albert Astals Cid (aacid) → nobody

Hello eumetaxas, or anyone else affected,

Accepted unity-2d into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity-2d/5.14.0-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity-2d (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Łukasz Zemczak (sil2100) wrote :

Performed the test with the greek-character directory name as mentioned in the Test Case and all is working as expected.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 5.14.0-0ubuntu1

---------------
unity-2d (5.14.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release (LP: #1060262):
    - [Launcher] [Multi-monitor] Removing a non running app tile from a
      launcher should remove it from all (LP: #988739)
    - Panel Titlebar double click is emitted for any mouse button (LP: #736491)
    - Launcher does not hide if shown while dragging a file (LP: #1002308)
    - icon isn't reset when clearing the search query (LP: #973225)
    - Issue when ejecting busy device from the Unity 2D Shell (LP: #997786)
    - Sticky edges don't work in RTL (LP: #984092)
    - pips are not correctly updated when plugin in a second monitor
      (LP: #1003943)
    - [dash] Unable to maximize (LP: #918648)
    - all panels have same window focus on multiple monitors unity2d
      (LP: #930147)
    - Dash will not open files under Greek folders (LP: #1002710)
    - Launcher does not respond to changes in icon theme (LP: #605475)
    - [panel] Invisible items in systray (LP: #703389)
    - [panel] Ignores "enabled" property on top-level menus (LP: #850017)
  * Reverted some quantal-specific commits which are no longer relevant
 -- Lukasz 'sil2100' Zemczak <email address hidden> Tue, 30 Oct 2012 09:59:49 +0100

Changed in unity-2d (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers