GTK+ theming engines no longer supported in 3.16+?

Bug #1579273 reported by James Lu
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unico
Undecided
Unassigned
lubuntu-artwork (Ubuntu)
Undecided
Unassigned
mythbuntu-default-settings (Ubuntu)
Undecided
Unassigned
unico (Ubuntu)
Undecided
Unassigned

Bug Description

From what I've heard over at https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=822976, GTK+ 3.16 and above drop support for theme engines entirely, rendering projects like Unico unusable. However, I'm not sure how to confirm this, or how to tell whether themes are already using pure CSS or a combination of CSS and theme engine elements.

In Ubuntu, there still seem to be some reverse dependencies for gtk3-engines-unico, even though GTK 3.18 is available in xenial:

gl@millennium:~$ reverse-depends gtk3-engines-unico -r xenial
Reverse-Depends
===============
* lubuntu-artwork-11-10
* lubuntu-artwork-12-04
* lubuntu-artwork-12-10
* lubuntu-artwork-13-04
* lubuntu-artwork-13-10
* lubuntu-artwork-14-04
* lubuntu-artwork-14-10
* lubuntu-artwork-15-04
* lubuntu-artwork-15-10
* lubuntu-artwork-16-04
* mythbuntu-default-settings

Could someone please clarify the status of this package?

Related branches

Mathew Hodson (mhodson)
tags: added: packaging
Jeremy Bicha (jbicha)
Changed in mythbuntu-default-settings (Ubuntu):
status: New → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers