Universal Netboot Installer

USB Drive not recognised in OSX Lion (10.7)

Reported by Vinny Troia on 2011-07-15
102
This bug affects 20 people
Affects Status Importance Assigned to Milestone
UNetbootin
Undecided
Geza Kovacs

Bug Description

When using UnetBootin on Mac OSX Lion, you are unable to select a USB drive from the list. When you click on the dropdown list, nothing happens.

There are also 2 Unetbootin icons that stay in your dock when the application is launched. One of them continues to bounce indefinitely.

Vinny Troia (vinny) wrote :
Mark Duncan (eattheapple) wrote :

I'm experiencing the exact same thing.

Changed in unetbootin:
status: New → Confirmed
Joe Taylor (bx-joe) wrote :

I have the exact same issue. UnetBootin is not currently usable under Lion.

Myron Gochnauer (goch) wrote :

I have the same problems. UnetBootin works properly on the same Mac when using the Windows version in/under VMWare Fusion and Windows 7. (Make sure you enable the USB drive in the Fusion Virtual-Machine / USB menu.)

wieckefamily (wieckefamily) wrote :

This bug affects me

Tom Frost (t15) wrote :

Note that launching Unetbootin from the command line with sudo eliminates the issue with the secondary bouncing icon, but unfortunately it still won't show any drives.

Carlo DiCelico (carlodicelico) wrote :

Same issue on Mac 10.7 Lion. I also tried it on VMWare Fusion with Windows 7 and it did not detect the USB drive that way, either.

Josso (josso000) wrote :

Yep, I can confirm it too.
Any chance of a bugfix update soon?

Mike (mike-techsupport) wrote :

Same

Tom Gallacher (tomgallacher23) wrote :

After looking into this problems it seems that the command being run "disktool -l" on line 541 in unetbootin.cpp is calling a deprecated command (which is used to show drives) and needs to be updated to work with the command "diskutil" on OS X lion.

Geza Kovacs (gezakovacs) wrote :

Thanks for the hint, Tom Gallacher. At any rate, I uploaded a version that doesn't use disktool, and, assuming that was the only issue, should work correctly on OSX Lion, at http://downloads.sourceforge.net/project/unetbootin/UNetbootin/555/unetbootin-mac-555.zip could someone confirm that it fixes the issue (asking because I don't actually have access to OSX Lion myself).

Changed in unetbootin:
assignee: nobody → Geza Kovacs (gezakovacs)
status: Confirmed → Fix Committed
Moystard (moystard) wrote :

It still does not work on my installation with the version you have uploaded Geza. No USB disks are listed.

Brandon LeBlanc (demosdemon) wrote :

Same here. The version you posted still doesn't show the inserted USB drives on Lion.

Angelo (an6elo) wrote :

Fix does not show USB drives on Lion, but it does show my 2nd harddrive with Windows (SATA)

Vinny Troia (vinny) wrote :

Fix does not work for me either. Both icons continue to load.

Kongxiao Zhao (freefrank21) wrote :

The fix works for me. Successfully listed my usbdrive.
Thanks Kovacs.

Geza Kovacs (gezakovacs) wrote :

Made the 555 release the default, because it seems it fixes the USB drive listing problem for someone at the very least. Anyhow, for the other users not having the USB drives listed, it's probably because they aren't formatted as FAT32 (HFS or NTFS-formatted USB drives won't be listed). As for the double-icons issue, I'm aware of it but don't have a good fix at the moment (the issue is that I haven't found any easy way of getting the graphical prompt for superuser privileges other than via osascript, which unfortunately results in a second icon showing up in the dock).

Changed in unetbootin:
status: Fix Committed → Fix Released
Steve Voida (svoida) wrote :

555 works for me on Lion. Resolved exactly the issue that others had raised.

Moystard (moystard) wrote :

You were right, my disk was not formatted using FAT32 so was not displayed. Fixed it, thank you for the patch.

ironstorm (ironstorm-gmail) wrote :

555 works for me on Lion, however 549 (which I didn't try) is the default release for Mac OS X if you hit the sourceforge page... one has to dig through the SF project files to get 555.

Geza Kovacs (gezakovacs) wrote :

Thanks for the reminder ironstorm, I've changed the default release on Sourceforge to 555 as well.

Sarim Khan (sarim2005) wrote :

The code is just executing "diskutil list" then seaching for "FAT" :S odd algorithm. So you need to format your usb drive with FAT32 filesystem to unetbootin to detect it.
But its not working after all, just gets hanged on 2.) Extracting and coping files :S

Giacomo (giacomo-shimmings) wrote :

If you're using Disk Utility in OSX 10.6.2 upwards, the 'Erase' or 'Partition' seems to change the type from "FAT32" to "Microsoft Basic Data". Using the command "sikutil list" I got this information:

/dev/disk2
   #: TYPE NAME SIZE IDENTIFIER
   0: GUID_partition_scheme *1.9 Gi disk2
   1: Microsoft Basic Data UNTITLED 1.9 Gi disk2s1

...and the same disk formatted in Linux:

/dev/disk2
   #: TYPE NAME SIZE IDENTIFIER
   0: FDisk_partition_scheme *1.9 Gi disk2
   1: DOS_FAT_32 UNTITLED 1.9 Gi disk2s1

Les Carleton (z-les-v) wrote :

Hi,

Just a note for anyone trying to workaround this. If you just name the USB drive 'FAT32' and erase it with FAT in the diskutil then uNetBootin will find it.

Geza Kovacs (gezakovacs) wrote :

@Giacomo:

Does http://downloads.sourceforge.net/project/unetbootin/UNetbootin/568/unetbootin-mac-568.zip fix the issue (sorry, don't have access to Lion myself)? Basically I've changed it to list partitions whose type contains "Microsoft" (in addition to "FAT32"), so the drive should be selectable. However, given that the partition scheme indicated is GUID not FDisk, I'm unsure whether it actually will boot.

Panama (webdevotion) wrote :

Works for me on OS X Lion.

One issue:
Drive is listed as "disk2s1" in stead of "My Little USB Stick" ( readable label given to a usb stick ).

Thanks for the fix!

Panama (webdevotion) wrote :

On a second thought: USB Drive is not recognized as a bootable drive on my netbook.
Tried Unetbootin from a Windows box earlier today and resulted in a bootable ( same ) usb drive.

Rodrigo Pereira (unebootin) wrote :

Here the USB is not recognized as bootable too. I need go to a linux box, run fdisk and mark the partition as bootable.

docmod (pascal-poschenrieder) wrote :

Both Versions do not work for me. (Lion 10.7.3)
The List of USB-Sticks is empty and I have got two Icons.

Eric Reitz (silentice) wrote :

I still have this problem too with OSX 10.7.3 and unetbootin 568, reformatted 5 or so times to fat32. Also launching unetbooting from a Standard user and NOT an administrator user.

yuhao (yuhao-cg) wrote :

Hi, guys,

you can do like this :

using osx's terminal

into the folder that your unetbootin.app saved,

#diskutil list

/dev/disk0
   #: TYPE NAME SIZE IDENTIFIER
   0: GUID_partition_scheme *500.1 GB disk0
   1: EFI 209.7 MB disk0s1
   2: Apple_HFS Macintosh HD 349.0 GB disk0s2
   3: Apple_Boot Recovery HD 650.0 MB disk0s3
   4: Microsoft Basic Data BOOTCAMP 150.2 GB disk0s4
/dev/disk2
   #: TYPE NAME SIZE IDENTIFIER
   0: FDisk_partition_scheme *15.6 GB disk2
   1: DOS_FAT_32 1 15.6 GB disk2s1

~~you will see your disks like above,

in my computer, my USB disk is /dev/disk2s1

so i command blow,

#sudo unetbootin.app/Contents/MacOS/unetbootin installtype=USB targetdrive=/dev/disk2s1

it works !!

Ivan Petrov (hilobakho) wrote :

Same problem as of 583 on Mountain Lion

cfriedt (chrisfriedt) wrote :

Wow... Hilarious that this bug is already several years old and it's still not fixed.

Unetbootin release 584.

$ diskutil list
/dev/disk0
   #: TYPE NAME SIZE IDENTIFIER
   0: GUID_partition_scheme *750.2 GB disk0
   1: EFI 209.7 MB disk0s1
   2: Apple_HFS Macintosh HD 749.3 GB disk0s2
/dev/disk1
   #: TYPE NAME SIZE IDENTIFIER
   0: NO NAME *14.3 GB disk1
/dev/disk2
   #: TYPE NAME SIZE IDENTIFIER
   0: Apple_partition_scheme *18.5 MB disk2
   1: Apple_partition_map 32.3 KB disk2s1
   2: Apple_HFS Flash Player 18.4 MB disk2s2

$ uname -a
Darwin HIDDENHOSTNAME 11.4.2 Darwin Kernel Version 11.4.2: Thu Aug 23 16:25:48 PDT 2012; root:xnu-1699.32.7~1/RELEASE_X86_64 x86_64

cfriedt (chrisfriedt) wrote :

Wow - I actually blogged about the solution years ago already -

http://perpetual-notion.blogspot.ca/2011/08/unetbootin-on-mac-os-x.html

David Glover (me-davidglover) wrote :

Still broken in 10.8.5.

2 years since reported. Happy birthday!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Bug attachments