Universal Netboot Installer

Installing Ubuntu 10.10 alternate gives Cd-rom related errors

Reported by sosaited on 2010-11-09
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
UNetbootin
Medium
Geza Kovacs
Ubuntu
Undecided
Unassigned

Bug Description

I first tried installing Ubuntu 10.10 64-bit (Alternate) from Windows 7 via Unetbootin 494, both with Hard drive option and USB one. But in both cases it gave Cd-rom related errors after language and keyboard selection (No common Cd-rom drive was detected in case of HDD, Error reading data from Cd-rom in case of USB). I tried adding "cdrom-detect/try-usb=true" in the menu both times, but got the same error. The ISO's MD5 was matched, and it was not corrupt as I burnt the same file later and installed successfully. This was on a Dell Inspiron 1564

Now I am trying to install 32-bit version (alternate) of 10.10 via Hard drive method (Unetbootin 494 on Ubuntu 10.04), and I get the same [No Common Cd-rom drive was detected) error. MD5 again matched error. On this machine I can't use USB or Cd, so this is the only choice.

Is there a workaround for this until this is resolved?

description: updated
Robert Roth (evfool) wrote :

Thank you for reporting this bug. See bug #234185, it might be related. Basically it suggests to try to make an USB image using Startup Disk Creator instead of UNetBootin. Could you please check, if that does work?

Changed in ubuntu:
status: New → Incomplete
dEUS101 (diesel101) wrote :

I've had this problem as well, a few minutes ago. When I checked the installer log (ALT + F4) when I got the "CD-ROM not found" error, it said there was a file missing: 'pool/main/l/linux/fs-secondary-modules-2.6.35-22-generic-di_2.6.35-22.33_amd64.udeb'.
So I booted up in Windows again and check that directory. The file was there, but had an incomplete extension...
It said "fs-secondary-modules-2.6.35-22-generic-di_2.6.35-22.33_amd64.ude", missing the 'b'.

Is this an error created by UNetbootIn? Why did the filename got cut off?
The USB drive is FAT32, maybe the max filename length was reached when the file was copied?

dEUS101 (diesel101) wrote :

There were 2 other files that had an incomplete extension in the same dir, but they were shorter, now I come to think of it...
I just properly named them (.udeb) and it worked fine. USB installation went smoothly and fast.

Geza Kovacs (gezakovacs) wrote :

@dEUS101: the issue of the 2 udeb files having the wrong names (specifically, being truncated to 64 characters) is because 7-zip, which is used by UNetbootin for extracting iso files, doesn't support the RockRidge extensions which are used by the Ubuntu alternate iso for having 64+ characters in filenames. See https://bugs.launchpad.net/unetbootin/+bug/373089 and http://sourceforge.net/tracker/?func=detail&aid=2928072&group_id=14481&atid=114481 for the bug reports detailing the issues.

summary: - Installing Ubuntu 10.10 gives Cd-rom related errors
+ Installing Ubuntu 10.10 alternate gives Cd-rom related errors
Geza Kovacs (gezakovacs) wrote :

Confirming, but unfortunately can't be fixed until 7-zip supports the RockRidge filesystem; tracked in http://sourceforge.net/tracker/?func=detail&aid=2928072&group_id=14481&atid=114481 until then the filenames in the iso which have 64+ character filenames will be truncated.

Changed in unetbootin:
assignee: nobody → Geza Kovacs (gezakovacs)
importance: Undecided → Medium
status: New → Confirmed
Changed in ubuntu:
status: Incomplete → Opinion
Gus (gus-lgze) wrote :

This also affects 10.10 server 64 (and I believe 10.04 64 server as well).

Looking at the downloaded file in winrar shows the same truncation. The universal USB installer fails for the same reason.

I corrected the file names and was able to install successfully.

Universal USB installer appears to run some post installation scripts and has settings for various ISOs. It might be possible to get them to make corrections with their post install scripts.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.