Cannot boot newer kernels (Ubuntu 10.10 alpha3): "No init found"

Bug #615285 reported by Volodymyr Shcherbyna
92
This bug affects 17 people
Affects Status Importance Assigned to Milestone
UNetbootin
Undecided
Geza Kovacs
unetbootin (Fedora)
Fix Released
High
unetbootin (Ubuntu)
Medium
Luke Faraone
Lucid
Medium
Unassigned

Bug Description

== BEGIN SRU INFO ==
This bug prevents anybody running Lucid from using Unetbootin with a Maverick ISO image.

The upstream developer has tested the proposed Lucid update against ubuntu-10.10-rc-desktop-amd64.iso and ubuntu-10.04-desktop-i386.iso.

== STEPS TO REPRODUCE ==
 0. Install unetbootin
 1. Download any Maverick ISO later than Alpha 3, such as the RC.
 2. Run "unetbootin", entering your password when prompted.
 3. Select the "Diskimage" checkbox
 4. Tap the "…" button to the far left on the same line.
 5. Select the Maverick ISO image you downloaded in #1.
 6. Either install to hard-drive or USB (change via the type menu)
 7. Click "okay"
 8. Reboot when prompted.
 9. In GRUB, select "Unetbootin" from the menu.

Expected behavior: the computer boots to the Live desktop.
Current (broken) behavior: the computer does not boot, saying a message like "Can't find init".

== END SRU INFO ==

Hello all,

I was unable to boot Ubuntu 10.10 alpha 3 (both x32 and x64) using Universal Netboot Installer. I was using USB flash drive and the error was "Can't find init".

I am pretty sure this error happens in 100% when using alpha 3 of Ubuntu 10.10, if it does not happen, I can enable debug logs (if possible) or make a picture of my screen.

I tried twice to reformat my USB drive in order to eliminate possible drive failures, but in both cases the error was the same.

Here is the iso which I was trying to boot: http://cdimage.ubuntu.com/cdimage/releases/maverick/alpha-3/maverick-desktop-i386.iso

At the same time, I was able to boot Ubuntu 10.04 x32 - everything went properly. So my USB drive is working OK ...

Thanks for this amazyingly useful tool!

Related branches

Revision history for this message
Volodymyr Shcherbyna (volodymyr) wrote :

I noticed that I can't boot Ubuntu 10.10 even using official ubuntu live USB disk creator.

Revision history for this message
Abhinandan Kothari (abhinandankothari) wrote :

I also tried to install ubuntu 10.10 alpha 3 using a usb disk by unetbootin but it did not worked.Giving the same error as mentioned above

Revision history for this message
Taylor Jasko (taylor-techcores) wrote :

I believe it's simply installing GRUB on the USB drive other than the physical HD itself. I just installed the beta of Ubuntu 10.10 using Unbootin and I was able to get it to boot when I booted from the flash drive. I have no idea why it chooses to install the boot loader there, but apparently it does.

Revision history for this message
Nogero (oregonbob) wrote :

I tried running unetbootin 471 (latest version) on Ubuntu 10.04 system to install Ubuntu 10.10 32bit Beta ISO on a USB stick. The USB stick won't boot with error "No init found", which is also being reported on ubuntuforums.

Luke Faraone (lfaraone)
summary: - Newer kernels (Ubuntu 10.10 alpha3) unable to boot using Universal
- Netboot Installer
+ Cannot boot newer kernels (Ubuntu 10.10 alpha3): "No init found"
Changed in unetbootin:
status: New → Incomplete
status: Incomplete → Confirmed
affects: ubuntu → unetbootin (Ubuntu)
Changed in unetbootin (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Revision history for this message
Geza Kovacs (gezakovacs) wrote :

This turned out to be due to a bug in the way I located files mentioned in syslinux include statements. The fix has been committed, and I will be making a new release shortly. For reference (and/or any patching that may be desired) the diff is located at:

http://github.com/gkovacs/unetbootin/commit/feab255c7c67b9663092be2420fb69a1fc32d446#diff-1

Changed in unetbootin:
assignee: nobody → Geza Kovacs (gezakovacs)
status: Confirmed → Fix Committed
Revision history for this message
Geza Kovacs (gezakovacs) wrote :

Fixed released as part of UNetbootin 490

Changed in unetbootin:
status: Fix Committed → Fix Released
Luke Faraone (lfaraone)
Changed in unetbootin (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Luke Faraone (lfaraone)
Revision history for this message
Jean-Luc (hardy-paris) wrote :

This must a critical issue for a majority people trying to install Ubuntu!

Revision history for this message
Volodymyr Shcherbyna (volodymyr) wrote :

Thanks for the bug fix. It worked!

I tried the beta version of Ubuntu 10.10 as well as beta of Fedora 14. Both works like a charm with *490 release.

Merci!

Luke Faraone (lfaraone)
Changed in unetbootin (Ubuntu):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unetbootin - 471-1ubuntu1

---------------
unetbootin (471-1ubuntu1) maverick; urgency=low

  * Fixes issues when loading Ubuntu 10.10 desktop iso. (LP: #615285)
 -- Geza Kovacs <email address hidden> Wed, 29 Sep 2010 14:54:28 -0400

Changed in unetbootin (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
unksi (unksi) wrote :

This bug still exists in Ubuntu 10.04 Lucid. I would expect most people that use unetbootin to create installable USB media use Lucid and they will so encounter this bug.

It would be great to see either updated or patched version of unetbootin in Lucid repositories, so people do not need to use the one from Maverick repositories.

Revision history for this message
Reda Lazri (0rAX0) (0rax0) wrote :

This bug is still present in 4.90 with Ubuntu 10.10 RC.

Revision history for this message
Marcus E (marcus+e) wrote :

Sorry for spamming up the thread, but I am glad I found this thread after cursing over why the 10.10 RC won't boot up on my netbook after using unetbootin in 10.04 to copy the iso to a usb stick.

Revision history for this message
Reda Lazri (0rAX0) (0rax0) wrote :

Never mind, it was my fault.

Luke Faraone (lfaraone)
Changed in unetbootin (Ubuntu Lucid):
status: New → In Progress
assignee: nobody → Luke Faraone (lfaraone)
Luke Faraone (lfaraone)
description: updated
Changed in unetbootin (Ubuntu Lucid):
importance: Undecided → Medium
Luke Faraone (lfaraone)
Changed in unetbootin (Ubuntu Lucid):
status: In Progress → Fix Committed
assignee: Luke Faraone (lfaraone) → nobody
Revision history for this message
Martin Pitt (pitti) wrote : Please test proposed package

Accepted unetbootin into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Revision history for this message
Arpad Kovacs (minhmeoke) wrote :

The lucid-proposed package seems to work correctly with the 32-bit Ubuntu 10.10 RC iso.

Martin Pitt (pitti)
tags: added: verification-done
removed: verification-needed
Revision history for this message
Geza Kovacs (gezakovacs) wrote :

Is there anything else that needs to be done before this fix can be moved from lucid-proposed to lucid-updates? The SRU page doesn't seem to indicate anything else after verifications, and if at all possible I'd like to avoid having a huge influx of bug reports and negative reviews from lucid users who are using the old version from the repositories tomorrow when they try making a Ubuntu 10.10 live USB.

Revision history for this message
Geza Kovacs (gezakovacs) wrote :

Nevermind, I just noticed that there's a mandatory 7-day waiting period for SRUs. Since this probably won't get an exception, I've put a notice on the UNetbootin home page warning users not to use the lucid package so hopefully that will take care of most of the unnecessary duplicate bug reports.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unetbootin - 408-1ubuntu0.10.04.2

---------------
unetbootin (408-1ubuntu0.10.04.2) lucid-proposed; urgency=low

  * Fixes issues when loading Ubuntu 10.10 desktop iso. (LP: #615285)
 -- Geza Kovacs <email address hidden> Wed, 06 Oct 2010 15:33:58 -0400

Changed in unetbootin (Ubuntu Lucid):
status: Fix Committed → Fix Released
Revision history for this message
In , MarcH (march-redhat-bugs) wrote :

Description of problem:
unetbootin fails to parse syslinux "include" statements. As a result, boot config files are incorrect and the boot process fails half-way with the message "no init found. try passing init= bootarg". Already reported in Launchpad and fixed in version 490.

Version-Release number of selected component (if applicable):
485

How reproducible:
With ubuntu-10.10-desktop-i386.iso (among others)

Revision history for this message
In , MarcH (march-redhat-bugs) wrote :

I downloaded from sourceforge the unetbootin-linux-494 standalone binary pre-compiled for Fedora and everything worked fine. The first, UNetbootin boot menu now includes all the menu entries correctly carried over from the original CD.

Version 485 offered only "Default" and "Help", both of them eventually halting in Busybox with this message: "no init found. try passing init= bootarg"

Revision history for this message
In , Fedora (fedora-redhat-bugs) wrote :

unetbootin-0-8.494bzr.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/unetbootin-0-8.494bzr.fc12

Revision history for this message
In , Fedora (fedora-redhat-bugs) wrote :

unetbootin-0-8.494bzr.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/unetbootin-0-8.494bzr.fc13

Revision history for this message
In , Fedora (fedora-redhat-bugs) wrote :

unetbootin-0-8.494bzr.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/unetbootin-0-8.494bzr.fc14

Revision history for this message
Thomas (teclab-at) wrote :

Today I installed a fresh 10.10 Desktop, then did an online update and the reboot failed with the same error. I wasn't able to fix it with all the tips from papa google like fsck, update-grub ... so I'am currently re-installing the system.
So here my questions: Is this the same bug? and when is it safe to do online-update?

thx

Revision history for this message
Luke Faraone (lfaraone) wrote : Re: [Bug 615285] Re: Cannot boot newer kernels (Ubuntu 10.10 alpha3): "No init found"

On 10/16/2010 10:59 AM, tombert wrote:
> Today I installed a fresh 10.10 Desktop, then did an online update and the reboot failed with the same error. I wasn't able to fix it with all the tips from papa google like fsck, update-grub ... so I'am currently re-installing the system.
> So here my questions: Is this the same bug? and when is it safe to do online-update?

If you're not using unetbootin, then this is not the same bug.

--
╒═════════════════════════════════════════════════════════════════╕
│Luke Faraone ╭Debian / Ubuntu Developer╮│
http://luke.faraone.cc ╰Sugar Labs, Systems Admin╯│
│PGP: 5189 2A7D 16D0 49BB 046B DC77 9732 5DD8 F9FD D506 │
╘═════════════════════════════════════════════════════════════════╛

Revision history for this message
In , Fedora (fedora-redhat-bugs) wrote :

unetbootin-0-8.494bzr.fc12 has been pushed to the Fedora 12 testing repository. If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with
 su -c 'yum --enablerepo=updates-testing update unetbootin'. You can provide feedback for this update here: https://admin.fedoraproject.org/updates/unetbootin-0-8.494bzr.fc12

Revision history for this message
In , Fedora (fedora-redhat-bugs) wrote :

unetbootin-0-8.494bzr.fc12 has been pushed to the Fedora 12 stable repository. If problems still persist, please make note of it in this bug report.

Revision history for this message
In , Fedora (fedora-redhat-bugs) wrote :

unetbootin-0-8.494bzr.fc13 has been pushed to the Fedora 13 stable repository. If problems still persist, please make note of it in this bug report.

Revision history for this message
In , Fedora (fedora-redhat-bugs) wrote :

unetbootin-0-8.494bzr.fc14 has been pushed to the Fedora 14 stable repository. If problems still persist, please make note of it in this bug report.

Changed in unetbootin (Fedora):
importance: Unknown → High
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.