unetbootin needs application icon

Bug #614124 reported by Alexander Skiba on 2010-08-06
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
UNetbootin
Undecided
Unassigned

Bug Description

Unetbootin should have a nice application icon. Ideally made by danRabbit (https://launchpad.net/~daniel-p-fore), who did the humanity-icons and developed the elementary-icons.

Alexander Skiba (ghostlyrics) wrote :
alecive (alecive) wrote :

Moreover, it lacks the entry in the .desktop file that is the file that manage the application menu:

cat /usr/share/applications/unetbootin.desktop
[Desktop Entry]
Version=1.0
Name=UNetbootin
Comment=Tool for creating Live USB drives
Categories=Application;System;
Exec=/usr/bin/unetbootin
Terminal=false
Type=Application
Name[en_US]=UNetbootin
GenericName[en_US]=UNetbootin
Comment[en_US]=Tool for creating Live USB drive

Doing this, the result is that with some iconsets that icon is blank, with others is the default application icon (very ugly, you can see it here -> http://www.image-upload.net/images/8ts7kr12drrtqg5rkj7.png ). The trick would be only adding by default this simple line to the unetbootin.desktop file:

Icon=unetbootin

And then, for iconsets that support that icon (for example, AwOken icon theme), this problem can be fixed for a while (see here -> http://www.image-upload.net/images/8ts7kr12drrtqg5rkj7.png ), until there will be an official icon!

schmoemi (schmoemi) wrote :

Maybe not perfect, but I tried an unetbootin icon as a merger of a cd icon an an USB stick icon. It looks like if the cd stuck in the stick :-)
Base icons are free ones from findicons.com

Geza Kovacs (gezakovacs) wrote :

An official icon has been added as of the latest UNetbootin release (506).

alecive (alecive) wrote :

But does it follow system theme specifications (as I said earlier)?

alecive (alecive) wrote :

Downloaded the latest version but not, there isn't the little fix I suggested. It's only a matter to add the "Icon" entry to "unetbootin.desktop" file. Doing this, unetbootin icon in applications menu will follow customized icon themes!

Alex Engelmann (alex-engelmann) wrote :

I'm on the latest version (549.1) and these is no icon for this app, either in the Software Center or the Applications panel.

MestreLion (mestrelion) wrote :

Using 563-2 for maverick from PPA, and still no icon. The "Icon=unetbootin" entry in the .desktop file is there, but there is no icon file shipped in the binary .DEB

Changed in unetbootin:
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers