Universal Netboot Installer

Root is incorrect in menu.lst for fedora 12 hard disk install

Reported by James Edgar on 2010-01-31
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
UNetbootin
High
Geza Kovacs

Bug Description

I was attempting a hard drive install from an Ubuntu partition. Menu.lst for Grub was modified by Unetbootin to add:

title UNetbootin
root (hd0,0)
kernel /boot/ubnkern root=live:CDLABEL=Fedora-12-i686-Live-FEL rootfstype=auto ro liveimg quiet rhgb rd_NO_LUKS rd_NO_MD noiswmd
initrd /boot/ubninit
boot

This resulted in the following error on booting to this selection:

[drm:drm_mode_rmfb] *ERROR* tried to remove a fb that we didn't own
Boot has failed, sleeping forever

By going to test mode, the first error is skipped, and the following error shows up:

No root device found.
Boot has failed, sleeping forever.

This problem can be fixed by replacing the CD name live:CDLABEL=Fedora-12-i686-Live-FEL
with the UUID of the partition that Unetbootin has placed the boot image on. Since my install image was
on the Ubuntu partition, I just copied that. I assume this is something Unetbootin can do automatically. In any case, other with the same issue can do the same thing. Thanks, James

Corrected Menu.lst entry:

title UNetbootin
root (hd0,0)
kernel /boot/ubnkern root=UUID=9174e8bd-2976-4e4f-a9b3-6b874715350e rootfstype=auto ro liveimg quiet rhgb rd_NO_LUKS rd_NO_MD noiswmd
initrd /boot/ubninit
boot

Geza Kovacs (gezakovacs) on 2010-01-31
Changed in unetbootin:
importance: Undecided → High
assignee: nobody → Geza Kovacs (gezakovacs)
status: New → In Progress
Geza Kovacs (gezakovacs) on 2010-02-01
Changed in unetbootin:
status: In Progress → Fix Committed
yord_yy (yord-yy) wrote :

Also it happens under Win7 - I was attempting a hard drive install from a Win7 partition, when at boottime i chose "UNetbootin", install seems to begin...and the same error arises:
    Boot has failed, sleeping forever

"UNetbootin" boot entry content was (when i saw it by pressing "e"):
  find --set-root /unetbtin/ubnkern
  kernel /unetbtin/ubnkern root=UUID=4E09-73C2 rootfstype=auto ro liveimg quiet rhgb rd_NO_LUKS rd_NO_MD noiswmd
  initrd /unetbtin/ubninit
  boot

some workaround? edit UUID manually (but to what)?

UNetbootin 4.19 for Windows is used

Geza Kovacs (gezakovacs) wrote :

Forgot to close this bug, it was fixed as of the 393 release.

@yord-yy Your issue is not a UNetbootin one, as the UUID and syslinux.cfg are correct. Most likely, Fedora is simply not detecting your hard drive or some other hardware.

Changed in unetbootin:
status: Fix Committed → Fix Released
Ren Xu (aoirex) wrote :

Great. Manully setting the UUID did the trick.

Is there any way to patch the existing LiveCD iso file produced by the older version of UNetbootin to fix this problem?

For example, is it possible to patch the new Fedora 14 LiveCD?
http://mirror.switch.ch/ftp/mirror/fedora/linux/releases/14/Live/x86_64/Fedora-14-x86_64-Live-Desktop.iso

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers