UNetbootin does not make partition bootable

Bug #493129 reported by Jussi Lehtola on 2009-12-06
38
This bug affects 8 people
Affects Status Importance Assigned to Milestone
UNetbootin
Undecided
Unassigned

Bug Description

Referring to
https://bugzilla.redhat.com/show_bug.cgi?id=544754

UNetbootin does not mark the USB filesystem as bootable, which leads to a non-working boot stick.

lowlux (lowlux) wrote :

this is still not fixed???? how lame!! i downloaded red hat 30 times since and failed every time for years!! this is bullshit!

Geza Kovacs (gezakovacs) wrote :

Whoa, ease up with the language there. I am unable to reproduce the reported issue myself, and the upstream report is too vague for me to make anything of it, hence I cannot fix whatever issue you're having (assuming it's the same as the one in the upstream report). If you could perhaps specify some additional details, ie UNetbootin version, OS you're running UNetbootin from, the particular ISO file you're feeding it, the precise error message you get and where you get it, then perhaps I might be able to help.

dino99 (9d9) on 2011-10-12
Changed in unetbootin:
status: New → Incomplete
Casiopeia (casiopeia) wrote :

I obseverd probably the same problem.

Observerved on unetbootin-windows-563 on Windows 7:
I used unetbootin to put Parted Magic on a USB-Stick.
The process completed without error messages.
However, the stick did not boot.
It turn out, the stick was formated fat32 with MBR, one partition defined. However the partition was not marked aktive.
Marking it active by other means solved the problem.
Note the stick has been in use in the past, but was not used for booting.

Hope that helps.

tikal808 (cmosetick) wrote :

Hello, I'm seeing this same behavior. I just upgraded my version of UNetbootin, thinking that it would make things better, but now it's actually worse, as I'm getting this non-bootable partition error on every machine I try my known-to-be-good USB stick. I've never see this before after two run throughs with UNTebootin.

version:
563-2~lucid2

ISO file:
linuxmint-12-gnome-dvd-64bit.iso

This is most definitely a bug as far as I'm concerned. Please fix asap!

I will speak for the hordes of people that use UNetbootin on a daily basis, thank you so much for this invaluable software!

Geza Kovacs (gezakovacs) wrote :

Hi, could you please try version 565 ( http://unetbootin.sourceforge.net/unetbootin-linux-latest ; haven't put it in my PPA yet ) and see if you're still having the issue of the partition note being marked bootable (just changed the way partitions are marked bootable in that version).

tikal808 (cmosetick) wrote :

Hi, I just reformatted my USB stick and tried version 565 with the same ISO file. Still not booting.

For example, this is what one of the notebook computers I have here says: "This is not a bootable disk. Please insert a bootable floppy and press any key to try again"

As before, Gparted v. 0.5.1 says that the partition is bootable. See attached image.

tikal808 (cmosetick) wrote :

I decided to try a different USB stick, freshly formatted with only one partition. version 565 is working with the Linux Mint ISO now. Perhaps there is an issue with having more than one active partition? I will still have to try the other stick with just one partition.

Einar Petersen (einar-petersen) wrote :

Had precisely same problems creating a Live stick for an Adonis image (BlueCat) from a WIN7 machine - Did the FAT32 full format of the stick then ran UNETBOOTIN as "manager/administrator" on the WIN7 machine - I suspect the latter might have done the trick, but I only tried a quick format earlier, so can't tell for sure what did the trick. The USB was a 32 GB Voyager but have had similar problems creating LiveDisks from Ubuntu as well...

Einar Petersen (einar-petersen) wrote :

The UNETBOOTIN was the latest I could find at this time...

Dominik (domfi) wrote :

I ran in the same problem here.

Here is what I've done:

* Prerequisite: An already used SANDisk U3 Cruzer 16GB (or any other stick laying around!)
* Under Linux: fdisk /dev/sdb -> Primary Partition created, Type W95 FAT32 ("b") (! not marked as active, as this is not required anywhere in your description on unetbootin.sourceforge.net!)
* Under Linux: mkdosfs /dev/sdb1
* Under Mac OS X 10.8: started Unetbootin, Installed Centos 6 from ISO to stick: All went fine!
* Plug it in Computer, try to boot from it -> did not work.
* Plug it in Linux Box, mark partition as bootable (fdisk -> a)
* Replug in Computer, try to boot from it -> Tada! It worked just fine!

If you don't get it to mark the partition as active (should not be THAT hard: it's just a byte/bit on disk, maybe you could get the code from syslinux source. there's an option "-a" for it...), it would be VERY NICE and CUSTOMER-FRIENDLY to -- AT LEAST -- mention this problem (and the obvious solution) on your website in the documentation.

Maybe you can change the "incomplete" status now and start working on the problem. Reading the comments above there are some more who have this problem and it is reproducable at least for me with different kinds of usb sticks. If you need further input please let me know.

It would be nice if such a great software like the unetbootin get this little glitch fixed.

Thank you and kind regards
Dom

Johan Bjäreholt (johanbjare) wrote :

This seriously needs to be fixed.
Have tried for 2hrs to make it bootable with unetbootin, with no success.
Tried with 3 machines (a mac, Linux and win7), and none of them worked.
I ended up with just using dd instead, always works.
Out of the 5 times i have tried unetbootin before, it only worked once (the first time). I regularly try again to see if this gets fixed, but that's not the case.

Please just fix this, I have had this problem for over 2 years.
Luckily i have my good ol' dd at least

Still a problem.

Debian x64 net install, from a mac.

Wasted hours.

Christof (x-chris-i) wrote :

I had this problem too. I formatted my USB stick with the "Disks" utility of Fedora 20. Then I loaded an ISO onto it with unetbootin. When booting from USB I got the error "this is not a bootable disk ...". I solved it by formatting it again with the same utility. This time I deleted the partition and re-created and -formatted it. Then I edited the partition and selected "make partition bootable" (or something like that). After that I could load the ISO on it and it would boot just fine.

Hope this helps someone.

Oliver Joos (oliver-joos) wrote :

Same here! Unetbootin became Uh-not-bootin!

1. I used Unetbootin to overwrite a bootable Mint18.2 stick with a Mint18.3 iso
   => not bootable anymore!
2. I set the "bootable" flag on the one and only partition on this stick
   => still not bootable
3. I formatted the stick and wrote the Mint18.3 iso again
   => not bootable
4. I set the "bootable" flag again
   => finally the sticks boots as expected

It seems necessary to format the stick before using Unetbootin AND to set the "bootable" flag afterwards!

I use Unetbootin 608-1 in a up-to-date Mint 18.2 (based on Ubuntu 16.04 LTS)
I boot the stick in a quite old HP Compaq 8710p (standard non-EFI BIOS)

Andreas (and-he) wrote :

I had the same problem and I would like to share my solution.
First, I use a rather old Wortmann Terra machine with openSUSE 42.3 and Windows 10. The USB stick is a used Intenso Alu Line 8 GB.
I prepare the stick with GParted (1 partition, file system: fat32, flags: boot, type).
Then with UNetbootin (Version 0.0.613-7.1 from the openSUSE 42.3 repository) I write a downloaded iso image of Ubuntu 18.04 to the stick.

When trying to boot from the stick I get the message "This is not a bootable disk. Please insert a bootable floppy and press any key to try again...". The problem is the same if I first write the iso file to the stick and then set the boot flag in GParted.

Solution:
In GParted I set the boot flag and then format the stick with file system ext4 instead of fat32. Then with UNetbootin I write the iso image again to the stick. Now it works!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers