Fails if mount point includes space

Bug #332482 reported by Henning Mersch on 2009-02-21
This bug affects 1 person
Affects Status Importance Assigned to Milestone

Bug Description

My USB Stick was (auto) mounted (by ubuntu) under /media/usb stick (space between usb and stick).
I tried to install via unetbootin the easy peasy iso, which resulted in ONE file at /media/usb stick.
Trying to boot this failed, of cause (sth like "linux kernel not found).
Investigasting this I discovered a newly by unetbootin created folder: /media/usb\40stick.
This contained the ~700MB of data, which should be written to the stick.

After renaming the mountpoint to /media/usbstick (w/o space) and restarting unetbootin, it works as suspected.

System: Amd64, Ubuntu Hardy
Unetbootin: Version linked from Easy Peasy Wiki

Additional suggestion:
Maybe a "--version" cmd option or any menu entry for showing Version would be nice to have

Best regards - Henning

Geza Kovacs (gezakovacs) wrote :

I fixed this bug a couple of versions ago, I just haven't updated the Ubuntu Eee-branded builds in a while so that's why you're having this issue. Try using the latest version from

Henning Mersch (ubuntu-hmersch) wrote :

Ah - ok. Thanks. I tried and it works as it should.

I thought a deb download provided by official tool homepage would be uptodate ;-)

Henning Mersch (ubuntu-hmersch) wrote :

ok, in current versions, d/l official release from

Changed in unetbootin:
status: New → Fix Released
ScottRippon (scott-rippon) wrote :

I have Ubuntu 9.04. I installed UNetbootin using the Add/Remove Applications functionality.
I had this same issue when I tried to burn the OLPC LiveCD ISO ( to my USB flash drive.

The name of my USB flash drive is 'USB DISK'. UNetbootin created and copied all the relevant files to the following folder which I'm having deleting:

drwxr-xr-x 10 root root 4096 2009-06-02 22:15 USB\040DISK

The odd thing is that it looks like it successfully completes the last step by copying the following file into the correct folder (/media/USB DISK/):

-r-x------ 1 username root 14607 2009-06-02 22:15 ldlinux.sys

Changed in unetbootin:
status: Fix Released → Incomplete

Seems to be fixed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers