UNetBootIn should display warning if run by non-Admin Windows user

Bug #325786 reported by Kurt Pfeifle on 2009-02-05
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
UNetbootin
Wishlist
Geza Kovacs

Bug Description

UPDATE: creating a new and better description about the real issue at hand.
(Original bug report kept below....)
------------------------------------------------------------

If a non-Admin Windows user runs unetbootin.exe, everything seems to work OK without a warning. However the resulting USB thumbdrive will not boot, because the syslinux setup will not have created the correct MBR on the stick.

UNetBootIn should:
  * Display a clear warning to the user under such a condition
  * Display a hint how to fix the resulting USB drive a posteriori (if possible)

(below is my original bug report)
_____________________________________________________

Original Summary: "USB Sticks created on Win XP without Administrator Privileges don't boot"
----------------------------------------------------------------------------------

I'm trying to create bootable USB thumbdrives from locally downloaded Live CD ISO image files with the help of unetbootin:

   * _Creating_ the bootable sticks with unetbootin.exe (v. 312) on Windows XP Prof...

   * ...and try to _use_ them to boot up on my personal notebook that has a b0rken harddrive.

unetbootin versions:
   unetbootin-windows-312.exe, unetbootin-windows-310.exe
Windows version:
   Win XP Prof SP2
Windows user:
   common user lacking admin privs
USB stick vendors:
   Kingston, Corsair, Samsung, OCZ
USB stick sizes:
   2 GB, 4 GB, 8 GB
ISO images:
   Fedora, openSUSE, Ubuntu, Kubuntu (various releases of each)

My Win XP system itself is locked down: it does not allow to boot from CD or from USB. And as mentioned above, it also I _don't_ have Adminstrator privileges here (I seem to remember that somewhere in the wiki is said that one _does_ needs those, but I'm not sure any more... [?]).

But this Win XP is the only working computer I currently have access to, so I didn't have much choice.

Starting and running unetbootin.exe from my non-privileged Win XP account does work, and it does not indicate any error. It also seems to write _all_ the required files onto the USB stick.

When I try to boot from the newly written USB stick on my harddisk-challenged notebook (it is a HP "compaq nx5000"), I am able to select from boot menu:
* USB Hard Disk
* Notebook MultiBay
* Notebook hard drive

Booting the USB Hard Disk however always displays an error message.

I tried different approaches:

* pre-formatting the USB stick with FAT32 (or VFAT), from a running Live CD on b0rken
  HP notebook, then using that stick on Win XP with unetbootin.exe

* pre-formatting the USB stick with FAT16, from a running Live CD on b0rken HP
  notebook, then using that stick on Win XP with unetbootin.exe

* deleting all partitions on USB stick, from a running Live CD on b0rken HP notebook,
  then using that stick on Win XP with unetbootin.exe

* using a newly-bought "virgin" USB stick (where the Live CD reports it as a FAT16
  medium) on Win XP with unetbootin.exe

These are the error messages I do get:

FAT32 or VFAT formatted stick:
   "This is not a bootable disk. Please insert a bootable disk. Please insert a
     bootable floppy and press any key to try again..."

FAT16 formatted stick:
   "Missing operating system"

Note: The b0rken notebook still _does_ boot from Live CD as well as from (older) USB sticks that I have created manually 1 year ago. It's just that unetbootin.exe-created sticks don't work on it.

Please, if it is all my own mistake, because I'm trying to do it as a non-Admin user, then change the summary of this bug report and make it read: "Running unetbootin on Win XP as a non-Admin user should give a warning to user and refuse to work"

Kurt Pfeifle (pfeifle) on 2009-02-05
description: updated
description: updated
description: updated
Kurt Pfeifle (pfeifle) on 2009-02-05
description: updated
description: updated
description: updated

Windows user:
   common user lacking admin privs

That's the issue. You can't directly write to the boot sector of your USB drive (which UNetbootin needs to do to install the syslinux bootloader to the USB drive, ie make it bootable) without administrator privileges, thus this isn't a solvable problem due to the operating system's security model.

However you said you were able to "pre-format the USB stick from a running Live CD" so you can try running UNetbootin from within the live CD environment on your notebook because in that case you do have the necessary administrator priviledges via sudo.

Changed in unetbootin:
assignee: nobody → gezakovacs
importance: Undecided → Wishlist
status: New → Won't Fix
Kurt Pfeifle (pfeifle) on 2009-02-05
description: updated
Geza Kovacs (gezakovacs) wrote :

"Running unetbootin on Win XP as a non-Admin user should give a warning to user and refuse to work"

Whoops missed that last paragraph, unfortunately I can't edit the description anymore since I replied to it. I suppose this is valid then, however I probably won't be able to fix it immediately without breaking things because the notion of "Administrator" and associated privileges have changed with each version of Windows - also I 'm not really a fan of making applications "refuse to work" but rather I prefer to just give warnings. This already happens in Windows Vista via UAC but apparently it doesn't work with older Windows versions.

Changed in unetbootin:
status: Won't Fix → Confirmed
Kurt Pfeifle (pfeifle) wrote :

Thanks, Geza, for your very quick response and feedback.

If that indeed is the issue, that's still a point for unetbootin to improve: discover the non-admin condition, display a clear warning to the user and (maybe) even refuse to run.

The problem with my current Live CDs is, that they're rather old, and I may not be able to install unetbootin into them. It's even more complicated: my locked-down WinXP doesn't let me use the (working) builtin CD burner. My b0rken HP notebook not only has a b0rken harddisk, but also a b0rken CD writer, and it is not allowed to connect the company network and access the internet through the company firewall.

Geza,
have you got any idea, if I could fix the crippled USB sticks created on Win XP a posteriori by running some magic isolinux commands from a Live CD environment?

(P.S.: I'll create a new bug which better describes the real issue at hand...)

Kurt Pfeifle (pfeifle) wrote :

Heh,

you added your second comment while I wrote mine. :-)

OK, refusing to work may not be the best option. But giving a clear warning would be very useful. Maybe even add some advice about how to fix the crippled stick a posteriori (if that is possible)?

Cheers,
and thanks for your incredible work on UNetBootIn!
Kurt

Kurt Pfeifle (pfeifle) on 2009-02-05
description: updated
description: updated
Geza Kovacs (gezakovacs) wrote :

"have you got any idea, if I could fix the crippled USB sticks created on Win XP a posteriori by running some magic isolinux commands from a Live CD environment?"

You didn't mention the type of Live CD, I'm assuming Ubuntu for the time being.

sudo apt-get install syslinux
sudo syslinux /dev/sdb1

(assuming /dev/sdb1 is the USB drive's FAT32 partition, you should be able to determine that from your partitioning tool when you formatted the disk)

Kurt Pfeifle (pfeifle) on 2009-02-05
description: updated
description: updated
Geza Kovacs (gezakovacs) wrote :

Sorry, those instructions weren't quite all that's needed, you'll really probably need:

sudo apt-get install syslinux
sudo syslinux /dev/sdb1
sudo dd if=/usr/lib/syslinux/mbr.bin of=/dev/sdb

(and yes that's supposed to be sdb not sdb1 since it's the disk itself not the partition). If that doesn't work just google for the more complete instructions.

And yes I do understand that a warning should be raised on Windows XP and older, I just don't have access to anything older than Vista right now so I can't actually fix it and test it just yet.

Kurt Pfeifle (pfeifle) wrote :

Thanks again, Geza,

I appreciate your prompt response very much. I'll go over to a friend later tonight where I can try these commands....

Just to be sure:
  * the second command ("sudo syslinux") does reference partition no. 1 (sdb1),
  * while the third one ("sudo dd") does reference the disk itself (sdb)?

Cheers,
Kurt

Kurt Pfeifle (pfeifle) on 2009-02-06
description: updated
Jason Winnebeck (jpwasp) wrote :

I got bit by this one. I know that as a normal user I can't format the USB drive, so I assume a normal user can't install bootloader or partition a drive, but the program said it worked so I trusted it and thought I was setting BIOS up wrong. What's lame about this bug is that when you run the program it actually gives an explicit "success" indication, rather than an indication of failure. I read the whole front page including the FAQ and also the "how it works" looking to see if it needs admin privileges and it didn't say so, so I thought maybe Unetbootin was way smarter than me and figured out how to do it. On a whim I still guess non-admin was the problem, searched and found this bug.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers