ubuntu 8.04 64bit server image fails

Bug #237867 reported by Sven Sternberger on 2008-06-06
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
UNetbootin
Undecided
Unassigned
debian-installer
Invalid
Undecided
Unassigned

Bug Description

Hello!

this is probably not a bug maybe a feature request ;-)

I tried to install Ubuntu Server 64 bit with an USB stick
prepeared from the vanilla 64bit Server CDROM Image.,
"Universal Netboot Installer" 2.16 . The preperation runs
without problems. The sticks boot, but then ubuntu complains
about the missing cdrom. So I created the folder "/cdrom"
and mounted the stick.

Then I tried to install further without "cdrom detection",
but it fails because the next step tried to read the
file
"/cdrom/dists/stable/Release" (this file is empty, maybe a symbolic link?)
which is not there I think the script try to access
"/cdrom/dists/hardy/Release"

But even if this not worked today for me, great tool, nice gui,
keep on hackin'

best regards!

sven

Seth Ellsworth (setharoth) wrote :

I have the same issue.

To start it failed due to not mounting the files ( no cdrom ), and I fixed the same way, manually mounted the files.

Then I ran across this issue, I would assume either the ISO or the interpretation of the iso is breaking a symbolic link.

I ended up copying hardy over to get past that. ( rm stable; cp -r hardy stable ).

Then I had yet another issue, file names were truncated at 64 characters.

For example:
./pool/main/l/linux/fs-secondary-modules-2.6.24-19-generic-di_2.6.24-19.34_amd64.udeb

Ends up as
./pool/main/l/linux/fs-secondary-modules-2.6.24-19-generic-di_2.6.24-19.34_amd64.ude

And is thus not found.

 If I daemontools mount the ISO, it also shows the file names as truncated, and the stable as an empty file instead of a link.

But if I burn the same image, and put the disk in a freeBsd machine I have handy, mount it; its links and un-truncated file names.

So maybe something in the Windows ( Vista 64-bit for me ) side of things it making unetbootin read the files incorrect, and place them that way?

I had the same problem.

I solved this by also copying the .iso file to the usb-stick and then loop-mounting this file at the /cdrom mountpoint (I had to manually insmod the loop module).

Paul Tan (paulctan) wrote :

I can confirm that is bug is still a problem today.

My workaround is to use the mini.iso installation image

https://help.ubuntu.com/community/Installation/MinimalCD

dn (nobled) wrote :

This seems more like a debian-installer bug, since d-i is assuming that the installation media is still a CD when, thanks to UNetbootin, it's not anymore.

Still a problem with Ubuntu 8.10 Alternate iso.

Colin Watson (cjwatson) wrote :

Firstly, bugs on the Ubuntu installer belong on the debian-installer source package in Ubuntu, not on the debian-installer upstream project.

Secondly, as of Ubuntu 8.10, unetbootin should be changed to pass cdrom-detect/try-usb=true as a kernel command line option if it wants the installer to try to probe USB devices. (Sorry, this won't work with 8.04.) See bug 234185.

Changed in debian-installer:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers