GPS gets denied by operating system while in use

Bug #1850167 reported by Michael Rupp on 2019-10-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
uNav
Undecided
Unassigned

Bug Description

I'm not sure there is a clear pattern to this, but here are the details I have so far:

I'm using a Nexus 5 hammerhead D820(E) 32GB. I've only had the UBporst on it for 8 days now so it's the latest version. I had been experimenting with various map and GPS using apps before having a SIM card, and the uNav app had similar results before and after the insertion of a SIM card. The SIM is a Google FI type, but a data only one instead of one with a ported phone number. I wasn't sure that the Google FI card would work so I didn't bother to port a phone from cheap VoIP accounts to a monthly bill. The card works and gets a good 4G signal.

I read somewhere while goofing around with the phone that only the active app gets access to the GPS, so I have been careful to only have one app stay on the screen when trying to use it for GPS related things.

During mapping use, I will experience my shown position remain stationary despite me resuming motion. I don't have a solid repeatable pattern yet, but it stands out in my mind that twice while sitting for a long time at a traffic control light, the stuck position occurred. I don't know how to do screen grabs with it yet, so I don't have the exact error message that gets thrown when interacting with uNav after it's stuck, but it is something like uNav was denied access to GPS. Looking at the permitted apps shows it has been granted access. Closing and re-opening the app doesn't regain access to GPS. Restarting the phone does restore access.

I would like to think that it's the OS that is the problem. Before the SIM card, I experienced the loss of access when using the speedometer app, and when using the Activity Tracker app. The day after putting the OS on the device, I was fast switching between the speedometer app and the Activity Tracker app while driving and each app worked great when it was the foreground app, then at one point both stopped working but the speedometer registered over 10 MPH while I was motionless and Activity Tracker had me motionless where I assume the GPS first got denied.

How can I get data from the device that will be helpful to determine if my old Nexus 7 has a physical problem with its hardware, or the OS is at fault, or the apps need updating?

BTW: this mapping app is making me VERY happy. I use Google Maps and Waze but think I can quit them now. Your app found a better route for a recent local drive than neither of those two apps as well as the old mapquest based in-dash navigation for my old Chevy Volt. I tried some things with the offline map instructions, but it didn't work out so far (images downloaded but had no maps), but I'm in Western New York State USA, so that may be why.

Revision history for this message
costales (costales) wrote : Re: [Bug 1850167] [NEW] GPS gets denied by operating system while in use

Hi Michael,
Yes, the OS will improve in the next releases the GPS and AGPS.
Now, I would recommend you to reboot the phone before to use a GPS app.
You should use this app for check your phone is working fine with GPS:
https://open-store.io/app/sensorsstatus.chrisclime
If it's your first run, leave the phone 1hour near to a window for getting
a 1st pos and confirm it is working.
A hug!
--
Costales.

Revision history for this message
Michael Rupp (wnymathguy-1) wrote :

The sensorstatus app is showing the GPS works sufficiently well. I seem to be getting 10-meter accuracy when near a window but indoors.

The accelerometer seems tweaky, but I don't know if that's normal for it to have white noise looking variations in the decimal portion of the x,y,z values. I figured out what the 9 m/s/s was after a short while; Physics.

Revision history for this message
costales (costales) wrote :

The accuracy of GPS should be centimeters, when the device is near to a window.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers