Car routing stopped working

Bug #1809915 reported by MaTiZ on 2018-12-27
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
uNav
Medium
costales

Bug Description

Currently unav is not able to find a route for cars. For bike and pedestrian it still works. I am using unav on a MX4 running ubuntu 16.04 OTA-6.

Changed in unav:
status: New → Confirmed
Pavel Zlámal (zlamal-pavel) wrote :

I can confirm this, but for me it does only when "Avoid tolls" is enabled. If I disable it, route is found OK for cars too.

MaTiZ (mdehollander) wrote :

Indeed, with 'avoid tolls' disabled car routing works. Think i got it accidently enabled.

MaTiZ (mdehollander) wrote :

Thanks for pointing out the solution. The avoid tolls routing is still a bug i guess.

Hi,

I think to remember Avoid Tolls doesn't work with the current API.
I'll review and remove that option.

Thanks for the bug!
--
Costales.

Pavel Zlámal (zlamal-pavel) wrote :

Hi Costales,

I managed to fix this bug, but when I build the app by myself, it never picks the GPS correctly and I'm somewhere 1000 km away from my location. It's because your specific release script replaces API tokens for the online services? Or does it perform any more changes to the code? I sometimes see comments like "/** TESTING BEGIN **/" and corresponding ending tag". I didn't get into the code much yet.

Anyway, solution is to remove wrong options header in "WebAPI.js" on lines 62 and 151 and replace it with just required feature like this: '{"avoid_features":"tollways"}'.

And for this "feature" there seem to be a limitation of max. 300km long road on the server side. But I'm not sure, if its general limitation or it relates to the used API tokens in devel code. Generally API returns error with message and specific code, maybe uNav could show the message instead of just "Not found" when looking for the road. Similar to the warning when user is planning more than 1000km long trip.

Thanks for the great app.

Pavel

costales (costales) wrote :

@Pavel: Yes, I convert the code to my APIs. This is not so simple as remove that option, I have to remove from all the branch.

costales (costales) wrote :

Hi,

Please, could you test this installer before to release it in the Store?

https://launchpad.net/unav/trunk/2.3/+download/navigator.costales_2.3_all.click

Thanks in advance!

Pavel Zlámal (zlamal-pavel) wrote :

Hi @costales,

I'll try it on my way home today and let you know.

Pavel Zlámal (zlamal-pavel) wrote :

Hi Costales,

I can confirm, that new version finds the route and pick GPS correctly. Option to avoid tolls is not present.

Pavel

costales (costales) wrote :

Thanks a lot for the confirmation.
The version was released in the Store :)
A hug.

Changed in unav:
status: Confirmed → Fix Released
assignee: nobody → costales (costales)
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers