Meizu MX4 crashes every time when uNav asks for location access

Bug #1708806 reported by Melanie on 2017-08-05
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
uNav
Undecided
Unassigned

Bug Description

After I went to Ubports and installed Unav I haven't been able to set up my location. When I hit the green butten "allow uNav access to location" my phone (Meizu Mx4) shuts down. After restart there is still no location possible.
Other Apps like OSM scout or Google Maps can get access to location.

Melanie (m-bauert) on 2017-08-05
description: updated
Melanie (m-bauert) on 2017-08-05
description: updated
costales (costales) wrote :

Hi Melanie,

Are you device update? Appears you are not in the last version. uNav can't do the device reboot.

If you are in the last version, can you try to remove cache & configuration of uNav? From the Terminal app copy and paste these commands:

rm -r ./.cache/navigator.costales
rm -r ./.config/navigator.costales
rm -r ./.local/share/navigator.costales

Best regards.

costales (costales) wrote :

Important info: those commands will remove your uNav's favorites and history ;)

Melanie (m-bauert) wrote :

The Meizu Mx4 is with Ubports on the list for "legacy devices". My current version is 15.04(r1), I flashed my phone 4 days ago.
Well, the device rebooted automatically after crashing though.
I had already removed the "navigator.costales" folder and uninstalled the app. After installing it freshly it didn't work first - there still was the old problem. Surprisingly (after about 4-5 attempts with crashing and rebooting) it suddenly worked and still does fine now. It was the same with your bike road app.
Nevertheless many thanks for your help!

Uhm,
One question, were you tried connected to WIFI? I saw an older bug where de
location hasn't real access if the phone was connected to WIFI.
I'm glad it is working again for you! Enjoy it! :)
Best regards and thanks for your feedback.
Costales.

Melanie (m-bauert) wrote :

Yes, I was connected to Wifi. But I don't remember if I was disconnected in between...

Melanie (m-bauert) wrote :

I don't know if you have a solution for "Here (we go") maps: In this case there is no location access possible, whatever I try. I assume that the Ubuntu Phone browser is the problem. "Here" maybe requires the Chrome browser. Have you heard anything about this?
Sorry for bothering but I found no other place to report that bug...

costales (costales) wrote :

I do not understand the question... what is here? :)

Melanie (m-bauert) wrote :

I mean this app: https://open.uappexplorer.com/app/herebasic.mdzs
it is also for navigation.

costales (costales) wrote :

Hi,
I don't know, HERE app worked in the past, but I didn't try anymore.
If you are with WIFI, try without WIFI.
And check the GPS settings, maybe you have them blocked (?).
Best regards.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers