gdm won't start

Bug #805744 reported by Davide Alberelli on 2011-07-05
54
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Mythbuntu
Won't Fix
Undecided
Unassigned
ugr-seeds
High
Unassigned

Bug Description

After last updates i get these:

[ 24.974182] gdm-simple-slav[1009]: segfault at 0 ip 002945b7 sp bfe9b6c8 error 4 in libnss_compat-2.13.so[291000+6000]
[ 38.598946] gdm-simple-slav[1218]: segfault at 0 ip 00a3b5b7 sp bf9c35c8 error 4 in libnss_compat-2.13.so[a38000+6000]
[ 39.562834] gdm-simple-slav[1238]: segfault at 0 ip 005eb5b7 sp bff72138 error 4 in libnss_compat-2.13.so[5e8000+6000]

and, obviously, no way to get the machine working.
The unique way is to Ctrl+Alt+F1 and then login and then startx, but also with this way there's no way to have the shell, just gnome2-style panels.

Kimmo Tuhkanen (kimmo-tuhkanen) wrote :

I'm having the same problem.

Martin Pulec (martin-pulec) wrote :

I have the same problem and it is in 3.0.4-0ubuntu3~natty1 GDM package (which I have from gnome3-ppa), previous (3.0.4-0ubuntu1...) was also buggy. Last working version is 3.0.2-0ubuntu1~build1 for me (at least from the packages which are still downloadable - from gnome3-ppa archive) - which I recommend to downgrade to (temporarily).

Martin Pulec (martin-pulec) wrote :

I marked this bug as duplicate of #801464 which is similar to this I guess.

Jordon Bedwell (envygeeks) wrote :

These bugs are not similar. This bug involves libc6 the other bug GLX from indications.

Changed in ugr-meta:
status: New → Confirmed
Martin Pulec (martin-pulec) wrote :

> These bugs are not similar. This bug involves libc6 the other bug GLX from indications.
Well OK, but the main thing about the other bug is that GDM doesn't start. And my opinion is that it is exactly from same reason as described in this bug. The another issues described there are rather caused by the fact, that gnome-shell isn't started from GDM but from xterm (or so). But I can be wrong:)

JC Hulce (soaringsky) wrote :

@Davide, @Martin, others: Can you confirm that this issue still exists with the latest updates? You can use the 'recovery console' session option to do updates if you cannot get into GNOME. I still have not been able to replicate this issue.

Be aware that if you have any shell extensions installed and the GNOME shell is updated, crashes WILL occur. Shell extensions will only work with the shell version that they were compiled on; they will almost always crash the shell if a different version is used.
To remove any shell extensions, run the following command in the 'recovery console' session:
rm -r .local/share/gnome-shell/extensions/*

Everyone affected by this issue, please run the updates and commands specified above (even if you do not think you have extensions installed) and report the results.

Changed in ugr-meta:
status: Confirmed → Incomplete
importance: Undecided → Critical
importance: Critical → Undecided
importance: Undecided → High
Martin Pulec (martin-pulec) wrote :

@JC Hulce:
Great, it seems like the issue is no longer present with current updates for me. I just installed the GDM version (3.0.4-0ubuntu3~natty1) which caused the problems before (and I have it held back) but now it is without problems.

tigermick (tigermickrs) wrote :

Hi!
i have the last GDM version (3.0.4-0ubuntu3~natty1) and it doesn't work for me...

tigermick (tigermickrs) wrote :

excuse me...
when I type dmesg command in terminal, i have this thing :
[ 131.283048] gdm-simple-slav[2149]: segfault at 0 ip 002cb5b7 sp bfdc97f8 error 4 in libnss_compat-2.13.so[2c8000+6000]

thank your for yours replies

JC Hulce (soaringsky) wrote :

@ tigetmick that appears to be the same issue, but I am confused as to why you still have it.
Please run the following commands and post the output:
sudo add-apt-repository ppa:gnome3-team/gnome3
sudo add-apt-repository ppa:ubuntugnometeam/ppa-gen
sudo apt-get update
sudo apt-get install ugr-desktop
sudo apt-get dist-upgrade

Lars Düsing (lars.duesing) wrote :

This bug is occuring here too, but not using ugr-desktop. I use mythbuntu.

Aug 16 14:03:25 rechner-kids kernel: [ 18.866268] gdm-simple-slav[904]: segfault at 0 ip 004a280e sp bfd13aa0 error 4 in libnss_compat-2.13.so[49f000+8000]

above steps (except install ugr-desktop!) won't do anything, except warnings about illegal gpg-key-ids.

Maybe we should try LightDM instead, just to see if stuff will work? It could be that ubuntu code is switching, and we're using some stable and some dev code, and compatibility for GDM is removed and replaced with LightDM compatibility. Just a guess...

Hi guys,

ran into this issue after setting up autologin. Deleted "/etc/gdm/custom.conf" and after everything ran fine again. Though no autologin ....

MB

Don't use autologin. Also, try updating everything.

Try logging in with a recovery console, then running 'sudo apt-get update'. That might fix it!

Brendan Cully (bcully) wrote :

just upgraded my mythbuntu to oneiric, and I've been struck by this bug. I'm also autologging in -- the WAF depends on it. Is there any way to get autologin working again?

Launchpad Janitor (janitor) wrote :

[Expired for ugr-meta because there has been no activity for 60 days.]

Changed in ugr-meta:
status: Incomplete → Expired
Tchalvak (tchalvak) on 2012-04-13
Changed in ugr-seeds:
status: Expired → Confirmed

I can confirm this on Ubuntu 11.10, running gnome-shell, lightdm removed and gdm installed. As soon as you select "Auto login" for your user, this segfault occurs.

>Log into recovery mode from bootloader, then choose root shell, and write

apt-get remove gdm
apt-get install gdm

On Fri, Apr 13, 2012 at 4:42 PM, Tchalvak <email address hidden> wrote:

> ** Changed in: ugr-seeds
> Status: Expired => Confirmed
>
> --
> You received this bug notification because you are a member of Ubuntu
> GNOME Remix: Testing Team, which is subscribed to UGR (Ubuntu Gnome
> Remix) Project.
> https://bugs.launchpad.net/bugs/805744
>
> Title:
> gdm won't start
>
> Status in Ubuntu Gnome Remix Seeds:
> Confirmed
>
> Bug description:
> After last updates i get these:
>
> [ 24.974182] gdm-simple-slav[1009]: segfault at 0 ip 002945b7 sp
> bfe9b6c8 error 4 in libnss_compat-2.13.so[291000+6000]
> [ 38.598946] gdm-simple-slav[1218]: segfault at 0 ip 00a3b5b7 sp
> bf9c35c8 error 4 in libnss_compat-2.13.so[a38000+6000]
> [ 39.562834] gdm-simple-slav[1238]: segfault at 0 ip 005eb5b7 sp
> bff72138 error 4 in libnss_compat-2.13.so[5e8000+6000]
>
>
> and, obviously, no way to get the machine working.
> The unique way is to Ctrl+Alt+F1 and then login and then startx, but also
> with this way there's no way to have the shell, just gnome2-style panels.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ugr-seeds/+bug/805744/+subscriptions
>
> --
> Mailing list: https://launchpad.net/~ugr-testing
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~ugr-testing
> More help : https://help.launchpad.net/ListHelp
>

--
*Nadeen Spirit
Computer science student*

Karl Dietz (dekarl) wrote :

I just updated a Mythbuntu installation from 11.04 via 11.10 to 12.04 and hit this issue, too:
May 27 12:41:26 mythmaster kernel: [ 1850.766321] gdm-simple-slav[5190]: segfault at 0 ip 00007ff5a4fc6fe5 sp 00007ffff7fc0570 error 4 in libnss_compat-2.15.so[7ff5a4fc3000+8000]

disabling autologin in /etc/gdm/custom.conf, as suggested in comment #13, lets me start gdm again. Obviously without autologin which significantly lowers the WAF
AutomaticLoginEnable=true

ndde (jannis-upb) wrote :

Same problem for me at ubuntu precise:

dmesg:
[ 2615.057625] gdm-simple-slav[2027]: segfault at 0 ip 0050469e sp bf9934b0 error 4 in libnss_compat-2.15.so[501000+7000]

Disabling autologin in /etc/gdm/custom.conf lets gdm start again.

ndde (jannis-upb) wrote :

One more thing. Yesterday I installed kubuntu-desktop. I bet, today is the first time since then that I restarted the system. Perhaps this helps to isolate the problem.

cncook001 (cncook001) wrote :

This may be related to bug 805154.

When gdm (3.0.4-0ubuntu16) gets released for precise it may fix this bug.

Mario Limonciello (superm1) wrote :

At least for mythbuntu we're not going to work to fix this. We switched to lightdm.

Changed in mythbuntu:
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers