Adwaita (default) GTK theme missing

Bug #759021 reported by meros
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ugr-seeds
Fix Released
Medium
Unassigned

Bug Description

The gtk part of the adwaita theme seems to be missing or broken. I get this:

.xsession-errors:(gnome-terminal:5582): Gtk-WARNING **: Could not load named theme "Adwaita": Error parsing stylesheet

And the windows have the ugly default GTK appearance.

Revision history for this message
meros (alexander-schrab) wrote :

Oh, application that run under root (sudo or otherwise) seems to work. So it might not be completely missing.

Revision history for this message
David Walker (downwardspindle) wrote :

Yup, I can confirm this. Your 'only under root' clue tipped me off at what the problem was. It seems the images located at /usr/share/themes/Adwaita/Gtk-3.0/assets all don't have read permissions for group or user. A quick 'chmod 644 *' did the trick and fixed everything. I'm guessing the package gnome-themes-standard was the culprit.

Revision history for this message
JC Hulce (soaringsky) wrote :

I'm putting the latest GNOME3 packages in the PPA in a few hours. Let's see what that does.

Changed in ugr-ebuild:
status: New → Incomplete
status: Incomplete → Confirmed
importance: Undecided → Medium
Revision history for this message
Chris Gummin (proxy-qtz-deactivatedaccount) wrote :

This bug has been fixed in Cosmic. I'm closing this bug.

Changed in ugr-ebuild:
status: Confirmed → Fix Released
JC Hulce (soaringsky)
affects: ugr-ebuild → ugr-meta
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Related questions