Ubuntu GNOME Remix image don't boot on EFI systems

Bug #1069908 reported by Everaldo Canuto on 2012-10-22
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu GNOME Remix
Undecided
Unassigned

Bug Description

On EFI systems, the Ubuntu GNOME Remix image don't boot and we get this error message:

    error: file `/casper/vmlinux.efi.signed` not found.
    error: you need to load the kernel first.

Also, looks like we miss some genisoimage parameters that will cause boot to fail at all on some EFI systems.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: grub-efi 2.00-7ubuntu11
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.6.1-0ubuntu3
Architecture: amd64
Date: Mon Oct 22 14:36:21 2012
InstallationMedia: Ubuntu GNOME Remix 12.10 "Quantal Quetzal" - Alpha amd64(20120902)
ProcEnviron:
 LANGUAGE=en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: grub2
UpgradeStatus: No upgrade log present (probably fresh install)

Everaldo Canuto (ecanuto) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in grub2 (Ubuntu):
status: New → Confirmed
Everaldo Canuto (ecanuto) wrote :

This is supposed to fix the first issue but after make a clean image:

http://bazaar.launchpad.net/~ubuntu-gnome-dev/+junk/iso-build-script/revision/28

But we miss the vmlinuz.efi.signed at casper folder, this is fixed on:

http://bazaar.launchpad.net/~ecanuto/+junk/iso-build-lp1069908/revision/30

It is the approach used by Ubuntu Release image, on daily images EFI secure boot stuff is not included, also for Kubuntu (release image) this secure boot stuff is also not included.

Everaldo Canuto (ecanuto) wrote :

Also, we need to apply this patch even if we are not going to have secure boot stuff:

    http://bazaar.launchpad.net/~darkxst/junk/iso-build-efi/revision/29

Everaldo Canuto (ecanuto) wrote :

Just checked now and the other flavors of Ubuntu (Kubuntu, Xubunu and Lubuntu) don't include secure boot stuff.

Are we going to follow Ubuntu or other flavors?

Everaldo Canuto (ecanuto) wrote :

 cjwatson just sugest us to make sure have installed grub-efi-amd64-signed and shim-signed as well.

Everaldo Canuto (ecanuto) wrote :

From IRC:

cjwatson> although probably better to include the signed kernel for the sake of the SB machines that get confused without it

Tim Lunn (darkxst) wrote :

I think we should keep secureboot, as per cjwatsons comments...

Looks like we should be right, just need to build iwth -updates enable to ensure we get the updated ubiquity >= 2.12.15, which is an absolute requirement for secureboot installations.

Tim Lunn (darkxst) on 2012-10-23
affects: grub2 (Ubuntu) → ugr-iso-build
Everaldo Canuto (ecanuto) wrote :

I think we are ready to go with:

https://code.launchpad.net/~ecanuto/+junk/iso-build-lp1069908

Keeping secure boot.

Tim Lunn (darkxst) wrote :

I am getting evolution-data-server copied into -updates. so wait for that

Stéphane Graber (stgraber) wrote :

FWIW edubuntu shipped with secureboot support. It was up to the various flavours to seed the right kernel and grub packages to get secureboot support. However it would cause a ~15MB extra disk usage which wasn't possible for some flavours.

Jeremy Bicha (jbicha) wrote :

Ok, we already have comment #6 since we start with the Ubuntu image as a wrapper, create our own squashfs, tweak a few things in the wrapper (isolinux theme, identifying as Ubuntu GNOME, etc.), and then just build the ISO from all of that. Those two packages are already included in pool/ .

I've merged everaldo's branch and am rebuilding the image now.

Jeremy Bicha (jbicha) wrote :

Ubuntu GNOME Remix 12.10.1 is now available for amd64 with this fixed. Generally speaking, EFI is only supported on amd64.

Changed in ugr-iso-build:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers