ufw

Network printer is not automatically detected in Natty due to UFW firewall

Bug #764933 reported by typo on 2011-04-18
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ufw
Undecided
Jamie Strandboge
system-config-printer (Ubuntu)
Undecided
Unassigned
ufw (Ubuntu)
Low
Jamie Strandboge

Bug Description

Binary package hint: system-config-printer

My HP Photosmart Premium printer is not automatically detected by system-config-printer in Ubuntu 11.04 natty. I have to manually enter either the hostname or the ip adress. This seems to be an regression.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: system-config-printer-gnome 1.3.1+20110222-0ubuntu15
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic-pae 2.6.38.2
Uname: Linux 2.6.38-8-generic-pae i686
Architecture: i386
CupsErrorLog:

Date: Mon Apr 18 19:39:59 2011
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release i386 (20100816.1)
Lpstat: Error: command ['lpstat', '-v'] failed with exit code 1: lpstat: No destinations added.
MachineType: NVIDIA MCP7A
PackageArchitecture: all
Papersize: a4
ProcEnviron:
 LANGUAGE=de:en
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic-pae root=UUID=7a48959a-cb49-4501-a84f-d96ff1dd573c ro quiet splash vt.handoff=7
SourcePackage: system-config-printer
UpgradeStatus: Upgraded to natty on 2011-04-17 (1 days ago)
dmi.bios.date: 06/02/2009
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: 6.00 PG
dmi.board.name: MCP7A
dmi.board.vendor: NVIDIA
dmi.board.version: 2
dmi.chassis.type: 3
dmi.chassis.vendor: NVIDIA
dmi.chassis.version: MCP7A
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr6.00PG:bd06/02/2009:svnNVIDIA:pnMCP7A:pvr2:rvnNVIDIA:rnMCP7A:rvr2:cvnNVIDIA:ct3:cvrMCP7A:
dmi.product.name: MCP7A
dmi.product.version: 2
dmi.sys.vendor: NVIDIA

typo (gnomeuser8) wrote :
Till Kamppeter (till-kamppeter) wrote :

Can you run the following commands in a terminal window and post their output (if a command does not exit, press Ctrl+C):

ifconfig
lpinfo -v
/usr/lib/cups/backend/snmp
sudo /usr/lib/cups/backend/dnssd
/usr/lib/cups/backend/snmp <IP of your printer>
hp-probe -bnet -mmdns
hp-probe -bnet -mslp
hp-makeuri <IP of your printer>

Does the web configuration interface of the printer appear if you enter its IP in the URL field of a browser?

Changed in system-config-printer (Ubuntu):
status: New → Incomplete
typo (gnomeuser8) wrote :
Download full text (4.5 KiB)

$ ifconfig
eth0 Link encap:Ethernet Hardware Adresse 00:01:2e:27:44:73
          inet Adresse:192.168.2.112 Bcast:192.168.2.255 Maske:255.255.255.0
          inet6-Adresse: fe80::201:2eff:fe27:4473/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metrik:1
          RX packets:153607 errors:0 dropped:0 overruns:0 frame:0
          TX packets:95935 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:1000
          RX bytes:166730189 (166.7 MB) TX bytes:56581634 (56.5 MB)
          Interrupt:22 Basisadresse:0x8000

eth1 Link encap:Ethernet Hardware Adresse 00:12:7b:49:80:84
          inet6-Adresse: fe80::212:7bff:fe49:8084/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST MULTICAST MTU:1500 Metrik:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:222 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:1000
          RX bytes:0 (0.0 B) TX bytes:10628 (10.6 KB)

lo Link encap:Lokale Schleife
          inet Adresse:127.0.0.1 Maske:255.0.0.0
          inet6-Adresse: ::1/128 Gültigkeitsbereich:Maschine
          UP LOOPBACK RUNNING MTU:16436 Metrik:1
          RX packets:5464 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5464 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:0
          RX bytes:429382 (429.3 KB) TX bytes:429382 (429.3 KB)

$ lpinfo -v
network ipp
network socket
network http
network lpd
direct scsi
network beh
direct hp
network smb
serial serial:/dev/ttyS0?baud=115200

direct hpfax

$ /usr/lib/cups/backend/snmp
 [no output]

$ sudo /usr/lib/cups/backend/dnssd
[Ctrl + C to exit]

$ /usr/lib/cups/backend/snmp 192.168.2.109
network socket://192.168.2.109:9100 "HP Photosmart Prem C410 series" "Photosmart C410b" "MFG:HP;MDL:Photosmart Prem C410 series;CMD:MLC,PCL,DW-PCL,PML,802.11,802.3,DESKJET,DYN;1284.4DL:4d,4e,1;CLS:PRINTER;DES:CQ521B;CID:HPIJVIPAV2;SN:CN09LD108505KV;S:038088C484001021006a0c8000053d4001e45d0005a44d0005046d0005a41d00064;Z:0102,0500000900000100000100000100000100000b,0600,07000000000000000000000000,0b000000000000000000000000000000000000000000000000000000000000000000000000,0c0,0e000000000000000000000000,0f000000000000000000000000,10000002000008000008000008000008000008,110,12000,150,17000000000025000" ""

$ hp-probe -bnet -mmdns

HP Linux Imaging and Printing System (ver. 3.11.1)
Printer Discovery Utility ver. 4.1

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

--------------------
| DEVICE DISCOVERY |
--------------------

Probing network for printers. Please wait, this will take approx. 10 seconds...

warning: No devices found on the 'net' bus. If this isn't the result you are expecting,
warning: check your network connections and make sure your internet
warning: firewall software is disabled.

Done.

$ hp-probe -bnet -mslp

HP Linux Imaging and Printing System (ver. 3.11.1)
Printer Discovery Utility ve...

Read more...

Changed in system-config-printer (Ubuntu):
status: Incomplete → New
Till Kamppeter (till-kamppeter) wrote :

Your printer is accessible without any problems if one explicitly talks to it using its IP address. What does not work is that it does not answer to broadcasted requests like the network printer discovery utilities use. Do you have any firewall on your computer or somewhere in your network? Is there anything in your router which blocks broadcasts?

In principal you are able to print, but you need to enter the printer's IP manually to set up the printer.

typo (gnomeuser8) wrote :

It's ufw! After I entered "sudo ufw disable", I tried "hp-probe -bnet -mmdns" and then it worked. When I enter "sudo ufw enable" it won't work again. I also tried system-config-printer again and without ufw it works.

You should add a new exception rule to ufw so that it works like before.

Anders Jackson (anders-jackson) wrote :

typo, how do the printer report back?
There shouldn't be any problems if we know that.

It might be that ufw filters multicasts, which is shouldn't.

Try in one terminal window to run this "sudo tail -f /var/log/syslog' and then start hp-probe to discover your printer. That would to start some error reports showing up looking likt this:

[UFW BLOCK] IN=eth0 OUT= MAC= SRC=192.168.1.20 DST=239.255.255.250 LEN=122 TOS=0x00 PREC=0x00 TTL=1 ID=0 DF PROTO=UDP SPT=53194 DPT=1900 LEN=102

You can post only the ones comming from your printer here.

summary: - HP network printer is not automatically detected in Ubuntu 11.04 natty
- (regression)
+ Network printer is not automatically detected in Natty due to UFW
+ firewall
Changed in ufw (Ubuntu):
assignee: nobody → Jamie Strandboge (jdstrand)
importance: Undecided → Low
status: New → Triaged
Changed in ufw:
assignee: nobody → Jamie Strandboge (jdstrand)
status: New → Fix Committed
Changed in ufw (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ufw - 0.30.1-2ubuntu1

---------------
ufw (0.30.1-2ubuntu1) oneiric; urgency=low

  * Merge from Debian unstable. Remaining changes:
    - debian/rules: Don't install the upstream application profiles that are
      shipped with the Debian package.
    - debian/control: use ufw-0.30-oneiric for Vcs-Bzr

ufw (0.30.1-2) unstable; urgency=low

  * debian/control: make lintian clean:
    - update Standards-Version to 3.9.2
    - Build-Depends on python (>= 2.6.6-3~)
  * conf/ufw.defaults:
    - remove IRC connection tracking, which is only required for DCC.
      Cherrypick r741 from trunk
    - allow nf_conntrack_netbios_ns (Samba). Cherrypick r744 from trunk.
      LP: #360975 (Closes: 631737)
  * enable IPv6 by default and fix 'allow to any ipv6' when IPv6 is enabled.
    Cherrypick r742 from trunk.
  * update manpage references to ufw and ufw-framework to include the section.
    Cherrypick r743 from trunk.
  * ACCEPT UPnP (239.255.255.250 for IPv4 and ff02::f for IPv6) for service
    discovery just like we do for mDNS (ie, allow discovery, but not
    connections to the services). LP: #764933
  * debian/ufw.logrotate.debian, debian/ufw.logrotate.ubuntu, debian/rules:
    use 'rotate' option in Debian logrotate file and split out ufw.logrotate
    like we do the initscript since because Ubuntu's rsyslog doesn't have the
    'rotate' option yet. (Closes: 628605)
  * Cherrypick r746 from trunk to update check-requirements to prompt to
    continue with tests that may autoload modules. Add '-f' option to
    check-requirements and update test suite accordingly (LP: #782816)
  * Cherrypick r747 from trunk to not fail when running 'show listening' under
    fakeroot (LP: #812516)
  * debian/postinst:
    - remove some old upgrade transition code for unsupported upgrade paths
    - reload ufw if it is enabled and we are upgrading to this version since
      this is needed after enabling IPv6
  * debian/rules: add build-arch and build-indep targets

ufw (0.30.1-1.1) unstable; urgency=low

  * Non-maintainer upload.
  * Rebuild to add Python 2.7 support
 -- Jamie Strandboge <email address hidden> Mon, 18 Jul 2011 17:09:57 -0500

Changed in ufw (Ubuntu):
status: Fix Committed → Fix Released
Jamie Strandboge (jdstrand) wrote :

This should be fixed in 0.31.

Changed in ufw:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in system-config-printer (Ubuntu):
status: New → Confirmed
Changed in system-config-printer (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers