ufw

Capital Y required for `ufw delete <number>`

Bug #1438647 reported by Christophe on 2015-03-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ufw
Low
Unassigned

Bug Description

Deleting rules using the `ufw delete <number>` asks to verify before deleting. The output asks for "y|n" but actually requires a capital Y instead of a lowercase Y.

testarossa# ufw delete 4
Deleting:
 allow 9091/tcp
Proceed with operation (y|n)? y
Aborted
testarossa# ufw delete 4
Deleting:
 allow 9091/tcp
Proceed with operation (y|n)? Y
Rule deleted

Version: ufw 0.34~rc-0ubuntu2
OS: Ubuntu 14.04.2 LTS

Related branches

summary: - Capital Y required for `ufw delete [0-9]*`
+ Capital Y required for `ufw delete <number>`
Jamie Strandboge (jdstrand) wrote :

Thank you for using Ubuntu and filing a bug. I tried this on Ubuntu 12.04, 14.04 and 14.10 and could not reproduce the issue. what are your locale settings? Please paste the output of 'sudo -i locale'. Thanks!

Changed in ufw:
status: New → Incomplete

  % sudo -i locale
LANG=en_US.UTF-8
LANGUAGE=
LC_CTYPE=en_US.UTF-8
LC_NUMERIC=nl_BE.UTF-8
LC_TIME=nl_BE.UTF-8
LC_COLLATE="en_US.UTF-8"
LC_MONETARY=nl_BE.UTF-8
LC_MESSAGES="en_US.UTF-8"
LC_PAPER=nl_BE.UTF-8
LC_NAME=nl_BE.UTF-8
LC_ADDRESS=nl_BE.UTF-8
LC_TELEPHONE=nl_BE.UTF-8
LC_MEASUREMENT=nl_BE.UTF-8
LC_IDENTIFICATION=nl_BE.UTF-8
LC_ALL=

There you go! :)

Changed in ufw:
status: Incomplete → In Progress
importance: Undecided → Low
Changed in ufw:
milestone: none → 0.34
status: In Progress → Fix Committed
Changed in ufw:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers