abstraction for enumerating and managing block devices

EeePC SD card reader icon looks like a usb stick in GNOME

Reported by Sitsofe Wheeler on 2009-10-25
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
udisks
Fix Released
Medium
udisks (Ubuntu)
Low
Kees Cook

Bug Description

Binary package hint: hal-info

Description of the problem:
In Ubuntu 8.04 an update brought a welcome change where SD cards in my EeePC 900's internal SD card reader would actually get an SD card icon on the desktop rather than a standard USB icon. In 9.10 SD cards are back to looking like USB sticks.

Steps to reproduce:
1. Insert SD card while GNOME is running.

Expected result:
Icon like /usr/share/icons/Humanity/devices/48/gnome-dev-media-sdmmc.svg to be shown on the desktop for the SD card partitions.

Actual result:
An icon like /usr/share/icons/Humanity/devices/48/drive-removable-media-usb.svg is shown.

How reproducible is the problem?
It is reproducible every time.

Version information:
Ubuntu 9.10 (karmic)
hal-info 20090716-0ubuntu1

Additional information:
The SD card reader is a USB device with the following info:
Bus 001 Device 003: ID 0951:1606 Kingston Technology

Related branches

Sitsofe Wheeler (sitsofe) wrote :

Punting over to udisks (as hal/hal-info have been dropped and GNOME uses udisks which in turn uses udev instead).

affects: hal-info (Ubuntu) → udisks (Ubuntu)
Sitsofe Wheeler (sitsofe) wrote :

Still here in Lucid.

Version information:
Ubuntu 10.04 LTS
udisks 1.0.1-1build1

Sitsofe Wheeler (sitsofe) wrote :

After talking to David Zeuthen, it turns out that fixing device types is currently being handled by udev rules in
/lib/udev/rules.d/80-udisks.rules

A udev rule like
SUBSYSTEMS=="usb", ENV{ID_MODEL}=="*Reader*SD*", ENV{ID_DRIVE_FLASH_SD}="1"
(which I am currently putting in /etc/udev/rules.d/usb-sd.rules) shows the expected icon on my EeePC 900.

Sitsofe Wheeler (sitsofe) wrote :

The sysfs output as reported by udevadm for the card reader in my EeePC 900 when it is at /dev/sdc .

Sitsofe Wheeler (sitsofe) wrote :

I guess it is worth noting that the switch to udisks (presumably in 9.10) has lost a lot of the rules that hal-info had picked up to workaround issues like this, so other devices have probably also regressed.

tags: added: patch
Kees Cook (kees) wrote :

Thanks for this patch! I've created a debdiff for it and uploaded it to Ubuntu.

Changed in udisks (Ubuntu):
assignee: nobody → Kees Cook (kees)
importance: Undecided → Low
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package udisks - 1.0.2-3+ubuntu2

---------------
udisks (1.0.2-3+ubuntu2) natty; urgency=low

  * Add 12-add-sd-reader-rule.patch: add missing SD Reader rule,
    thanks to Sitsofe Wheeler (LP: #460713).
 -- Kees Cook <email address hidden> Thu, 10 Mar 2011 14:26:19 -0800

Changed in udisks (Ubuntu):
status: Fix Committed → Fix Released
Changed in udisks:
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.