Left mouse button stop working after the first keyboard layout switch

Bug #637208 reported by homer doe
436
This bug affects 100 people
Affects Status Importance Assigned to Milestone
udev
Confirmed
Undecided
Unassigned
udev (Ubuntu)
Undecided
Unassigned
Nominated for Maverick by kolen

Bug Description

Binary package hint: udev

if I switch it using any hotkey (alt+shift by default) or click on keyboard tray icon

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: udev 161+git20100827-1
ProcVersionSignature: Ubuntu 2.6.35-20.29-generic 2.6.35.4
Uname: Linux 2.6.35-20-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Mon Sep 13 20:13:42 2010
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
MachineType: LENOVO 20041
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-20-generic root=UUID=f9f55aec-98c5-47b7-b4c7-5f9f64676f50 ro quiet splash
ProcEnviron:
 LANG=ru_RU.utf8
 SHELL=/bin/bash
SourcePackage: udev
dmi.bios.date: 01/29/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 29CN17WW(V1.05)
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Base Board Product Name
dmi.board.vendor: LENOVO
dmi.board.version: Base Board Version
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnLENOVO:bvr29CN17WW(V1.05):bd01/29/2010:svnLENOVO:pn20041:pvrLenovoG460:rvnLENOVO:rnBaseBoardProductName:rvrBaseBoardVersion:cvnChassisManufacturer:ct10:cvrChassisVersion:
dmi.product.name: 20041
dmi.product.version: Lenovo G460
dmi.sys.vendor: LENOVO

Revision history for this message
homer doe (powerofdollarz) wrote :
Revision history for this message
homer doe (powerofdollarz) wrote :

as it turned out, the problem in the mouse a4tech:
if layout is RU, when I connect the mouse - left button of the mouse became to stick.
I solved this problem this way:
Disconnecting the mouse, change layout to US, click on the touchpad, and connecting the mouse back.

dmesg:

[ 6795.507441] usb 2-1.1: new full speed USB device using ehci_hcd and address 24
[ 6795.604299] input: A4Tech USB Full Speed as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1/2-1.1:1.0/input/input41
[ 6795.604539] generic-usb 0003:09DA:8090.0021: input,hidraw0: USB HID v1.11 Mouse [A4Tech USB Full Speed] on usb-0000:00:1d.0-1.1/input0
[ 6795.610218] input: A4Tech USB Full Speed as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1/2-1.1:1.1/input/input42
[ 6795.610442] generic-usb 0003:09DA:8090.0022: input,hiddev96,hidraw1: USB HID v1.11 Keyboard [A4Techон USB Full Speed] on usb-0000:00:1d.0-1.1/input1

/proc/bus/input/devices

I: Bus=0003 Vendor=09da Product=8090 Version=0111
N: Name="A4Tech USB Full Speed"
P: Phys=usb-0000:00:1d.0-1.1/input0
S: Sysfs=/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1/2-1.1:1.0/input/input45
U: Uniq=
H: Handlers=mouse1 event8
B: EV=17
B: KEY=ffff0000 0 0 0 0 0 0 0 0
B: REL=143
B: MSC=10

I: Bus=0003 Vendor=09da Product=8090 Version=0111
N: Name="A4Tech USB Full Speed"
P: Phys=usb-0000:00:1d.0-1.1/input1
S: Sysfs=/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1/2-1.1:1.1/input/input46
U: Uniq=
H: Handlers=sysrq kbd event9 js0
B: EV=12001f
B: KEY=837fff 2c3027 bf004444 0 c000000 1 10c04 b27c007 ffa67bfa d941dfff febeffdf ffefffff ffffffff fffffffe
B: REL=40
B: ABS=ffffff01 701ff
B: MSC=10
B: LED=1f

Revision history for this message
homer doe (powerofdollarz) wrote :

Why mouse is present like a keyboard in the system?

Revision history for this message
Vadim Andreyev (kolobast) wrote :

This kind of mouses has an additional buttons which are an additional built-in keyboard.
For example my A4 Tech. X7 XL-750MK has a mouse, keyboard and joystick in it.

McLure (mclure)
Changed in udev (Ubuntu):
status: New → Confirmed
Changed in udev:
status: New → Confirmed
Revision history for this message
Zhekpisov Sergey (ololo.) wrote :

A4Tech X-755 BK, same bug$ also left mouse don't work with NumLock, solved the same way.
Sorry for my English.

Revision history for this message
Zhekpisov Sergey (ololo.) wrote :

Some solution, that solve our problem.
1) xinput --list
It will show you your input devices, our A4Tech mouse have id, for example, there are
⎜ ↳ A4TECH USB Device id=11 [slave pointer (2)]
⎜ ↳ A4TECH USB Device id=10 [slave pointer (2)]
2) xinput set-int-prop %id% "Device Enabled" 8 0
, where %id% is one of id's of your mouse. In my case it was 10. Generally, this is the second id of list. This command will disable advanced built-in keyboard of A4Tech mouse.
If you want to enable back, use
xinput set-int-prop %id% "Device Enabled" 8 1.

Revision history for this message
corristo (corrmage) wrote :

same problem. A4 mouse.

Revision history for this message
NewBis (alien-mail) wrote :

A4Tech-XL740K same problem.

Revision history for this message
paragraf_203@o2.pl (paragraf-203) wrote :

same problem A4tech-g7-750 mouse...

Revision history for this message
konflikt (konfliktadm) wrote :

A4Tech-K3-230 mouse same problem

Revision history for this message
Bulajic Milivoje (bulajicm) wrote :

A4tech-X7 same..

Revision history for this message
CrossFire (zifix) wrote :

A4Tech XL-750 BH same bug.

Revision history for this message
gregory (gregory-gmmb) wrote :

A4Tech G7-630 same bug.

Revision history for this message
Vlad (vvladxx) wrote :

A4tech X7, have this bug too.
I temporarily solved this problem by turning off the layout led indicator Scroll Lock in the keyboard settings, but without it I'm quite uncomfortable.

Revision history for this message
Xing (jabrenok) wrote :

A4tech X-748K
64

Revision history for this message
Michael (info-john) wrote :

I experience the same behavior with a Microsoft Wireless Desktop 3000: Using one of the keyboard's multimedia keys makes the left mouse button stop working. Was fine with 10.04, broken with 10.10 RC

Revision history for this message
kolen (incredible-angst) wrote :

> I temporarily solved this problem by turning off the layout led indicator

Also works for me. Disabled scroll lock indicator and now left button works after switching layouts. A4Tech K3-230.
Maybe turning on/off scroll lock indicator has some bad effect on virtual keyboard detected in mouse.

Revision history for this message
homer doe (powerofdollarz) wrote :

> > I temporarily solved this problem by turning off the layout led indicator

not work for me

Revision history for this message
Bulajic Milivoje (bulajicm) wrote :

>> > I temporarily solved this problem by turning off the layout led indicator

>not work for me

not work for me too.. only "xinput set-int-prop %id% "Device Enabled" 8 0" work until reboot.

Very annoying bug

Revision history for this message
Michael (info-john) wrote :

I'd like to confirm that only 'xinput set-int-prop %id% "Device Enabled" 8 0' fixes the issue for me.
However, the multimedia keys are not working then.

Revision history for this message
nikita (nikita-mail) wrote :

Yeah, only 'xinput set-int-prop %id% "Device Enabled" 8 0' fixes it for my A4 X7 X-710BK

Revision history for this message
alpacino (alpacino-anton) wrote :

A4Tech G7-630 same bug

Nickolay (lukaville)
Changed in udev (Ubuntu):
assignee: nobody → Nickolay (lukaville)
Changed in udev:
assignee: nobody → Nickolay (lukaville)
Xing (jabrenok)
tags: removed: i386
Revision history for this message
sashakas (sashakas) wrote :

A4Tech G7-540 same bug.

Revision history for this message
Valentyn Shybanov (olostan) wrote :

Is it possible to make Zhekpisov Sergey's solution persistant?

Really annoying bug :(

Revision history for this message
Michael (info-john) wrote :

In my case, the solution of Zhekpisov Sergey disables all of my keyboard's multimedia keys. That is quite a disadvantage. With 10.04 everything was working fine. Would be good to investigate what change caused this problem.

Revision history for this message
Vlad (vvladxx) wrote :

Looks like it's not udev bug, because I tried to manually downgrade the package udev from lucid repository, but the bug is still alive.
Ubuntu Maverick release will be today. With the latest update bug is not fixed... It seems that the bug will also be in the release.
Maybe this bug is caused by X server? I'll try to downgrade all related x11 packages. If this doesn't help, I'll go back to lucid.

Revision history for this message
Michael (info-john) wrote :

Just upgraded to 10.10 Final Release. As expected, the bug is still there.

Revision history for this message
Valentyn Shybanov (olostan) wrote :

Disabling led when switching layouts works for me (thnx Vlad https://bugs.launchpad.net/ubuntu/+source/udev/+bug/637208/comments/14 )

Also plugging out mouse and keyboard didn't helped when, only rebooting.

Now with disabled led-indicator layout switching works even without " xinput set-int-prop %id% "Device Enabled" 8 0"

Hope that helps to solve this problem.

Revision history for this message
ap0stol (x777ozon) wrote :

10.10 Acer 5920G
also affected

2 Valentyn Shybanov: thx for temporary solution with disablings leds

Revision history for this message
Legolas (aka-wood-elf) wrote :

fore A4Tech X-738K too. Notebook Dell Vostro A860

Revision history for this message
Wizard (tester456) wrote :

I experience the same behavior with a Microsoft Wired Keyboard 600: Using one of the keyboard's multimedia keys makes the left mouse button stop working. It worked in 10.04, and startet to occure when i switched to 10.10.
Ah and my mouse is an Logitech MX518.

Revision history for this message
jack6.liu (jack6.liu) wrote :

A4tech mouse&keyboard set G7100 have the same behavior.

Revision history for this message
Sukochev Roman (Leolik) (leolik) wrote :

Upgrade system to 10.10.
Bug reproduced with my A4Tech XL-750BH
;(

Revision history for this message
Nickolay (lukaville) wrote :

fore A4Tech XL-740K (X7) too... (((

Changed in udev:
assignee: Nickolay (lukaville) → nobody
Changed in udev (Ubuntu):
assignee: Nickolay (lukaville) → nobody
Revision history for this message
homer doe (powerofdollarz) wrote :

its xserver-xorg-input-evdev bug

Revision history for this message
Vlad (pushi22le) wrote :

Same Bug with Sharkoon Fireglider and a generic Logitech keyboard.

Revision history for this message
pepone1234 (pepone1234-gmail) wrote :

I am also experiencing this bug wih a a4tech x7 750 and a dell studio 15 laptop.

Revision history for this message
Casper (goacas) wrote :

A4Tech GL-5300 the same problem.
The solution with xinput set-int-prop %id% "Device Enabled" 8 0 is not working for me. It disables my mouse at all. So mouse even becomes unmovable.

Revision history for this message
homer doe (powerofdollarz) wrote :
Revision history for this message
pepone1234 (pepone1234-gmail) wrote :

#40

Could you post the 64 bit version please?

Thank you.

Revision history for this message
homer doe (powerofdollarz) wrote :

 xserver-xorg-input-evdev from https://launchpad.net/~xorg-edgers/+archive/ppa

Revision history for this message
pawloch (pawloch) wrote :

32bit version installed on ubuntu 10.10 64 bit causes keyboard and mouse to stop working.
tried to find 64 bit version at "https://launchpad.net/~xorg-edgers/+archive/ppa", but can't find.
Using microsoft wireless keyboard 5000 and mouse on hp dv6835nr. Left mouse button still freezes

Revision history for this message
Sukochev Roman (Leolik) (leolik) wrote :
Revision history for this message
orlovdn (orlovdn) wrote :

Also acer extensa 7620

Revision history for this message
Nikolay (groft) wrote :

xl-750-bh

Revision history for this message
hareaa (hareaa) wrote :

Ubuntu 10.10 i386, the same problem with mouse. after caps-, num-, and scroll-lock left button is not working. Mouse - A4tech G7-750. to make it work back I disconnect the mouse, and then press again one of those three buttons, and then connect mouse back.

Revision history for this message
Enigmatic (enigmat) wrote :

Ubuntu 10.10, a4Tech G7-540. After NumLock not work left mouse button.

Revision history for this message
Enigmatic (enigmat) wrote :

mmm,
> $ xinput --list
  > A4TECH USB Device id=10 [slave pointer (2)]
  > A4TECH USB Device id=11 [slave pointer (2)]

> $ xinput set-int-prop 11 "Device Enabled" 8 0

It's work!

Revision history for this message
Ravishankar (ravi-buz) wrote :

i have a Microsoft Wired Keyboard 600 and face the same problem when i use the multimedia keys or the calculator key , is there any solution.

Revision history for this message
serega386 (serega386-gmail) wrote :

$ xinput --list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ A4Tech USB Mouse id=8 [slave pointer (2)]
⎜ ↳ Microsoft Microsoft® Digital Media Keyboard 3000 id=10 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Microsoft Microsoft® Digital Media Keyboard 3000 id=9 [slave keyboard (3)]
    ↳ Power Button id=7 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]

Revision history for this message
Jon Koops (jonkoops) wrote :

Same here for the Logitech G500 Laser mouse, think G5 would have the same issue. Never had problems with this in 10.04 though.

Revision history for this message
mabu (mabu) wrote :

Bug is present with the Logitech G5, too.
Never had problems with this in 10.04 though.

Revision history for this message
Bison (kristobendito) wrote :

Same problem here, I've got an a4tech x7 xl-747H and after upgrading my ubuntu to 10.10 the left click stopped working, Thank you so much for the xinput trick, it worked for me!!! I hope this bug become fixed asap.

Revision history for this message
Mad Hatter (madhatter) wrote :

I has automated searching and blocking additional buttons. Just add it to startup! =)

Revision history for this message
David R. Hedges (p14nd4) wrote :

Chiming in as another user experiencing this problem immediately after upgrading from 10.04 to 10.10. I have a Microsoft Digital Media Keyboard and Microsoft 5-Button Mouse with IntelliEye (IntelliMouse Explorer), and the problem was exhibited immediately after I pressed the calculator button on my keyboard (which happened to be about 60 seconds after booting after the upgrade). Hoping to see a fix for this soon! Let me know if there's anything I can do to help this get fixed.

Revision history for this message
G$L (gsl2k10) wrote :

Same issue on Linux Mint Julia, mouse X-748K

Revision history for this message
Alexandr (can4ik) wrote :

A4Tech XL-760H same

Revision history for this message
Murat Uenalan (muenalan) wrote :

Confirmed.

Was just confused with the many mouse entries in the xinfo list. For me entry 13 on my sony vaio laptop solved it. Notably, I have a usb mouse and a builtin touch pad "mouse". Just in case the bug has something to do with a possible conflict.

murat ~ $ xinput --list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ Macintosh mouse button emulation id=14 [slave pointer (2)]
⎜ ↳ Microsoft Microsoft IntelliMouse® Optical id=10 [slave pointer (2)]
⎜ ↳ AlpsPS/2 ALPS GlidePoint id=13 [slave pointer (2)]
⎜ ↳ PS/2 Mouse id=12 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Video Bus id=7 [slave keyboard (3)]
    ↳ Sony Vaio Keys id=8 [slave keyboard (3)]
    ↳ Power Button id=9 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=11 [slave keyboard (3)]

murat ~ $ xinput set-int-prop 13 "Device Enabled" 8 0

Revision history for this message
Agel (archagel) wrote :

A4TECH X7 XL-747H left click working but missing mouse scroll. cat /dev/usb/hiddev reacts on scroll events only, not mouse moving.

Revision history for this message
Nikita (nikita-dto) wrote :

A4Tech G7-630, same problem.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers