Failed to open file '/usr/local/share/udev-discover/udev-discover.ui

Reported by moma on 2011-08-24
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
udev-discover
High
J. Félix Ontañón
0.2
High
J. Félix Ontañón

Bug Description

Hello,
I just successfully installed udev-discover from PPA on a 64bit Natty.
But it displays an error message when started.

$ udev-discover

Gtk-Message: Failed to load module "canberra-gtk-module"
Traceback (most recent call last):
  File "/usr/bin/udev-discover", line 562, in <module>
    UDevDiscoverGUI()
  File "/usr/bin/udev-discover", line 228, in __init__
    'main_window']):
  File "/usr/lib/python2.7/dist-packages/gi/types.py", line 44, in function
    return info.invoke(*args)
glib.GError: Failed to open file '/usr/local/share/udev-discover/udev-discover.ui': No such file or directory
---------

The problem seems to be that "udev-discover.ui" was installed to "/usr/share/udev-discover/", and not to "/usr/local/share/udev-discover/".

$ sudo updatedb
$ locate udev-discover.ui
/usr/share/udev-discover/udev-discover.ui
---------

Ernst Sjöstrand (ernstp) wrote :

Same here!

J. Félix Ontañón (fontanon) wrote :

Confirmed, dunno why the path_prefix was set to "/usr/local" instead of "/usr/" while packaging for AMD64.
It needs to be fixed, so a minor version of packaging will be released.

Meanwhile you can edit the /usr/bin/udev-discover and replace the line 34:

UDEVDISCOVER_UI = '/usr/local/share/udev-discover/udev-discover.ui'

with

UDEVDISCOVER_UI = '/usr/share/udev-discover/udev-discover.ui'

Changed in udev-discover:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → J. Félix Ontañón (fontanon)
tags: added: path
tags: added: install
removed: path
Ed Catmur (ed-catmur) wrote :

See also bug 835968

Changed in udev-discover:
status: Confirmed → In Progress
J. Félix Ontañón (fontanon) wrote :

This is caused by the same kind of problems as described by lp:835968
I won't mark it as duplicate because it affects directly to AMD64 deb packages, though

J. Félix Ontañón (fontanon) wrote :

udev-discover-0.2.1 was released and debian packages for amd64 has been built fixing this bug.

https://launchpad.net/~fontanon/+archive/udev-discover/+packages

Changed in udev-discover:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers