Packages failing due to pristine-tar not being able to reconstruct their tarball

Bug #653301 reported by James Westby on 2010-10-01
38
This bug affects 3 people
Affects Status Importance Assigned to Milestone
The Leprechaun project
Undecided
Unassigned
Ubuntu Distributed Development
High
Unassigned
pristine-tar (Debian)
Fix Released
Unknown

Bug Description

Hi,

Some packages fail like:

bzrlib.plugins.builddeb.errors.PristineTarError: There was an error using pristine-tar: Generating delta from tar failed: pristine-bz2 failed to reproduce build of akonadi_1.4.0.orig.tar.bz2
(Please file a bug report.)
pristine-tar: command failed: pristine-bz2 --no-verbose --no-debug --no-keep gendelta ...

So we should triage and file bug reports.

Currently affected:

http://package-import.ubuntu.com/status/gausssum.html
http://package-import.ubuntu.com/status/crawl.html
http://package-import.ubuntu.com/status/freecol.html

James Westby (james-w) on 2010-10-01
description: updated
James Westby (james-w) on 2010-10-02
description: updated
James Westby (james-w) on 2010-10-02
description: updated
James Westby (james-w) on 2010-10-02
description: updated
James Westby (james-w) on 2010-10-02
description: updated
James Westby (james-w) on 2010-10-02
description: updated
James Westby (james-w) on 2010-10-02
description: updated
James Westby (james-w) wrote :

Should be fixed by pristine-tar 1.10. This will be synced to natty when it opens, at
which point we should request a backport to lucid/hardy, and the request an install on
jubany.

Thanks,

James

Ugo Riboni (uriboni) wrote :

It also affects the package for banshee : http://package-import.ubuntu.com/status/banshee.html

Joey Stanford (joey) on 2010-11-09
visibility: public → private
visibility: private → public
Changed in leprechaun:
status: New → Invalid
Max Bowsher (maxb) wrote :

Filed bug 695108 against lucid-backports.

John A Meinel (jameinel) wrote :

lamont just installed a backport of natty's pristine-tar package. So I've requeued the failing imports, and I'm thinking to close this. I'll way to see that they are actually succeeding before doing so. (I did test akonadi manually, and it did import successfully.)

John A Meinel (jameinel) wrote :

Updating the pristine-tar code helped many of the packages, but some are still failing. I'm leaving this bug open, because the failure is already linked to this bug, so it is easiest to just maintain it.

description: updated
Changed in pristine-tar (Debian):
status: Unknown → Fix Released
Jelmer Vernooij (jelmer) wrote :

Sync request filed as bug 824067

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.