failed make for uCube

Bug #660576 reported by Duncan McGreggor
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Geis
High
Stephen M. Webb
ucube
Undecided
Stephen M. Webb
utouch-geis (Ubuntu)
Undecided
Stephen M. Webb
Maverick
Undecided
Unassigned

Bug Description

Hey Stephen,

When I try to build uCube I get a failure:

ucube/app.cpp:250: undefined reference to `geis_event_dispatch(_GeisInstance*)'

I'll past the full thing in a comment so that I don't gum up the description.

Revision history for this message
Duncan McGreggor (oubiwann) wrote :

Here's the output from make (a second run, so less verbose):

$ make
make all-recursive
make[1]: Entering directory `/tmp/ucube'
Making all in ucube
make[2]: Entering directory `/tmp/ucube/ucube'
g++ -I.. -I../include -DDATA_DIR=\"/usr/local/share/ucube\" -DUCUBE_BUILD_IMAGE_SEARCH_PATH=\"../assets/\" -DUCUBE_INSTALL_IMAGE_SEARCH_PATH=\"/usr/local/share/ucube/images/\" -D_GNU_SOURCE=1 -D_REENTRANT -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT -I/usr/include/SDL -I/usr/include/freetype2 -g -O2 -o ucube ucube-app.o ucube-config.o ucube-cube.o ucube-font.o ucube-gamestate.o ucube-image.o ucube-imagecache.o ucube-introstate.o ucube-playstate.o ucube-ucube.o ucube-video.o ucube-videocontextsdl.o -lutouch-geis -lSDL -lSDL_image -lSDL -lGLEW -lfreetype -lGL
ucube-app.o: In function `UCube::App::GeisInit::pump()':
/tmp/ucube/ucube/app.cpp:250: undefined reference to `geis_event_dispatch(_GeisInstance*)'
ucube-app.o: In function `GeisInit':
/tmp/ucube/ucube/app.cpp:217: undefined reference to `geis_init(GeisWinInfo*, _GeisInstance**)'
/tmp/ucube/ucube/app.cpp:223: undefined reference to `geis_input_devices(_GeisInstance*, GeisInputFuncs*, void*)'
/tmp/ucube/ucube/app.cpp:233: undefined reference to `geis_subscribe(_GeisInstance*, unsigned int*, char const**, GeisGestureFuncs*, void*)'
/tmp/ucube/ucube/app.cpp:217: undefined reference to `geis_init(GeisWinInfo*, _GeisInstance**)'
/tmp/ucube/ucube/app.cpp:223: undefined reference to `geis_input_devices(_GeisInstance*, GeisInputFuncs*, void*)'
/tmp/ucube/ucube/app.cpp:233: undefined reference to `geis_subscribe(_GeisInstance*, unsigned int*, char const**, GeisGestureFuncs*, void*)'
ucube-app.o: In function `UCube::App::GeisInit::pump()':
/tmp/ucube/ucube/app.cpp:250: undefined reference to `geis_event_dispatch(_GeisInstance*)'
collect2: ld returned 1 exit status
make[2]: *** [ucube] Error 1
make[2]: Leaving directory `/tmp/ucube/ucube'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/ucube'
make: *** [all] Error 2

Revision history for this message
Stephen M. Webb (bregma) wrote :

uCube requires at least version 1.0.12 of the geis development libraries to compile.

Changed in ucube:
assignee: nobody → Stephen M. Webb (bregma)
status: New → In Progress
Revision history for this message
Stephen M. Webb (bregma) wrote :

utouch-geis 1.0.12 or later needs to be packaged and made available publicly

Changed in utouch-geis:
assignee: nobody → Stephen M. Webb (bregma)
importance: Undecided → High
status: New → In Progress
Revision history for this message
Duncan McGreggor (oubiwann) wrote :

Stephen, is there any way of making uCube work with previous versions of GEIS?

Revision history for this message
Stephen M. Webb (bregma) wrote :

uCube will run against earlier versions of libutouch-geis without problem but it will not build against any version of libutouch-geis-dev earlier than 1.0.12 because of C++ name mangling issues.

Stephen M. Webb (bregma)
Changed in utouch-geis:
status: In Progress → Fix Committed
Stephen M. Webb (bregma)
Changed in utouch-geis (Ubuntu):
status: New → Confirmed
assignee: nobody → Stephen M. Webb (bregma)
Stephen M. Webb (bregma)
Changed in utouch-geis (Ubuntu):
status: Confirmed → In Progress
Revision history for this message
Stephen M. Webb (bregma) wrote :

The fix for this is included in release 1.0.12.

Changed in utouch-geis:
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package utouch-geis - 1.0.13-0ubuntu1

---------------
utouch-geis (1.0.13-0ubuntu1) natty; urgency=low

  * New upstream release:
    - Fixes failed make for some dependent projects (LP: #660576).
    - Prevents event dispatch from hanging under some circumstances
      (LP: #656503).
  * Updated to build with toolchain from Natty Narwhal.
 -- <email address hidden> (Stephen M. Webb) Tue, 30 Nov 2010 18:34:46 -0500

Changed in utouch-geis (Ubuntu):
status: In Progress → Fix Released
Stephen M. Webb (bregma)
Changed in ucube:
status: In Progress → Fix Released
Adolfo Jayme (fitojb)
Changed in utouch-geis (Ubuntu Maverick):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions