Ubuntu Customization Kit

Build failed on Ubuntu 10.04 beta 1 with latest updates

Reported by Samiux on 2010-03-22
64
This bug affects 15 people
Affects Status Importance Assigned to Milestone
Ubuntu Customization Kit
Undecided
Unassigned
uck (Ubuntu)
Medium
Alessio Treglia
Lucid
Undecided
Unassigned

Bug Description

I was going to build customised Ubuntu 10.04 beta (with the latest updates) on Ubuntu 10.04 beta (with the latest updates) but failed. Attached please find the build log.

Related branches

Samiux (runnersam) wrote :
Wolf Geldmacher (wolf-womaro) wrote :

Could you please try the (not yet released) uck version from SVN?
The handling of directories (like /root which causes the problem in your report) has been changed and this change should also solve the problem you are having.

Samiux (runnersam) wrote :

I use svn UCK 2.2.0 as suggested to remaster Ubuntu 10.04 beta but failed. Attached please find my build.log.

Wolf Geldmacher (wolf-womaro) wrote :

There was an unwanted interaction between the fix for "Bug #547260: uck-remaster: hard coded path to custom scripts -> crashs " and uck-gui's use of uck-remaster. I've changed uck-remaster in SVN to hopefully solve your problem without braking the fix for the other error.

Can you please verify?

Samiux (runnersam) wrote :

As suggested to download the latest SVN, the previous error solved. However, the build failed finally. Attached please find the build.log.

Wolf Geldmacher (wolf-womaro) wrote :

You lack the package gfxboot in your host system - this will supply the mkbootmsg command and is a dependency for (re-)building the gfxboot-theme-ubuntu. (This should be pulled in by installation of the uck*.deb, but as you are using an unpackaged pre-release version this does not happen automatically).

As an alternative:

If you don't need to modify gfxboot (i.e. you stay with the one from the Live-CD) you can also
remove all the lines (starting at :
     # Create a temporary directory to assemble the gfxboot stuff in
and ending at:
    # Cleanup
    [ "$BUILD_DIR" != "/" ] && rm -rf "$BUILD_DIR"
) from ~/tmp/customization-scripts/customize_iso.
This will save some time, too.

Samiux (runnersam) wrote :

I installed gfxboot and gfxboot-theme-ubuntu as suggested. It works. However, new error produced and finally failed. Attached please find the build.log

install squashfs-tools

Changed in uck:
status: New → Fix Committed
futurefx (force) wrote :

i just let developer to know how strange way can be avoided crash in UCK 2.0.12, when using only synaptic GUI and do not let synaptic crash (close and reopen after bigger use like between removal and install processes). DO NOT open "Run console application" OR .iso build fails for sure. This way i still can edit Ubuntu Lucid daily builds.

when UCK 2.2.0 .deb will be released??, maybe then i can start using "Run console application".

Thank you for making life saver tool UCK, i never install non-edited Ubuntu on my pc.

Log what i included is when i used terminal to remove and install packages and then build fails always, like i said only using Synaptic can complete .iso build fine.

Pascal de Bruijn (pmjdebruijn) wrote :

I had the same problem as initially reported here.

I just checked out SVN, and now building a custom Lucid ISO (based on the -rc ISO) seems to work just fine.

I hope UCK 2.2.0 can be released simultaneously with Lucid.

thestorm (thestormname) wrote :

When will the fixed of errors?

Alessio Treglia (quadrispro) wrote :

Fabrizio, does this bug affect Ubuntu Lucid too?

Wolf Geldmacher (wolf-womaro) wrote :

yep - 10.04 == lucid

this bug is solved in 2.2.0 version of UCK (:

Changed in uck (Ubuntu):
assignee: nobody → Alessio Treglia (quadrispro)
status: New → Fix Committed
Changed in uck (Ubuntu):
status: Fix Committed → In Progress
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package uck - 2.2.0-0ubuntu1

---------------
uck (2.2.0-0ubuntu1) maverick; urgency=low

  * New upstream release:
    - Add Ubuntu 10.04 support (LP: #544555).
    - Fix crash due to the use of hard coded path for custom scripts,
      fixes LP: #547260.
  * Drop all patches, applied upstream.
  * Bump Standards.
  * Remove debian/README.source, now unnecessary.
 -- Alessio Treglia <email address hidden> Sat, 08 May 2010 01:47:14 +0200

Changed in uck (Ubuntu):
status: In Progress → Fix Released
Changed in uck:
status: Fix Committed → Fix Released
Sindhu S (sindhu-s) wrote :

No, I still get this when using uck version 2.0.12

Wolf Geldmacher (wolf-womaro) wrote :

@Sindhu: we cannot fix bugs in outdated versions. Please upgrade to a more current version.

Sindhu S (sindhu-s) wrote :

But this is the version I have from installing uck off lucid lynx's repositories. :(

Wolf Geldmacher (wolf-womaro) wrote :

We do have severe problems pushing updated versions into the releases and don't seem to have any influence on when changes get taken over. Sorry.

Narcis Garcia (narcisgarcia) wrote :

Sad to read about problems in pushing updated versions to Ubuntu's repositories.
Installing UCK 2.2 solved the problem for me.

running ubuntu 10.10 and the system reports that mkbootmsg is missing.
i installed the uck 2.2 deb from maverick repositories, which didnt work,
installed the deb package from sf,net, which didnt work either

in reinstalled gfxboot, gfxboot-ubuntu-theme, and squashfs-tool as suggested, which didnt work out either.

i ran apt-file search mkbootmsg which yielded in no results.

any help is greatly appreciated.

build.log

<snip>
make[1]: Verlasse Verzeichnis '/tmp/tmp.mhYcuIV2cw/gfxboot-theme-ubuntu/po'
mkdir -p boot
mkbootmsg -O -v -L ../.. -l boot/log -c boot.config boot/init
make: mkbootmsg: Kommando nicht gefunden
make: *** [bootdir] Fehler 127
Failed to build gfxboot theme

Wolf Geldmacher (wolf-womaro) wrote :

It's not the same problem - 10.10 has its own ;-)
Please see Bug Report #659572 for a solution.

thx

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions