package ubuntustudio-audio 0.64 failed to install/upgrade: ErrorMessage: package ubuntustudio-audio is already installed and configured

Bug #695854 reported by Jose Conde on 2010-12-31
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Studio
Undecided
Unassigned
ubuntustudio-meta (Ubuntu)
Undecided
Unassigned

Bug Description

Sorry I'm not very savy I can not help more.

ProblemType: Package
DistroRelease: Ubuntu 10.04
Package: ubuntustudio-audio 0.64
ProcVersionSignature: Ubuntu 2.6.32-26.46-generic 2.6.32.24+drm33.11
Uname: Linux 2.6.32-26-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Thu Dec 30 19:12:44 2010
ErrorMessage: ErrorMessage: package ubuntustudio-audio is already installed and configured
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
SourcePackage: dpkg
Title: package ubuntustudio-audio 0.64 failed to install/upgrade: ErrorMessage: package ubuntustudio-audio is already installed and configured

Jose Conde (whitespys) wrote :
Fabio Marconi (fabiomarconi) wrote :

Hello
Please run in a terminal
sudo apt-get clean
and run again update manager
thanks
Fabio

Changed in ubuntu:
status: New → Incomplete
Philip Muškovac (yofel) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in dpkg.

affects: ubuntu → dpkg (Ubuntu)

On Sun, 03 Apr 2011, Philip Muškovac wrote:
> Thank you for taking the time to report this bug and helping to make
> Ubuntu better. This bug did not have a package associated with it, which
> is important for ensuring that it gets looked at by the proper
> developers. You can learn more about finding the right package at
> https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this
> bug as a bug in dpkg.

And you have badly classified it. :-(

The error is:

Preparing to replace ubuntustudio-audio 0.64 (using .../ubuntustudio-audio_0.70_amd64.deb) ...
ntu1_amd64.deb) ...
@audio - rtprio 99
Traceback (most recent call last):
  File "/usr/share/ubuntustudio-audio/rtprio.py", line 18, in <module>
    rtprio.rm_setting()
  File "/usr/lib/python2.6/dist-packages/changesettings.py", line 80, in rm_setting
    self.rm_list.remove(self.remove_string)
ValueError: list.remove(x): x not in list
dpkg: warning: old pre-removal script returned error exit status 1
dpkg - trying script from the new package instead ...
buntu1_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/ubuntustudio-audio_0.70_amd64.deb (--unpack):
 subprocess new pre-removal script returned error exit status 1

So this is a bug in ubuntustudio-audio.

Cheers,
--
Raphaël Hertzog ◈ Debian Developer

Follow my Debian News ▶ http://RaphaelHertzog.com (English)
                      ▶ http://RaphaelHertzog.fr (Français)

Changed in dpkg (Ubuntu):
status: Incomplete → Invalid
affects: dpkg (Ubuntu) → ubuntustudio-meta (Ubuntu)
Changed in ubuntustudio-meta (Ubuntu):
status: Invalid → Confirmed
tags: added: dist-upgrade
Ross Gammon (rosco2) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates.

Feel free to try installing one of the latest versions of Ubuntu Studio and reporting any bugs you find.

Changed in ubuntustudio-meta (Ubuntu):
status: Confirmed → Invalid
Changed in ubuntustudio:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers