package conflict (foomatic-db / foomatic-db-compressed-ppds) causes Ubuntu Studio installation to fail

Bug #642405 reported by Ronan Jouchet on 2010-09-18
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Studio
Undecided
Unassigned
ubuntustudio-meta (Ubuntu)
Undecided
Luke Yelavich

Bug Description

Hello,

The installation of today's (20100918) daily Studio spin fails at the "Select and install software" step and presents a red screen asking me to retry or skip, even if I uncheck all of the four package choices (2d3d, audio, dssi, video).
Skipping the step results in a failed install (it seems to finish but drops the user to a BusyBox prompt).

Here is the exact error message appearing in tty4:
in-target: foomatic-db-compressed-ppds : Conflicts : foomatic-db but 20100915-0ubuntu2 is to be installed
                                         Conflicts : foomatic-db-hpijs but 20100915-0ubuntu2 is to be installed

This seems to be UbuntuStudio specific: the ubuntu-alternate iso of the same day installs without a hitch.

I tested 20100918/32bit builds, and Janne Jokitalo confirmed the issue with the 20100917/amd64 build.

tags: added: iso-testing

 affects ubuntu/ubuntustudio-meta
 status inprogress
 assignee themuso

Changed in ubuntustudio:
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntustudio-meta - 0.74

---------------
ubuntustudio-meta (0.74) maverick; urgency=low

  * Refreshed dependencies (LP: #642405)
  * Added foomatic-db-compressed-ppds to desktop
  * Removed foomatic-db-engine from desktop
  * Moved foomatic-db to desktop-recommends
  * Remove ia64/sparc data from update.cfg
 -- Luke Yelavich <email address hidden> Wed, 22 Sep 2010 11:22:59 +1000

Changed in ubuntustudio-meta (Ubuntu):
status: In Progress → Fix Released
Luke Yelavich (themuso) on 2010-09-22
Changed in ubuntustudio:
status: Fix Committed → Fix Released
Ronan Jouchet (ronj) wrote :

Hi Luke, hi everybody.

The installation still fails. I tested today's ISO (yes, it includes the new ubustu-meta 0.74: browsing inside the ISO I confirm I have $iso/pool/universe/u/ubuntustudio-meta/ubuntustudio-*_0.74_i386.deb )
Here is the slightly exact error message appearing in tty4:
in-target: foomatic-db-compressed-ppds : Conflicts : foomatic-db but 20100915-0ubuntu3 is to be installed
                                         Conflicts : foomatic-db-hpijs but 20100915-0ubuntu2 is to be installed

Changed in ubuntustudio:
status: Fix Released → New
Changed in ubuntustudio-meta (Ubuntu):
status: Fix Released → New
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntustudio-meta - 0.75

---------------
ubuntustudio-meta (0.75) maverick; urgency=low

  * Refreshed dependencies
  * Removed foomatic-db from desktop-recommends (Really fixes lp: #642405)
 -- Luke Yelavich <email address hidden> Fri, 24 Sep 2010 11:14:37 +1000

Changed in ubuntustudio-meta (Ubuntu):
status: New → Fix Released
Ronan Jouchet (ronj) wrote :

I confirm it's now fixed

Changed in ubuntustudio:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers