[Maverick A1] Audio and Video suite package options cause pkgsel failure during d-i install

Bug #588780 reported by Jeff Lane on 2010-06-02
24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Studio
Undecided
Unassigned

Bug Description

Installing Studio in a VM for Alpha 1 ISO testing...

I get as far as the package selection, where pkgsel fails. (See attached screenshot, FWIW). The problem appears to be one of the package groups.

Initially, I selected all four (2/3d graphics, audio suite, audio plugins, video suite) and got the pkgsel failure every time I tried. Eventually, I de-selected everything but 2/3d graphics and the install proceeded.

Jeff Lane (bladernr) wrote :
tags: added: iso-testing
Jeff Lane (bladernr) wrote :

More information... on subsequent tests, it appears that the package groups that fail are the audio and video suites. The 2d/3d and audio codecs packages install just fine either separately or together, while the audio and video suites fail every time they are selected.

I've tried 5 installs choosing each package option individually... the results are:

Chose all four: FAIL
Chose only 2d/3d graphics: PASS
Chose only Audio Suite: FAIL
Chose only Audio Codecs: PASS
Chose only Video Suite: FAIL
Chose both Audio and Video Suites: FAIL
Chose both 2d/3d GFX and Audio Codecs: PASS

summary: - [Maverick A1] One (or more) of the package options fails duiring d-i
- install
+ [Maverick A1] Audio and Video suite package options cause pkgsel failure
+ during d-i install
Steve Beattie (sbeattie) wrote :

Here looks to be the relevant bits from /var/log/syslog:

Jun 2 18:38:53 in-target: Some packages could not be installed. This may mean that you have
Jun 2 18:38:53 in-target: requested an impossible situation or if you are using the unstable
Jun 2 18:38:53 in-target: distribution that some required packages have not yet been created
Jun 2 18:38:53 in-target: or been moved out of Incoming.
Jun 2 18:38:53 in-target: The following information may help to resolve the situation:
Jun 2 18:38:53 in-target:<
Jun 2 18:38:53 in-target: The following packages have unmet dependencies:
Jun 2 18:38:53 in-target: bitmeter: Conflicts: bitscope
Jun 2 18:38:53 in-target: libdirectfb-1.2-9: Conflicts: libdirectfb-1.2-0 but 1.2.8-5ubuntu2 is to be installed
Jun 2 18:38:53 in-target: E:<
Jun 2 18:38:53 in-target: Broken packages
Jun 2 18:38:53 in-target:<
Jun 2 18:38:53 in-target: tasksel: aptitude failed (100)

Full syslog is attached.

Changed in ubuntustudio:
status: New → Confirmed
Scott Lavender (slavender) wrote :

Email today from the daily health check report on the Ubuntu Studio CD images...

     ubuntustudio/daily: Uninstallable packages:

     bitmeter 1.2-0ubuntu2 produces uninstallable binaries:
      * bitscope (amd64 i386)

     linux-meta 2.6.34.5.4 produces uninstallable binaries:
      * linux-image-preempt (amd64)
      * linux-preempt (amd64)

     mplayer 2:1.0~rc3+svn20090426-1ubuntu16 produces uninstallable binaries:
      * mencoder (amd64 i386)
      * mplayer (amd64 i386)

papukaija (papukaija) on 2010-06-07
tags: added: maverick
Colin Watson (cjwatson) wrote :

This should be fixed in current daily builds, and for Alpha 2; http://cdimage.ubuntu.com/ubuntustudio/daily/current/report.html shows no uninstallable packages right now.

Changed in ubuntustudio:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers