Mute button not enabled by default in Ardour 2.8.6 Lucid AM64

Bug #581786 reported by Angus Kerr on 2010-05-17
36
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ardour
Fix Released
Unknown
Ubuntu Studio
High
Scott Lavender
ardour (Debian)
Fix Released
Unknown
ardour (Ubuntu)
Medium
Scott Lavender
Lucid
High
Scott Lavender

Bug Description

-- SRU report follows --

Please see comment #8 (https://bugs.edge.launchpad.net/ubuntu/+source/ardour/+bug/581786/comments/8) for the SRU information.

-- Original report follows --

Hi

I tried in vain to work out why the 'mute' button does not work in Ardour 2.8.6 packaged with Ubuntu Studio Lucid AM64. Help was forthcoming from the Ardour forum:

It seems that mute has been disabled intentionally during, or after the installation of Ardour in Ubuntu Studio when the package was created.

The file 'ardour.rc' in .ardour2 directory in the home folder of the user, contains the following entries:

Option name="mute-affects-pre-fader" value="0"/>
Option name="mute-affects-post-fader" value="0"/>
Option name="mute-affects-control-outs" value="0"/>
Option name="mute-affects-main-outs" value="0"/>

The options should be set to 1, like this:

Option name="mute-affects-pre-fader" value="1"/>
Option name="mute-affects-post-fader" value="1"/>
Option name="mute-affects-control-outs" value="1"/>
Option name="mute-affects-main-outs" value="1"/>

This is a bug that will affect any user who tries to use the mute button on ardour. The mute button is one of the most frequently used buttons on a real, or virtual mixer.

99.9% of people using ardour, would want the mute function to work. The default settings in the Ubuntu cater for the 0.1% who don't want mute to work.

Please change this option in the next release, to the values suggested above.

Thanks

Angus Kerr (angus-tropical) wrote :

Any comments?

Changed in ubuntustudio:
status: New → Confirmed
Changed in ardour (Ubuntu):
status: New → Confirmed
Changed in ubuntustudio:
status: Confirmed → In Progress
Emmet Hikory (persia) on 2010-05-24
Changed in ubuntustudio:
importance: Undecided → High
Changed in ardour (Ubuntu):
importance: Undecided → Medium
Changed in ubuntustudio:
status: In Progress → Triaged
Changed in ardour:
status: Unknown → In Progress
Changed in ubuntustudio:
assignee: nobody → Scott Lavender (slavender)
Changed in ardour (Ubuntu):
assignee: nobody → Scott Lavender (slavender)
Changed in ubuntustudio:
status: Triaged → In Progress
Changed in ardour (Ubuntu):
status: Confirmed → In Progress
Changed in ardour (Debian):
status: Unknown → Confirmed
Angus Kerr (angus-tropical) wrote :

Cool

Great to see this getting some action!

Thanks, Team.

Angus

tags: added: patch
Scott Lavender (slavender) wrote :

I should mention that the patch will only be effective after Ardour is rebuilt and only for new installs.

If the ardour.rc file is existing in the user's home directory it will need to be moderated as described in the first post of this bug.

Changed in ardour (Debian):
status: Confirmed → Fix Released
Changed in ubuntustudio:
status: In Progress → Fix Committed
Changed in ardour (Ubuntu):
status: In Progress → Fix Committed
Scott Lavender (slavender) wrote :

ardour-2.8.7 with 120_mute.patch is now in Maverick. This will work new installs of ardour-2.8.7 only!

Users running lucid will still need to update their ~/.ardour2/ardour.rc file as noted in the first post.

Users UPGRADING to Maverick will still need to update their ~/.ardour2/ardour.rc file as noted in the first post as upgrades should not affect home directories.

Changed in ardour (Ubuntu):
status: Fix Committed → Fix Released
Changed in ubuntustudio:
status: Fix Committed → Fix Released
Ricardo Lameiro (rlameiro) wrote :

The patch is already been applied in Debian with new release
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=582938#43

Changed in ardour:
status: In Progress → Fix Released
Lorenzo Bicci (bicci) wrote :

I would suggest releasing an updated package for Lucid, if Ubuntu Studio doesn't want to lose old and new users.

Scott Lavender (slavender) wrote :

SRU:
1. Bug is fixed in current development release (maverick) and bug report is listed as "fix released".
2.1. Currently the mute button in Ardour does not function and requires hand modification of an ardour system configuration file and deletion of a generated configuration file in the user's home directory to activate the mutton button pervasively.
2.2. In the current development branch and new upstream release resolved this bug.
2.3. A patch is attached to this bug report.
2.4. Test case follows....
TEST CASE:
  a. start jack with appropriate settings for stable, low latency performance
  b. start ardour
  c. create new track, arm new track, and record audio on new track
  d. begin playback of new audio track
  e. left click mute button...audio will *NOT* be muted
2.5. I am unaware of any potential regression, however if should be noted that if a regression did occur it would affect those using Ardour (i.e. excludes practically all desktop users and only the subset of ubuntu studio users who use ardour)

It should be noted that this is a significant regression (the loss of mute functionality in a DAW) in an LTS version.

Scott Lavender (slavender) wrote :

I should also note that I have tested this patch myself and it was originally uploaded to Debian via Debian Multimedia Team (see: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=582938#43) before upstream released a bug fix updated version.

Daniel T Chen (crimsun) on 2010-07-18
description: updated
Daniel T Chen (crimsun) wrote :

uploaded with minor tweaking to debian/changelog and debian/control

Changed in ardour (Ubuntu Lucid):
assignee: nobody → Scott Lavender (slavender)
importance: Undecided → High
milestone: none → lucid-updates
status: New → In Progress

Accepted ardour into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in ardour (Ubuntu Lucid):
status: In Progress → Fix Committed
tags: added: verification-needed
Martin Pitt (pitti) wrote :

Any testers?

Scott Lavender (slavender) wrote :

Martin,

I am building a box for a friend this weekend which will have Lucid installed on it.

I will report if it works or not.

Lorenzo Bicci (bicci) wrote :

I installed Ubuntu Studio 10.04 64bit on tuesday and the mute button was working out of the box.

Scott Lavender (slavender) wrote :

@ Lorenzo

I'm not sure how that worked for you. The patch was applied to version 1:2.8.6.1-1ubuntu0.1 which Launchpad lists in -Proposed only.

@Martin,

I'm having trouble testing this because I cannot get Synaptic to show 2.8.6.1-1ubuntu0.1.

I enabled -proposed under Software Sources -> Updates but when I refresh the sources in Synaptic it still shows 1:2.8.6-1 only.

Scott Lavender (slavender) wrote :

I see the problem, version 2.8.6.1-1ubuntu0.1 failed to build for i386 :(

https://launchpad.net/ubuntu/+source/ardour/1:2.8.6-1ubuntu0.1

Lorenzo Bicci (bicci) wrote :

I don't know why, but I swear it worked out of the box!
I don't know if it could be relevant, but it was installed from a DVD downloaded not more than two weeks ago.

I subscribed this bug because it affected me on another machine on which I had installed Ubuntu Studio 64bit in June.

Martin Pitt (pitti) wrote :

Ah, so Lorenzo probably tested the 64 bit version. The i386 build failure looks weird; I retried it, let's see whether it works better this time.

Martin Pitt (pitti) wrote :

i386 built now, will be available on the mirrors in about two hours. Can you please test again? Thanks!

Scott Lavender (slavender) wrote :

Martin,

I will test this tonight.

Scott Lavender (slavender) wrote :

Martin,

On a fresh, vanilla Lucid install I enabled the lucid-proposed repository, refreshed my sources, and installed ardour 1:2.8.6-1ubuntu0.1.

After adding myself to the audio group and rebooting I was able to start JACK via qjackctl and then Ardour. The Ardour tracks were muted as expected and desired.

Good job!

Martin Pitt (pitti) on 2010-09-17
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ardour - 1:2.8.6-1ubuntu0.1

---------------
ardour (1:2.8.6-1ubuntu0.1) lucid-proposed; urgency=low

  * Applied 120_mute_patch to enable mute button by default (LP: #581786)
  * (Closes: #582938)
 -- Scott Lavender <email address hidden> Sat, 22 May 2010 15:07:57 -0500

Changed in ardour (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.