wubi and ubuntu studio

Bug #1070682 reported by jay halitzer on 2012-10-24
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Studio
Fix Released
Undecided
Unassigned
Wubi
Undecided
Unassigned

Bug Description

I download the ubuntustudio from the link that was suggested and there was a wubi.exe windows installer included. But when i execute the file there is still only Ubuntu, Kubuntu, Mythbuntu, Edubuntu and Lubuntu that are available in the list to install.
Any other ideas would be appreciated.

Note: Ubuntu studio also does not have the package lupin-support installed. This is required by Wubi in order to generate the grub menu entries to boot from a loop-mounted install.

Related branches

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1070682/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
bcbc (bcbc) on 2012-10-24
affects: ubuntu → ubuntustudio
jay halitzer (jayhalitzer) wrote :

The Ubuntu studio version that I'm attempting to install is the latest 12.10 and the current o/s I have is windows 7 Home Premium 32-bit.

Howard Chan (smartboyhw) wrote :

We are going to put this into our blueprint for the R cycle. Do please wait.

Changed in ubuntustudio:
assignee: nobody → Ubuntu Studio Development Team (ubuntustudio-dev)
status: New → Opinion
bcbc (bcbc) on 2012-11-02
description: updated
Howard Chan (smartboyhw) on 2012-11-15
Changed in ubuntustudio:
status: Opinion → In Progress
assignee: Ubuntu Studio Development Team (ubuntustudio-dev) → Howard Chan (smartboyhw)
assignee: Howard Chan (smartboyhw) → Ubuntu Studio Development Team (ubuntustudio-dev)
bcbc (bcbc) wrote :

Howard Chan, Just curious if you tested your change yet. I got Ubuntu Studio to run with Wubi, but there was an issue matching the .disk/info with the space in "Ubuntu Studio" and Wubi finding the image files (it used the same string to match). If you're interested here's my version (there are some other changes in there too): https://docs.google.com/folder/d/0B7WusWpqHR-4Mk5oRUdVWjMtNHM/edit

God don't add Xubuntu.....They asked to delete it....
On 2012-11-16 上午4:15, "bcbc" <email address hidden> wrote:

> Howard Chan, Just curious if you tested your change yet. I got Ubuntu
> Studio to run with Wubi, but there was an issue matching the .disk/info
> with the space in "Ubuntu Studio" and Wubi finding the image files (it
> used the same string to match). If you're interested here's my version
> (there are some other changes in there too):
> https://docs.google.com/folder/d/0B7WusWpqHR-4Mk5oRUdVWjMtNHM/edit
>
> --
> You received this bug notification because you are subscribed to Ubuntu
> Studio.
> Matching subscriptions: Ubuntu Studio
> https://bugs.launchpad.net/bugs/1070682
>
> Title:
> wubi and ubuntu studio
>
> Status in Ubuntu Studio Project:
> In Progress
> Status in Wubi, Windows Ubuntu Installer:
> New
>
> Bug description:
> I download the ubuntustudio from the link that was suggested and there
> was a wubi.exe windows installer included. But when i execute the file
> there is still only Ubuntu, Kubuntu, Mythbuntu, Edubuntu and Lubuntu that
> are available in the list to install.
> Any other ideas would be appreciated.
>
> Note: Ubuntu studio also does not have the package lupin-support
> installed. This is required by Wubi in order to generate the grub menu
> entries to boot from a loop-mounted install.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntustudio/+bug/1070682/+subscriptions
>

bcbc (bcbc) wrote :

My changes aren't intended to be promoted. As such, it makes no difference whether I add Xubuntu or not.
I was trying to point out the issue with the space in the name, not suggesting you implement any of my changes.

Howard Chan (smartboyhw) on 2012-11-16
Changed in wubi:
status: New → In Progress
assignee: nobody → Howard Chan (smartboyhw)
Howard Chan (smartboyhw) wrote :
Changed in wubi:
status: In Progress → Fix Released
Changed in ubuntustudio:
status: In Progress → Fix Released
assignee: Ubuntu Studio Development Team (ubuntustudio-dev) → Howard Chan (smartboyhw)
bcbc (bcbc) wrote :

Howard, I see you removed the space from Ubuntu Studio so it can find the image files, but that's also checked against the .disk/info file on the ISO and it has to match. It's "Ubuntu Studio" in the .disk/info.

In my own version of wubi.exe, having no control over the ISO, I modified Wubi to strip out spaces before checking (I used UbuntuStudio as the name when I did it) but in yours you used a hyphen (Ubuntu-studio).

My workaround was like this:
=== modified file 'src/wubi/backends/common/distro.py'
--- src/wubi/backends/common/distro.py 2012-04-24 15:57:38 +0000
+++ src/wubi/backends/common/distro.py 2012-11-02 09:04:33 +0000
@@ -163,10 +163,12 @@
             log.debug('could not get info %s' % info)
             return False
         name, version, subversion, arch = info # used in backend as well
- if self.name and name != self.name:
- log.debug('wrong name: %s != %s' % (name, self.name))
+
+ # strip out space from distro name - takes care of 'Ubuntu Studio'
+ if self.name and name.replace(' ','') != self.name:
+ log.debug('wrong name: %s != %s' % (name.replace(' ',''), self.name))
             return False

But that's not a great solution. The better solution would be to change the .disk/info file to match unless it's required.

Howard Chan (smartboyhw) wrote :

bcbc, here is the problem.
1. I saw in .disk/info in the 12.10 final release live DVD that it is Ubuntu-Studio. So I think it is a match.
2. Let me see how to change the info file. That in all is a better solution.

bcbc (bcbc) wrote :

Ah, you're right. I didn't check that - all I saw was the error log when I tested it that showed it as "Ubuntu Studio". So I took a look at the code, and this is the reason why (it replaces the '-' with ' ' in the name):

    def parse_isoinfo(self, info):
        '''
        Parses the file within the ISO
        that contains metadata on the iso
        e.g. .disk/info in Ubuntu
        Ubuntu 9.04 "Jaunty Jackalope" - Alpha i386 (20090106)
        Ubuntu 9.04 "Jaunty Jackalope" - Alpha i386 (20090106.1)
        Ubuntu Split Name 9.04.1 "Jaunty Jackalope" - Final Release i386 (20090106.2)
        '''
        log.debug(" parsing info from str=%s" % info)
        if not info:
            return
        info = disk_info_re.match(info)
        name = info.group('name').replace('-', ' ')
        version = info.group('version')
        subversion = info.group('subversion')
        arch = info.group('arch')
        log.debug(" parsed info=%s" % info.groupdict())
        return name, version, subversion, arch

Howard Chan (smartboyhw) wrote :

Hmm bcbc we should then change the code for that....... Can you try getting rid of the replace thing in info.group('name').replace('-', ' ') and see if it works?

bcbc (bcbc) wrote :

I was thinking that maybe the problem isn't replacing the '-' with spaces. This makes it more user friendly in the GUI as it shows "Ubuntu Studio" in the drop down box, not "Ubuntu-Studio". The problem is that it's not escaping the image file names properly. It shouldn't have an issue problem copying "Ubuntu Studio.ico". It does that in backends/win32/backend.py. Then you can use the more user friendly "Ubuntu Studio" and it will match the .disk/info.

Here is the error from my first version (that used "Ubuntu Studio"):
11-02 01:31 DEBUG WindowsBackend: Copying C:\Users\bcbc_~1\AppData\Local\Temp\pyl7B56.tmp\data\images\Ubuntu\ Studio.ico -> C:\ubuntu\Ubuntu\ Studio.ico
11-02 01:31 ERROR TaskList: [Errno 2] No such file or directory: 'C:\\Users\\bcbc_~1\\AppData\\Local\\Temp\\pyl7B56.tmp\\data\\images\\Ubuntu\\ Studio.ico'
Traceback (most recent call last):
  File "\lib\wubi\backends\common\tasklist.py", line 197, in __call__
  File "\lib\wubi\backends\win32\backend.py", line 160, in copy_installation_files
  File "\lib\shutil.py", line 38, in copyfile

bcbc (bcbc) wrote :

Actually that debug output doesn't look like an escaping error; it just says the .ico file is missing (not tripping up on the spaces). I'll try it again today and let you know what I find.

Howard Chan (smartboyhw) wrote :

bcbc, here's what I want you to try.

1. ONLY rename all Ubuntu-Studio.ico images to Ubuntu Studio.ico (likewise
for headers and vertical) and try to install.

2. Remove the replace space with hyphen code in the
/src/wubi/backend/common/distro.py and try to install.

Post back the results here.
On 2012-11-18 上午1:30, "bcbc" <email address hidden> wrote:

> Actually that debug output doesn't look like an escaping error; it just
> says the .ico file is missing (not tripping up on the spaces). I'll try
> it again today and let you know what I find.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1070682
>
> Title:
> wubi and ubuntu studio
>
> Status in Ubuntu Studio Project:
> Fix Released
> Status in Wubi, Windows Ubuntu Installer:
> Fix Released
>
> Bug description:
> I download the ubuntustudio from the link that was suggested and there
> was a wubi.exe windows installer included. But when i execute the file
> there is still only Ubuntu, Kubuntu, Mythbuntu, Edubuntu and Lubuntu that
> are available in the list to install.
> Any other ideas would be appreciated.
>
> Note: Ubuntu studio also does not have the package lupin-support
> installed. This is required by Wubi in order to generate the grub menu
> entries to boot from a loop-mounted install.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntustudio/+bug/1070682/+subscriptions
>

bcbc (bcbc) wrote :

That's the plan. By the way, do you have Windows on your computer? Or in a VM?

bcbc (bcbc) wrote :

The wubi build fails when the image files have a space in the name. I'm investigating...

bcbc (bcbc) wrote :

There's a problem in 7-zip. This is what it looks like when there is a space in data/images/Ubuntu Studio-vertical.bmp:
=========================================================
7-Zip 4.64 Copyright (c) 1999-2009 Igor Pavlov 2009-01-03

Scanning

Updating archive ../archive.7z

System error:

Creating self extracting file Z:\home\bcbc\wubi\build\application.exe
mv build/application.exe build/wubi.exe
=========================================================

And this is what it looks like after I rename it to UbuntuStudio-vertical.bmp:
=========================================================
7-Zip 4.64 Copyright (c) 1999-2009 Igor Pavlov 2009-01-03

Scanning

Updating archive ../archive.7z

Compressing winboot\wubildr
Compressing data\images\preferences-desktop-locale.png
Compressing data\images\desktop.bmp
Compressing data\images\disksize.bmp
Compressing data\images\Edubuntu-header.bmp
Compressing data\images\Edubuntu-vertical.bmp
Compressing data\images\install.bmp
Compressing data\images\Kubuntu-header.bmp
Compressing data\images\Kubuntu-vertical.bmp
Compressing data\images\language.bmp
Compressing data\images\lock.bmp
Compressing data\images\Lubuntu-header.bmp
Compressing data\images\Lubuntu-vertical.bmp
Compressing data\images\Mythbuntu-header.bmp
Compressing data\images\Mythbuntu-vertical.bmp
Compressing data\images\Ubuntu-header.bmp
Compressing data\images\Ubuntu-vertical.bmp
Compressing data\images\UbuntuStudio-header.bmp
Compressing data\images\UbuntuStudio-vertical.bmp
Compressing data\images\user.bmp
Compressing data\images\Xubuntu-header.bmp
Compressing data\images\Xubuntu-vertical.bmp
Compressing data\images\Edubuntu.ico
Compressing data\images\Kubuntu.ico
Compressing data\images\Lubuntu.ico
Compressing data\images\Mythbuntu.ico
Compressing data\images\Ubuntu.ico
Compressing data\images\UbuntuStudio.ico
Compressing data\images\Wubi.ico
Compressing data\images\Xubuntu.ico
Compressing winboot\wubildr.tar
Compressing lib\wubi\frontends\win32\accessibility_page.pyo
Compressing lib\encodings\aliases.pyo
Compressing lib\openpgp\sap\api.pyo
---<DELETED MANY LINES FOR BREVITY>---
Compressing bin\cygwin1.dll
Compressing bin\Formats\iso.dll
Compressing python23.dll

Everything is Ok
Creating self extracting file Z:\home\bcbc\wubi\build\application.exe
mv build/application.exe build/wubi.exe
=========================================================

bcbc (bcbc) wrote :

Howard, I think my environment is corrupted. I didn't have the same problem on my precise wubi.exe. So I'm going to delete and start over fresh.

bcbc (bcbc) wrote :

This works... but the icon switching doesn't work (it isn't loading the images with the space in the name):
bcbc@13:23:07:~/wubi$ bzr diff
=== added file 'data/images/Ubuntu Studio-header.bmp'
Binary files data/images/Ubuntu Studio-header.bmp 1970-01-01 00:00:00 +0000 and data/images/Ubuntu Studio-header.bmp 2012-11-18 20:23:24 +0000 differ
=== added file 'data/images/Ubuntu Studio-vertical.bmp'
Binary files data/images/Ubuntu Studio-vertical.bmp 1970-01-01 00:00:00 +0000 and data/images/Ubuntu Studio-vertical.bmp 2012-11-18 20:23:24 +0000 differ
=== added file 'data/images/Ubuntu Studio.ico'
Binary files data/images/Ubuntu Studio.ico 1970-01-01 00:00:00 +0000 and data/images/Ubuntu Studio.ico 2012-11-18 20:23:24 +0000 differ
=== removed file 'data/images/Ubuntu-Studio-header.bmp'
Binary files data/images/Ubuntu-Studio-header.bmp 2012-11-15 11:51:50 +0000 and data/images/Ubuntu-Studio-header.bmp 1970-01-01 00:00:00 +0000 differ
=== removed file 'data/images/Ubuntu-Studio-vertical.bmp'
Binary files data/images/Ubuntu-Studio-vertical.bmp 2012-11-15 11:51:50 +0000 and data/images/Ubuntu-Studio-vertical.bmp 1970-01-01 00:00:00 +0000 differ
=== removed file 'data/images/Ubuntu-Studio.ico'
Binary files data/images/Ubuntu-Studio.ico 2012-11-15 11:51:50 +0000 and data/images/Ubuntu-Studio.ico 1970-01-01 00:00:00 +0000 differ
=== modified file 'data/isolist.ini'
--- data/isolist.ini 2012-11-16 07:01:12 +0000
+++ data/isolist.ini 2012-11-18 21:22:26 +0000
@@ -120,26 +120,26 @@
 website=http://lubuntu.net
 ordering=7

-[Ubuntu-Studio-i386]
+[Ubuntu Studio-i386]
 min_iso_size=1500000000
 max_iso_size=3500000000
 min_disk_space_mb=10000
 min_memory_mb=512
 arch=i386
-name=Ubuntu-Studio
+name=Ubuntu Studio
 packages=ubuntustudio-desktop
 metalink=http://cdimage.ubuntu.com/ubuntustudio/releases/12.10/release/ubuntustudio-12.10-dvd-i386.metalink
 metalink2=http://cdimage.ubuntu.com/ubuntustudio/dvd/current/quantal-dvd-i386.metalink
 website=http://ubuntustudio.org
 ordering=8

-[Ubuntu-Studio-amd64]
+[Ubuntu Studio-amd64]
 min_iso_size=1500000000
 max_iso_size=3500000000
 min_disk_space_mb=10000
 min_memory_mb=512
 arch=amd64
-name=Ubuntu-Studio
+name=Ubuntu Studio
 packages=ubuntustudio-desktop
 metalink=http://cdimage.ubuntu.com/ubuntustudio/releases/12.10/release/ubuntustudio-12.10-dvd-amd64.metalink
 metalink2=http://cdimage.ubuntu.com/ubuntustudio/dvd/current/quantal-dvd-amd64.metalink

I built it on quantal because I have the 12.10 dvd already downloaded.

Howard Chan (smartboyhw) wrote :

bcbc, can you try to discuss it in LP Bug #1080090 please? That is a better side to discuss...

jay halitzer (jayhalitzer) wrote :

hi howard,
I wasn't sure if you guys fixed the wubi.exe to install ubuntu studio. I
downloaded it again but when I tried the wubi.exe it still doesn't list the
ubuntu studio to install. Is there another place do get the working one
that you guys workrd on?

On Mon, Nov 19, 2012 at 4:36 AM, Howard Chan <email address hidden> wrote:

> bcbc, can you try to discuss it in LP Bug #1080090 please? That is a
> better side to discuss...
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1070682
>
> Title:
> wubi and ubuntu studio
>
> Status in Ubuntu Studio Project:
> Fix Released
> Status in Wubi, Windows Ubuntu Installer:
> Fix Released
>
> Bug description:
> I download the ubuntustudio from the link that was suggested and there
> was a wubi.exe windows installer included. But when i execute the file
> there is still only Ubuntu, Kubuntu, Mythbuntu, Edubuntu and Lubuntu that
> are available in the list to install.
> Any other ideas would be appreciated.
>
> Note: Ubuntu studio also does not have the package lupin-support
> installed. This is required by Wubi in order to generate the grub menu
> entries to boot from a loop-mounted install.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntustudio/+bug/1070682/+subscriptions
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints