Error: divide by zero

Bug #1839182 reported by Antonio Roberts on 2019-08-06
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntustudio-installer
Fix Released
Undecided
Len Ovens
ubuntustudio-installer (Ubuntu)
Undecided
Ubuntu Studio Development

Bug Description

I'm trying to install some ubuntustudio packages (low latency kernel and settings) on top of Ubuntu 19.04 using the ubuntustudio-installer gui. At a certain point the installer crashes and reports the following error:

divide by zero
divide by zero
    while executing
"expr 300 + (200 / $nofl * $pct)"
    (procedure "pctunpk" line 2)
    invoked from within
"pctunpk $unpk $getcnt"
    (procedure "install" line 75)
    invoked from within
"install"
    invoked from within
".install invoke"
    ("uplevel" body line 1)
    invoked from within
"uplevel #0 [list $w invoke]"
    (procedure "tk::ButtonUp" line 22)
    invoked from within
"tk::ButtonUp .install"
    (command bound to event)

I've tried installing the same packages on a Dell XPS 13 and Dell XPS 15 and they both hang at different moments during the installer, but both whilst trying to unpack packages.

On one computer it stalled when installing the lowlatency kernel and on the other it stalled when installing a different package but unfortunately I didn't note down which one.

After about 20 minutes of waiting for the progress bar to complete (it didn't) I restarted my computer and everything appears to be working but I have no way to be sure.

ProblemType: Bug
DistroRelease: Ubuntu 19.04
Package: ubuntustudio-installer 0.04~19.04.1
ProcVersionSignature: Ubuntu 5.0.0-23.24-lowlatency 5.0.15
Uname: Linux 5.0.0-23-lowlatency x86_64
NonfreeKernelModules: nvidia_modeset nvidia
ApportVersion: 2.20.10-0ubuntu27.1
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Tue Aug 6 18:12:45 2019
InstallationDate: Installed on 2018-06-18 (414 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
PackageArchitecture: all
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: ubuntustudio-installer
UpgradeStatus: Upgraded to disco on 2019-04-19 (109 days ago)

Antonio Roberts (hellocatfood) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntustudio-installer (Ubuntu):
status: New → Confirmed
hamish cunningham (hamish-dcs) wrote :

Similar error for me using the PPA and ubuntu-studio installer on Ubuntu 18.04.

Changed in ubuntustudio-installer (Ubuntu):
assignee: nobody → Ubuntu Studio Development (ubuntustudio-dev)
Changed in ubuntustudio-installer:
status: New → Confirmed
assignee: nobody → Len Ovens (len-ovenwerks)
Changed in ubuntustudio-installer:
status: Confirmed → In Progress
Changed in ubuntustudio-installer (Ubuntu):
status: Confirmed → In Progress
Changed in ubuntustudio-installer:
status: In Progress → Fix Committed
Changed in ubuntustudio-installer (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntustudio-installer - 0.06

---------------
ubuntustudio-installer (0.06) eoan; urgency=medium

  [ Len Ovens ]
  * Fix progress bar math (LP: #1839182)

 -- Erich Eickmeyer <email address hidden> Thu, 29 Aug 2019 19:27:10 -0700

Changed in ubuntustudio-installer (Ubuntu):
status: Fix Committed → Fix Released
summary: - Error: divie by zero
+ Error: divide by zero
Changed in ubuntustudio-installer:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers