Activity log for bug #1833740

Date Who What changed Old value New value Message
2019-06-21 16:31:37 Erich Eickmeyer bug added bug
2019-06-21 16:50:19 Erich Eickmeyer attachment added Debdiff of ubuntustudio-installer 0.04 compared to 0.02 (in disco) https://bugs.launchpad.net/ubuntustudio-installer/+bug/1833740/+attachment/5272147/+files/ubuntustudio-installer_0.04.debdiff
2019-06-21 16:51:15 Erich Eickmeyer bug task added ubuntustudio-installer (Ubuntu)
2019-06-21 16:51:22 Erich Eickmeyer ubuntustudio-installer (Ubuntu): status New Confirmed
2019-06-21 16:52:58 Erich Eickmeyer ubuntustudio-installer: status Confirmed Fix Released
2019-06-21 16:54:08 Erich Eickmeyer bug added subscriber Ubuntu Sponsors Team
2019-06-21 16:54:26 Erich Eickmeyer tags disco
2019-06-21 19:09:04 Thomas Ward nominated for series Ubuntu Disco
2019-06-21 19:09:04 Thomas Ward bug task added ubuntustudio-installer (Ubuntu Disco)
2019-06-21 19:09:04 Thomas Ward nominated for series Ubuntu Eoan
2019-06-21 19:09:04 Thomas Ward bug task added ubuntustudio-installer (Ubuntu Eoan)
2019-06-21 19:35:56 Erich Eickmeyer attachment removed Debdiff of ubuntustudio-installer 0.04 compared to 0.02 (in disco) https://bugs.launchpad.net/ubuntustudio-installer/+bug/1833740/+attachment/5272147/+files/ubuntustudio-installer_0.04.debdiff
2019-06-21 21:09:04 Erich Eickmeyer ubuntustudio-installer (Ubuntu Eoan): status Confirmed Fix Released
2019-06-21 21:09:20 Erich Eickmeyer ubuntustudio-installer (Ubuntu Disco): assignee Erich Eickmeyer (eeickmeyer)
2019-06-21 21:09:24 Erich Eickmeyer ubuntustudio-installer (Ubuntu Eoan): assignee Erich Eickmeyer (eeickmeyer)
2019-06-21 21:12:09 Erich Eickmeyer ubuntustudio-installer (Ubuntu Disco): status New Fix Committed
2019-06-21 21:15:10 Erich Eickmeyer attachment added ubuntustudio-installer_0.04~19.04.1.debdiff https://bugs.launchpad.net/ubuntu/+source/ubuntustudio-installer/+bug/1833740/+attachment/5272228/+files/ubuntustudio-installer_0.04~19.04.1.debdiff
2019-06-21 21:27:52 Erich Eickmeyer ubuntustudio-installer (Ubuntu Disco): assignee Erich Eickmeyer (eeickmeyer)
2019-06-21 21:56:55 Erich Eickmeyer ubuntustudio-installer (Ubuntu Disco): status Fix Committed In Progress
2019-06-23 19:29:22 Mathew Hodson ubuntustudio-installer (Ubuntu Disco): importance Undecided Medium
2019-06-23 19:29:26 Mathew Hodson ubuntustudio-installer (Ubuntu Eoan): importance Undecided Medium
2019-07-01 08:18:34 Łukasz Zemczak ubuntustudio-installer (Ubuntu Disco): status In Progress Fix Committed
2019-07-01 08:18:36 Łukasz Zemczak bug added subscriber Ubuntu Stable Release Updates Team
2019-07-01 08:18:38 Łukasz Zemczak bug added subscriber SRU Verification
2019-07-01 08:18:41 Łukasz Zemczak tags disco disco verification-needed verification-needed-disco
2019-07-01 15:43:00 Erich Eickmeyer description [Impact] * Users of desktops other than GNOME are erroneously installing "ubuntustudio-gnome-branding" from the package selection, causing gdm3 and all of gnome-shell to be pulled-in as dependencies. Users of desktops other than GNOME, especially if new to Linux, don't know any better and select it regardless. * While pulling-in and configuring gdm3, dpkg waits for the user to select between gdm3 and an already-installed DM, such as lightdm or sddm. * This upload fixes this by eliminating the "ubuntustudio-gnome-branding" from the selection. [Test Case] * Using any flavor other than Ubuntu proper (i.e. the GNOME) desktop, install and run ubuntustudio-installer, selecting "ubuntustudio-gnome-branding" as an option. Click the "Install" button. * Installer will hang while awaiting DM selection instructions from the user, but are not available due to the way Ubuntu Studio Installer's tk/tcl script functions (does not present a selection dialog). [Regression Potential] * Since nothing depends on ubuntustudio-installer to run functionally, there is no regression potential. [Other Info] * This was not done originally as it was thought that users would actually read the description of the package explaining that it's for the default GNOME desktop only. Unfortunately, questions on askubuntu.com and in the IRC chat room have appeared with this very issue. [Impact]  * Users of desktops other than GNOME are erroneously installing "ubuntustudio-gnome-branding" from the package selection, causing gdm3 and all of gnome-shell to be pulled-in as dependencies. Users of desktops other than GNOME, especially if new to Linux, don't know any better and select it regardless.  * While pulling-in and configuring gdm3, dpkg waits for the user to select between gdm3 and an already-installed DM, such as lightdm or sddm.  * This upload fixes this by eliminating the "ubuntustudio-gnome-branding" from the selection. [Test Case]  * Using any flavor other than Ubuntu proper (i.e. the GNOME) desktop, install and run ubuntustudio-installer, selecting "ubuntustudio-gnome-branding" as an option. Click the "Install" button.  * Installer will hang while awaiting DM selection instructions from the user, but are not available due to the way Ubuntu Studio Installer's tk/tcl script functions (does not present a selection dialog). * New version does not include "ubuntustudio-gnome-branding" as a selection, so test case for new version should no longer show "ubuntustudio-gnome-branding" as a selection. [Regression Potential]  * Since nothing depends on ubuntustudio-installer to run functionally, there is no regression potential. [Other Info]  * This was not done originally as it was thought that users would actually read the description of the package explaining that it's for the default GNOME desktop only. Unfortunately, questions on askubuntu.com and in the IRC chat room have appeared with this very issue.
2019-07-01 15:44:24 Erich Eickmeyer tags disco verification-needed verification-needed-disco disco verification-done-disco verification-needed-disco
2019-07-01 15:44:39 Erich Eickmeyer tags disco verification-done-disco verification-needed-disco disco verification-done-disco
2019-07-06 19:06:23 Erich Eickmeyer ubuntustudio-installer (Ubuntu Eoan): assignee Erich Eickmeyer (eeickmeyer)
2019-07-08 21:58:25 Erich Eickmeyer description [Impact]  * Users of desktops other than GNOME are erroneously installing "ubuntustudio-gnome-branding" from the package selection, causing gdm3 and all of gnome-shell to be pulled-in as dependencies. Users of desktops other than GNOME, especially if new to Linux, don't know any better and select it regardless.  * While pulling-in and configuring gdm3, dpkg waits for the user to select between gdm3 and an already-installed DM, such as lightdm or sddm.  * This upload fixes this by eliminating the "ubuntustudio-gnome-branding" from the selection. [Test Case]  * Using any flavor other than Ubuntu proper (i.e. the GNOME) desktop, install and run ubuntustudio-installer, selecting "ubuntustudio-gnome-branding" as an option. Click the "Install" button.  * Installer will hang while awaiting DM selection instructions from the user, but are not available due to the way Ubuntu Studio Installer's tk/tcl script functions (does not present a selection dialog). * New version does not include "ubuntustudio-gnome-branding" as a selection, so test case for new version should no longer show "ubuntustudio-gnome-branding" as a selection. [Regression Potential]  * Since nothing depends on ubuntustudio-installer to run functionally, there is no regression potential. [Other Info]  * This was not done originally as it was thought that users would actually read the description of the package explaining that it's for the default GNOME desktop only. Unfortunately, questions on askubuntu.com and in the IRC chat room have appeared with this very issue. [Impact]  * Users of desktops other than GNOME are erroneously installing "ubuntustudio-gnome-branding" from the package selection, causing gdm3 and all of gnome-shell to be pulled-in as dependencies. Users of desktops other than GNOME, especially if new to Linux, don't know any better and select it regardless.  * While pulling-in and configuring gdm3, dpkg waits for the user to select between gdm3 and an already-installed DM, such as lightdm or sddm.  * This upload fixes this by eliminating the "ubuntustudio-gnome-branding" from the selection. [Test Case]  * Using any flavor other than Ubuntu proper (i.e. the GNOME) desktop, install and run ubuntustudio-installer, selecting "ubuntustudio-gnome-branding" as an option. Click the "Install" button.  * Installer will hang while awaiting DM selection instructions from the user, but are not available due to the way Ubuntu Studio Installer's tk/tcl script functions (does not present a selection dialog).  * New version does not include "ubuntustudio-gnome-branding" as a selection, so test case for new version should no longer show "ubuntustudio-gnome-branding" as a selection. 1. Open ubuntustudio-installer 2. Check to see if ubuntustudio-gnome-branding is an option for installation. - if NO, verification-done - if YES, bug still exists [Regression Potential]  * Since nothing depends on ubuntustudio-installer to run functionally, there is no regression potential. [Other Info]  * This was not done originally as it was thought that users would actually read the description of the package explaining that it's for the default GNOME desktop only. Unfortunately, questions on askubuntu.com and in the IRC chat room have appeared with this very issue.
2019-07-08 22:08:28 Launchpad Janitor ubuntustudio-installer (Ubuntu Disco): status Fix Committed Fix Released
2019-07-08 22:08:32 Brian Murray removed subscriber Ubuntu Stable Release Updates Team