Ubuntu One hangs

Bug #1108045 reported by Boyan Sotirov on 2013-01-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu One Windows Installer
High
Brian Curtin

Bug Description

I noticed that my Ubuntu One installation (version 4.0.0) doesn't work properly. When I try to open it, it hangs on "Getting information, please wait..." and this goes on forever.
I noticed that the proxy.log provides an error that the connection was closed by the proxy server. Indeed there's a proxy server, but the connection shouldn't go over the proxy server. I have a local routing table on my Windows 7 setup that routes all the unknown traffic over a clear Internet connection. Few days ago I tried it over a connection without any proxies involved, the result was the same.
Also the syncdeamon-exception.log shows some errors.
I'll attach all the logs I found. Let me know if I could do any more specific tests.

Boyan Sotirov (lz1dsb) wrote :
Boyan Sotirov (lz1dsb) wrote :
Boyan Sotirov (lz1dsb) wrote :
Boyan Sotirov (lz1dsb) wrote :
Boyan Sotirov (lz1dsb) wrote :
Julien Funk (jaboing) on 2013-01-28
Changed in ubuntuone-windows-installer:
status: New → Confirmed
importance: Undecided → High
status: Confirmed → Triaged
assignee: nobody → Brian Curtin (brian.curtin)
tags: added: u1-by-user u1-on-production u1-windows
Boyan Sotirov (lz1dsb) wrote :

A little update from my side. It seems like the whole issue is related to the proxy server used in the office where I work. I mentioned that I saw such an error in the proxy.log.
Today I took my office laptop at home and there was no issue. The Ubuntu One folder was synchronized without any issue.
In order to further troubleshoot this, which looks like a networking issue... How is the Ubuntu One for Windows app determining whether to use proxy or not. A bit more about my setup:
1. I use a wired connection.
2. I use a statically configured gateway to exit out of the office network, bypassing the proxy that way.
3. I use static routing for the office networks, which off course are routed through the proxy server.

I've got the impression, that with this setup Ubuntu One is still trying to exit the office network through the proxy server, even though the default gateway (statically configured) is pointing to a gateway which bypasses the proxy server.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers