ubuntu one crashes on first attempt to log in

Bug #1096105 reported by Niels Viggo Hansen on 2013-01-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu One Windows Installer
Critical
Brian Curtin

Bug Description

Just installed ubuntu one on one ubuntu and two windows machnes. On the second windows machine (windows 7 home 64 bit, with "ubuntuone-4.0.0-windows-installer" ubuntu one crashes on the welcome screen. No matter if I choose "sign in with existing account" or "I dont have an account yet", I get

---------------------------
Ubuntu One experienced an error
---------------------------
Sorry, an error has occurred and Ubuntu One needs to close.
---------------------------
Close Hide Details...
---------------------------
ZipImportError
bad local file header in C:\Program Files (x86)\ubuntuone\dist\library.zip

Julien Funk (jaboing) on 2013-01-04
Changed in ubuntuone-windows-installer:
importance: Undecided → Critical
status: New → Confirmed
assignee: nobody → Brian Curtin (brian.curtin)
tags: added: by-user on-production u1-windows
Brian Curtin (brian.curtin) wrote :

Can you try re-downloading the installer from https://one.ubuntu.com/windows/ubuntuone-4.0.0-windows-installer.exe

It seems like the download may have been corrupted. I'm able to install 4.0.0 on several OSes and no one else has reported this same error, so it feels unlikely that it's a problem in the codebase.

Niels Viggo Hansen (nv-7) wrote :

Thanks for attending!

I uninstalled, downloaded again form the URL in Brian's email, reinstalled.

The exact same thing happens again.

In fact I am not sure I am the only one who experienced this. It seems to be uncommon but existing. Maybe a collision with a particular kind of driver, etc?. A google search for the error message returns one or two reports that seem to describe the same phenomenon. Here's one: http://askubuntu.com/questions/230457/sorry-ubuntu-one-has-encountered-and-error-and-needs-to-close

There's also a suggestion of a fix - unfortunately I can't make any sense of it.

Brian Curtin (brian.curtin) wrote :

Darn, I was hoping that would have fixed it. I'm able to reproduce this problem now but by doing something entirely unrelated, and something I can't imagine anyone else would ever be doing (I only did it by mistake, actually).

I'll dig around and see if I can find out why this is happening for you.

Julien Funk (jaboing) on 2013-01-16
tags: added: u1-on-production
Julien Funk (jaboing) on 2013-01-16
tags: added: u1-by-user
Julien Funk (jaboing) on 2013-01-17
tags: removed: by-user
Julien Funk (jaboing) on 2013-01-17
tags: removed: on-production
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers