Uninstalling python-ubuntuone-storageprotocol removes ValiCert certificate (which is in ca-certificates)

Bug #1037294 reported by Roman Yepishev on 2012-08-15
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ubuntu One storage protocol
Status tracked in Trunk
Stable-3-0
Undecided
Unassigned
Stable-4-0
Undecided
Rodney Dawes
Trunk
Critical
Rodney Dawes
ubuntuone-storage-protocol (Ubuntu)
High
Rodney Dawes
Precise
High
Unassigned
Quantal
High
Rodney Dawes

Bug Description

Steps to reproduce:

$ ls -l /etc/ssl/certs/ValiCert_Class_2_VA.pem
lrwxrwxrwx 1 root root 58 Feb 25 23:59 /etc/ssl/certs/ValiCert_Class_2_VA.pem -> /usr/share/ca-certificates/mozilla/ValiCert_Class_2_VA.crt

$ ls -l /usr/share/ca-certificates/mozilla/ValiCert_Class_2_VA.crt
-rw-r--r-- 1 root root 1066 Feb 8 2012 /usr/share/ca-certificates/mozilla/ValiCert_Class_2_VA.crt

sudo apt-get remove --purge python-ubuntuone-storageprotocol
...

$ ls -l /etc/ssl/certs/ValiCert_Class_2_VA.pem
lrwxrwxrwx 1 root root 58 Feb 25 23:59 /etc/ssl/certs/ValiCert_Class_2_VA.pem -> /usr/share/ca-certificates/mozilla/ValiCert_Class_2_VA.crt

$ ls -l /usr/share/ca-certificates/mozilla/ValiCert_Class_2_VA.crt
ls: cannot access /usr/share/ca-certificates/mozilla/ValiCert_Class_2_VA.crt: No such file or directory

$ sudo apt-get install ubuntuone-client
...
Setting up python-ubuntuone-storageprotocol (4.1+r151-17~precise1) ...
...

$ ls -l /usr/share/ca-certificates/mozilla/ValiCert_Class_2_VA.crt
ls: cannot access /usr/share/ca-certificates/mozilla/ValiCert_Class_2_VA.crt: No such file or directory

This missing certificate prevents all Ubuntu One applications from connecting due to SSL error.

WORKAROUND:

Install the certificate again with

$ sudo apt-get install --reinstall ca-certificates

Related branches

lp:~dobey/ubuntuone-storage-protocol/rename-valicert
Roman Yepishev (community): Approve (fieldtest) on 2012-08-16
Roberto Alsina (community): Approve on 2012-08-16
Roman Yepishev (rye) on 2012-08-15
Changed in ubuntuone-storage-protocol (Ubuntu):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Ubuntu One Desktop+ team (ubuntuone-desktop+)
tags: added: ubuntuone-desktop+
tags: added: desktop+ support
removed: ubuntuone-desktop+
Changed in ubuntuone-storage-protocol:
assignee: nobody → Ubuntu One Desktop+ team (ubuntuone-desktop+)
importance: Undecided → Critical
status: New → Triaged
Rodney Dawes (dobey) on 2012-08-15
visibility: public → private
Roman Yepishev (rye) on 2012-08-16
description: updated
Changed in ubuntuone-storage-protocol:
status: Triaged → Fix Committed
Rodney Dawes (dobey) on 2012-08-22
Changed in ubuntuone-storage-protocol (Ubuntu Precise):
importance: Undecided → High
status: New → Triaged
assignee: nobody → Rodney Dawes (dobey)
Changed in ubuntuone-storage-protocol (Ubuntu Quantal):
assignee: Ubuntu One Desktop+ team (ubuntuone-desktop+) → Rodney Dawes (dobey)
visibility: private → public
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-storage-protocol - 3.99.4-0ubuntu1

---------------
ubuntuone-storage-protocol (3.99.4-0ubuntu1) quantal; urgency=low

  * New upstream release.
    - Rename the ValiCert file to be namespaced as UbuntuOne. (LP: #1037294)
    - Fix test running and cert location handling for darwin.
  * debian/prerm, debian/postinst, debian/postrm:
    - Ensure the ValiCert file remains when U1 is removed. (LP: #1037294)
  * debian/control:
    - Update to allow building on older versions of Ubuntu.
  * debian/copyright:
    - Update to be more in line with dep5.
  * debian/rules:
    - Update to allow building on older versions of Ubuntu.
    - Use the --fail-missing option to dh.
 -- Rodney Dawes <email address hidden> Wed, 22 Aug 2012 13:19:31 -0400

Changed in ubuntuone-storage-protocol (Ubuntu Quantal):
status: Triaged → Fix Released
tags: added: u1-support-escalated
removed: support
Rodney Dawes (dobey) on 2014-01-29
Changed in ubuntuone-storage-protocol (Ubuntu Precise):
assignee: Rodney Dawes (dobey) → nobody
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1037294

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers