Migration from old style delete to new style delete ("trash")

Bug #670700 reported by Vincenzo Di Somma on 2010-11-04
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu One Servers
Medium
Unassigned
desktopcouch
High
Unassigned
desktopcouch (Ubuntu)
High
Unassigned

Bug Description

We need to provide hooks and scripts to migrate from content deleted just with the "deleted" flag to the content moved to the "trash" database.

Related branches

Vincenzo Di Somma (vds) on 2010-11-04
Changed in desktopcouch:
status: New → Confirmed
status: Confirmed → Triaged
importance: Undecided → Medium
Changed in ubuntuone-servers:
status: New → Triaged
importance: Undecided → Medium
Changed in desktopcouch:
assignee: nobody → Vincenzo Di Somma (vds)
Changed in ubuntuone-servers:
assignee: nobody → Eric Casteleijn (thisfred)
milestone: none → post-m-cleanup
Changed in desktopcouch:
milestone: none → 1.0
Eric Casteleijn (thisfred) wrote :

Reprioritized, because we need the migration if the 'deleted' feature is to be in the release.

Changed in desktopcouch:
importance: Medium → High
Changed in desktopcouch (Ubuntu):
status: New → Triaged
assignee: nobody → Vincenzo Di Somma (vds)
milestone: none → natty-alpha-1
dobey (dobey) on 2010-11-24
Changed in desktopcouch:
status: Triaged → Fix Committed
Vincenzo Di Somma (vds) on 2010-11-24
Changed in desktopcouch:
status: Fix Committed → In Progress
Changed in desktopcouch:
assignee: Vincenzo Di Somma (vds) → Eric Casteleijn (thisfred)
Chad Miller (cmiller) on 2010-11-26
Changed in desktopcouch:
status: In Progress → Fix Committed
Changed in desktopcouch:
status: Fix Committed → In Progress
Changed in desktopcouch:
status: In Progress → Fix Committed
Changed in desktopcouch (Ubuntu):
importance: Undecided → High
status: Triaged → In Progress
Changed in desktopcouch (Ubuntu):
assignee: Vincenzo Di Somma (vds) → Eric Casteleijn (thisfred)
Changed in desktopcouch (Ubuntu):
milestone: natty-alpha-1 → natty-alpha-2
Changed in desktopcouch (Ubuntu):
status: In Progress → Fix Released
Changed in desktopcouch:
status: Fix Committed → Fix Released
Changed in ubuntuone-servers:
assignee: Eric Casteleijn (thisfred) → nobody
Changed in desktopcouch:
assignee: Eric Casteleijn (thisfred) → nobody
Changed in desktopcouch (Ubuntu):
assignee: Eric Casteleijn (thisfred) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers