Songs have no valid bitrate information

Bug #655762 reported by BluJai on 2010-10-06
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu One Android Music
Medium
Chad Miller
Ubuntu One Servers
Medium
Unassigned

Bug Description

On both the online "cloud" library and in queue all songs display a size of 0k beside the artist name. Specifically, the text reads "(0k mp3)".

This is currently occurring on a Motorola Droid (Android).

Related branches

BluJai (blujai-gaeana) on 2010-10-06
description: updated
Zach (zackify) wrote :

This happens because the file is not an mp3. Happened to me with some of my .m4a files. They do need a better message when it's not an mp3 though.

Martin Albisetti (beuno) on 2010-10-06
Changed in ubuntuone-android-music:
status: New → Triaged
importance: Undecided → Medium
Zach (zackify) wrote :

I converted my files to mp3 and now it still shows this error. When I play a song it will start but not have a finish time. The song just counts up. I can't move the bar to move to another spot in the song.

Our music scanner does not scan and store the bitrate of the music's encoding. This is a server-side problem, so I'll link this bug report to that project.

For the client, reporting "0k" is wrong, so I'm hiding the bitrate when we don't know it, instead of converting a null value to a numerical zero. For that, I call this problem fixed.

summary: - Songs all display a size of 0k
+ Songs all display a bitrate of 0k
Changed in ubuntuone-android-music:
status: Triaged → Fix Committed
Changed in ubuntuone-servers:
status: New → Confirmed
importance: Undecided → Medium
Changed in ubuntuone-android-music:
assignee: nobody → Chad Miller (cmiller)
Chad Miller (cmiller) on 2010-10-07
Changed in ubuntuone-android-music:
status: Fix Committed → Fix Released
Paul Sladen (sladen) wrote :

And in this case, I'd be expecting "Okay!" and "Not okay!" ;-)

Zach (zackify) wrote :

It's fine for me

Chad Miller (cmiller) on 2010-10-10
summary: - Songs all display a bitrate of 0k
+ Songs have no valid bitrate information
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers