OAuth tokens are not added to Ubuntu One after /sso-finished-so-get-tokens/

Bug #628118 reported by Roman Yepishev
70
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Ubuntu One Servers
High
Alejandro J. Cura

Bug Description

STR:
  1. Make sure SSO account has one e-mail and that email was previously used in Ubuntu One.
  2. Patch ubuntu-sso-client with http->https fix for ping url - LP:627700.
  3. Run ubuntuone-preferences, it will open ubuntu-sso-client; Click on "already have the account" button.
  4. Log into SSO with your credentials, receive "Success!" message. Close the dialog. See that u1sdtool --connect makes syncdaemon go to AUTH_FAILED.
  5. Log into https://login.ubuntu.com/+applications and see that you HAVE the token there;
      Log into https://one.ubuntu.com/account/machines and see that you DON'T have the token there even though ping url returned 200 ( ~/.cache/sso/oauth-login.log)

Roman Yepishev (rye)
visibility: private → public
description: updated
tags: added: desktop+ u1-maverick
Changed in ubuntuone-servers:
assignee: Ubuntu One web team (ubuntuone-web) → Alejandro J. Cura (alecu)
Changed in ubuntuone-servers:
status: Confirmed → In Progress
Changed in ubuntuone-servers:
status: In Progress → Fix Committed
Revision history for this message
Alejandro J. Cura (alecu) wrote :

We've cowboyed a fix for this to the edge servers and it seems to be working right.

John Lenton (chipaca)
Changed in ubuntuone-servers:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers