Share email rejected because it looks like spam

Reported by Duane Hinnen on 2010-07-26
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu One Servers
High
Roman Yepishev

Bug Description

I can share a directory, add a email as target, then message waiting to accept.

In my email I find the reason:
This message was created automatically by mail delivery software.
A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:
  <email address hidden>
    SMTP error from remote mail server after RCPT TO:<email address hidden>:
    host mx1.gmx.net [213.165.64.102]: 550-5.7.1 {mx035} The recipient does not accept mails from 'gmx.de' over foreign mailservers
    550 5.7.1 ( http://portal.gmx.net/serverrules )

my account runs a <email address hidden>.
My wife here account is <email address hidden>

Ubuntu one sends an email by its own mailserver with sender <email address hidden> to <email address hidden>.

GMX.DE reject the email because it looks like spam when another mail server sends as sender gmx.de.

Any suggestion?

Roman Yepishev (rye) wrote :

Our servers should not pretend to send the messages from user's e-mail addresses. In case strict SPF rules are used, the messages will be marked as spam or be completely discarded. The servers can also be configured not to accept any messages that originate on another machines but have From header set to the email of the user.

We need to start sending email with something like <email address hidden> or similar, while stating the email of the user somewhere within the message.

Changed in ubuntuone-client:
assignee: nobody → Ubuntu One web team (ubuntuone-web)
importance: Undecided → Medium
status: New → Confirmed
Rodney Dawes (dobey) on 2010-10-04
affects: ubuntuone-client → ubuntuone-servers
Roman Yepishev (rye) on 2010-12-23
Changed in ubuntuone-servers:
importance: Medium → High
Martin Albisetti (beuno) on 2010-12-23
Changed in ubuntuone-servers:
status: Confirmed → Triaged
assignee: Ubuntu One web team (ubuntuone-web) → Martin Albisetti (beuno)
Richard (r-oostveen) wrote :

is there any information when this bug will be solved?

Eugene Crosser (crosser) wrote :

SPF checks the address in MAIL FROM: command in the SMTP transaction. It does not check the From: header in the message. So, you can use a "legitimate" address in ubuntu.com or canonical.com domain in MAIL FROM:, and the originating user's address in the From: header. This will be clear to the receiving user and will make SPF happy.

Even better if the sharing URL was visible to the sharer, so that [s]he could send it to the recipient via IM or other means.

Mariusz Kraus (marcars) wrote :

Hi there
can yo explain what do you mean with "legitimate" address?? I have too problrm with share folders on domain wp.pl.
And i recive this same massages:
This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:

  <email address hidden>
    SMTP error from remote mail server after MAIL FROM:<email address hidden> SIZE=2476:
    host mx.wp.pl [212.77.101.4]: 550 BLAD SPF - zobacz strone / SPF Error:
    Please see http://spf.pobox.com/why.html?sender=marcars%40wp.pl&ip=91.189.90.139&receiver=smtp.wp.pl Jesli jestes uzytkownikiem poczta.wp.pl sprawdz poprawnosc autoryzacji SMTP / If you are a poczta.wp.pl user check SMTP configuration:
    http://poczta.wp.pl/autoryzacja/

------ This is a copy of the message, including all the headers. ------

Return-path: <email address hidden>
Received: from lardizabala.canonical.com ([91.189.89.53])
 by adelie.canonical.com with esmtp (Exim 4.71 #1 (Debian))
 id 1ROb77-0006ra-97
 for <email address hidden>; Thu, 10 Nov 2011 20:20:45 +0000
Received: from lardizabala.canonical.com (localhost [127.0.0.1])
 by lardizabala.canonical.com (Postfix) with ESMTP id 3182E20A2A1
 for <email address hidden>; Thu, 10 Nov 2011 20:20:45 +0000 (UTC)
Content-Type: text/plain; charset="utf-8"
MIME-Version: 1.0
Content-Transfer-Encoding: quoted-printable
Subject: Mariusz Kraus shared Helion with you via Ubuntu One
From: <email address hidden>
To: <email address hidden>
Date: Thu, 10 Nov 2011 20:20:45 -0000
Message-ID: <email address hidden>

=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D
 Ubuntu One: https://one.ubuntu.com
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

How can i solved that problem??

Download full text (4.3 KiB)

hi mariusz

I do not know why this problem exists, it is a startes problem.

from your error message I copied:
From: <email address hidden>
To: <email address hidden>

you can clear see who is the sended and who is addressed.
The problem is that the sender server wp.pl NEVER sended this email, it was send by ubuntu one.
There for it says it is SPAM.
And wp.pl is correct someone is sended an email with the sender address wp.pl.

I already have this problem for 1,5 years and ubuntu one does not seems to take this serious.

Regards

-------- Original-Nachricht --------
> Datum: Thu, 10 Nov 2011 20:24:12 -0000
> Von: Mariusz Kraus <email address hidden>
> An: <email address hidden>
> Betreff: [Bug 609999] Re: Share email rejected because it looks like spam

> Hi there
> can yo explain what do you mean with "legitimate" address?? I have too
> problrm with share folders on domain wp.pl.
> And i recive this same massages:
> This message was created automatically by mail delivery software.
>
> A message that you sent could not be delivered to one or more of its
> recipients. This is a permanent error. The following address(es) failed:
>
> <email address hidden>
> SMTP error from remote mail server after MAIL FROM:<email address hidden>
> SIZE=2476:
> host mx.wp.pl [212.77.101.4]: 550 BLAD SPF - zobacz strone / SPF
> Error:
> Please see
> http://spf.pobox.com/why.html?sender=marcars%40wp.pl&ip=91.189.90.139&receiver=smtp.wp.pl Jesli jestes uzytkownikiem
> poczta.wp.pl sprawdz poprawnosc autoryzacji SMTP / If you are a poczta.wp.pl user
> check SMTP configuration:
> http://poczta.wp.pl/autoryzacja/
>
> ------ This is a copy of the message, including all the headers. ------
>
> Return-path: <email address hidden>
> Received: from lardizabala.canonical.com ([91.189.89.53])
> by adelie.canonical.com with esmtp (Exim 4.71 #1 (Debian))
> id 1ROb77-0006ra-97
> for <email address hidden>; Thu, 10 Nov 2011 20:20:45 +0000
> Received: from lardizabala.canonical.com (localhost [127.0.0.1])
> by lardizabala.canonical.com (Postfix) with ESMTP id 3182E20A2A1
> for <email address hidden>; Thu, 10 Nov 2011 20:20:45 +0000 (UTC)
> Content-Type: text/plain; charset="utf-8"
> MIME-Version: 1.0
> Content-Transfer-Encoding: quoted-printable
> Subject: Mariusz Kraus shared Helion with you via Ubuntu One
> From: <email address hidden>
> To: <email address hidden>
> Date: Thu, 10 Nov 2011 20:20:45 -0000
> Message-ID: <email address hidden>
>
> =3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
> =3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D
> Ubuntu One: https://one.ubuntu.com
> =3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
> =3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D
>
> How can i solved that problem??
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/609999
>
> Title:
> Share email rejected because it looks like spam
>
> Status in Ubuntu One Servers:
> Triaged
>
> Bug description:
> I can share a directory, add a email as target, then message waiting
> to accept.
>
> In my email I find the reason:
> This message was created automatically by mail de...

Read more...

Mariusz Kraus (marcars) wrote :

Thanks for quick replay.

So you want me to say that is no way to share any folder with my e-mail post on Ubuntu one with another users ?

If not. Is there any solution for this problem?

Richard (r-oostveen) wrote :

hi,

WRONG you can share your folders with any user who is NOT using an email address by wp.pl (<email address hidden>)

regards
r.o
-------- Original-Nachricht --------
> Datum: Sat, 12 Nov 2011 09:18:26 -0000
> Von: Mariusz Kraus <email address hidden>
> An: <email address hidden>
> Betreff: [Bug 609999] Re: Share email rejected because it looks like spam

> Thanks for quick replay.
>
> So you want me to say that is no way to share any folder with my e-mail
> post on Ubuntu one with another users ?
>
> If not. Is there any solution for this problem?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/609999
>
> Title:
> Share email rejected because it looks like spam
>
> Status in Ubuntu One Servers:
> Triaged
>
> Bug description:
> I can share a directory, add a email as target, then message waiting
> to accept.
>
> In my email I find the reason:
> This message was created automatically by mail delivery software.
> A message that you sent could not be delivered to one or more of its
> recipients. This is a permanent error. The following address(es) failed:
> <email address hidden>
> SMTP error from remote mail server after RCPT TO:<email address hidden>:
> host mx1.gmx.net [213.165.64.102]: 550-5.7.1 {mx035} The recipient
> does not accept mails from 'gmx.de' over foreign mailservers
> 550 5.7.1 ( http://portal.gmx.net/serverrules )
>
> my account runs a <email address hidden>.
> My wife here account is <email address hidden>
>
> Ubuntu one sends an email by its own mailserver with sender
> <email address hidden> to <email address hidden>.
>
> GMX.DE reject the email because it looks like spam when another mail
> server sends as sender gmx.de.
>
> Any suggestion?
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntuone-servers/+bug/609999/+subscriptions

--
Mit freundlichen Gruessen / Best Regards
Richard Oostveen
mobile phone (+49) 01578 44 125 24
Answering address: <email address hidden>

Empfehlen Sie GMX DSL Ihren Freunden und Bekannten und wir
belohnen Sie mit bis zu 50,- Euro! https://freundschaftswerbung.gmx.de

Roman Yepishev (rye) on 2012-04-29
Changed in ubuntuone-servers:
assignee: Martin Albisetti (beuno) → Roman Yepishev (rye)
status: Triaged → In Progress
Changed in ubuntuone-servers:
status: In Progress → Fix Committed
Roman Yepishev (rye) on 2012-05-19
Changed in ubuntuone-servers:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions