"Ubuntu One" name creates confusion

Reported by Tony Yarusso on 2009-05-12
346
This bug affects 35 people
Affects Status Importance Assigned to Milestone
Ubuntu One Servers
Undecided
Elliot Murphy
Ubuntu
Medium
Unassigned

Bug Description

The usage of the word Ubuntu in the context of "Ubuntu One" is inconsistent with the Trademark Policy outlined at http://www.ubuntu.com/aboutus/trademarkpolicy

Specifically of note are the following:

"The objective of the Ubuntu trademark policy is to encourage widespread use of the Ubuntu trademarks by the Ubuntu community while controlling that use in order to avoid confusion on the part of Ubuntu users and the general public, to maintain the value of the image and reputation of the trademarks and to protect them from inappropriate or unauthorised use."
The danger of confusion among users and the general public about whether this new service is part of or associated with Ubuntu is extremely high.

"there is no commercial intent behind the use"
The service has clear and stated commercial intent.

"what you are referring to is in fact Ubuntu. If someone is confused into thinking that what isn't Ubuntu is in fact Ubuntu, you are probably doing something wrong"
The service is not Ubuntu and has no association with Ubuntu as a product or community. It merely runs on and works with Ubuntu, on equal footing with other applications like Apache, Firefox, or an Ubuntu user's blog.

"there is no suggestion (through words or appearance) that your project is approved, sponsored, or affiliated with Ubuntu or its related projects unless it actually has been approved by and is accountable to the Ubuntu Community Council"
I am not aware of any such approval or even discussion by the Community Council at this time.

"If you are producing new software which is intended for use with or on Ubuntu, you may use the Trademark in a way which indicates the intent of your product. For example, if you are developing a system management tool for Ubuntu, acceptable project titles would be "System Management for Ubuntu" or "Ubuntu Based Systems Management". We would strongly discourage, and likely would consider to be problematic, a name such as UbuntuMan, Ubuntu Management, ManBuntu, etc. Furthermore, you may not use the Trademarks in a way which implies an endorsement where that doesn't exist, or which attempts to unfairly or confusingly capitalise on the goodwill or brand of the project."
The service clearly falls under the latter list of examples similar to UbuntuMan, and as such is named unacceptably. Furthermore it appears to be attempting to capitalize on the brand, which is similarly explicitly prohibited.

Proposed fix:
Rename the service to not include the words "UBUNTU, KUBUNTU, EDUBUNTU, and XUBUNTU" nor "any mark ending with the letters UBUNTU or BUNTU", or in an acceptably non-ambiguous manner such as "Cloud Storage Solution for Ubuntu".

visibility: private → public
William Grant (wgrant) wrote :

While Canonical Ltd. clearly cannot violate the Ubuntu trademark in a legal sense, it is in very bad taste to use it in a way that is forbidden by the trademark policy that all other parties must follow.

There is enough confusion already that services such as Launchpad and Landscape are developed by and strongly related to the Ubuntu community. Creating another such service - but this time with 'Ubuntu' in the name, reinforcing those incorrect ideas - is not a good idea.

Jane Silber (silbs) wrote :

Hi -

Canonical owns the Ubuntu trademark and licenses it in a way that we think best serves the project. Sometimes that includes commercial use, both by Canonical and by other companies. That's a natural part of protecting the mark and ensuring the health of the project. We also license it in a way that allows the Ubuntu community quite a lot of freedom, and the trademark policy attempts to lay out those use cases. I don't think there is anything untoward in the use of the mark in Ubuntu One.

cheers,
Jane

Tony Yarusso (tonyyarusso) wrote :

Given that the treatment given to Ubuntu One is vastly different than what would be given to any similar project developed by a third party, this very much appears to be a licensing of the mark in a way that best serves Canonical, rather than best serves the project. The blurring of the line between Ubuntu and Canonical is a key concern here, as otherwise this seems to strongly go against the line of the Ubuntu Promise which reads "Ubuntu will always be free of charge, including enterprise releases and security updates." If there exist things that are proprietary in code and commercial in cost, yet marketed as Ubuntu, then those things constitute a separate, for-pay-only "enterprise" version of Ubuntu, which is of course not acceptable to the Ubuntu community. While in legal terms as the controller of the Ubuntu mark Canonical can get away with such things in court, doing so is a violation of the community's trust in it to protect that mark on their behalf, and degrades the value of the Ubuntu name.

Elliot Murphy (statik) on 2009-05-12
Changed in ubunet:
status: New → Won't Fix
Corey Burger (corey.burger) wrote :

Sorry, but I am going to agree with Tony here. Ubuntu is clearly associated with an operating system that based on Linux (and related technologies) that is 99% free software. The current use of Ubuntu is largely by LoCo teams promoting said operating system. There is also use by commercial interests promoting their software as running on Ubuntu or as selling computers running Ubuntu. Both of these latter uses are descriptive and explicitly allowed under most copyright law.

Ubuntu One is completely at a tangent to that. It is a service that can be used in Ubuntu. If we are going to tie Ubuntu into Ubuntu One, then we are violating our own stated promise of keeping Ubuntu all free software.

So basically, yes, Canonical owns the Ubuntu trademark. However, it is accountable to the larger Ubuntu community for use of that trademark and I think this use violates that trust and accountability.

Changed in ubunet:
status: Won't Fix → New
John Lenton (chipaca) wrote :

Where did you get the impression that "we are going to tie Ubuntu into Ubuntu One"?

Corey Burger (corey.burger) wrote :

We could start with the name. But for more facts, we can have:

"Seamless integration with your Ubuntu based computer" - this means you are going to be installing the client by default.

or how about this Oreilly talk: http://en.oreilly.com/oscon2009/public/schedule/detail/8843

Basically, UbuntuOne is useless with deep Ubuntu integration.

Corey Burger (corey.burger) wrote :

I should also mention there are two directly related instances that matter here:

1. Canonical created Landscape, which is a similar sort of service. It too has an open client with a closed source server side. It is explicitly not Ubuntu Landscape, it is just Landscape

2. The service now known as buntfu.com, which is a service that allows people to list PCs running Ubuntu used to use the tag "computers for human beings" and was told to stop by Canonical

As a way forward, I suggest the following:

1. Change UbuntuOne to Ubunet. It neatly avoids the issue of violating teh spirit of the trademark, while still being clearly associated with ubuntu (ala buntfu)
2. change Ubuntuone.com to have two links, one to ubuntu.com and one to ubunet.com, much like the Mozilla people did with Firefox.com for a long while.

David D Lowe (flimm) wrote :

Just the company name "Canonical" is enough to associate the product with Ubuntu anyway. Why not call it "Canonical One"? That way, you're advertising the company too.
According to canonical.com, "Our distribution Ubuntu is a community developed and supported project." But exactly how is the community involved in Ubuntu One? How does Ubuntu One meet the Ubuntu philosophy? How is this project more worthy of the trademark then community driven U-lite, which was forced to change its name from UbuntuLite?

Elliot Murphy (statik) on 2009-05-12
Changed in ubunet:
status: New → Won't Fix
Corey Burger (corey.burger) wrote :

Elliot, since you persist on closing this bug without discussion, I am reopening and assigning it to the Community Council.

Changed in ubunet:
assignee: nobody → Ubuntu Community Council (communitycouncil)
status: Won't Fix → New
michael thompson (michaeldt) wrote :

The reasons listed in the description above are all quoted from the section:

"Permitted Use

Certain usages of the Trademarks are fine and no specific permission from us is needed. "

However, the trademark policy also makes provision for commercial uses not covered by the usages covered under that section. Hence the policy indeed does make provision for the use of the Ubuntu trademark in Ubuntu One.

As an aside, Canonical are financial supporters of Ubuntu and own the trademark. Associating their service with Ubuntu lends a sense of familiarity to the product more than the Canonical trademark would. This project would allow canonical to generate income which ultimately supports the development of Ubuntu. If Ubuntu were a free standing project with no financial support from Canonical then I could understand the desire to not associate Ubuntu One with Ubuntu, however, as far as I am aware that is not the case.

Corey Burger (corey.burger) wrote :

The issue is that this use requires a trademark exemption (in my view) and the person that grants that exemption is Canonical. Who then grant it to Canonical...

Tim Cole (tcole) wrote :

Without taking sides, I think this is something we do need to reach a consensus with the Community Council about.

Jono Bacon (jonobacon) wrote :

I see this bug as invalid for a few reasons:

 * Ubuntu One cannot infringe the Ubuntu Trademark Policy when Canonical is the rights holder. The Trademark Policy is provided to license the marks out to a range of groups, teams and users in a way that is flexible yet affords the protection of the mark, which is important to us all. Ubuntu One is a Canonical driven project and product and as Canonical is the rights holder, there is infringement of the policy.

 * Secondly, Corey, you assigned this to the Community Council (yet didn't raise this as a topic on https://wiki.ubuntu.com/CommunityCouncilAgenda). The Community Council is the wrong place to raise trademark issues: you should instead contact <email address hidden>. If you wish to raise an issue over the Ubuntu One's inclusion in Ubuntu, then this is a topic for the Technical Board and you can raise it at https://wiki.ubuntu.com/TechnicalBoardAgenda.

On Tue, 2009-05-12 at 22:13 +0000, Tim Cole wrote:
> Without taking sides, I think this is something we do need to reach a
> consensus with the Community Council about.

Unfortunately, most of the CC seems to have expired four days ago, and
no appointment or election of replacements has been seen.

--
William Grant

I appreciate that people have opinions about the trademark, and I welcome people to talk about them and bring them up in the appropriate forums. We're using this bugtracker to track our ongoing work on the project, and I'd like to keep it reserved for keeping track of features, tasks, changes, etc. It's fine that this was reported as a bug initially, it was commented on, and I am now closing it.

Changed in ubunet:
assignee: Ubuntu Community Council (communitycouncil) → nobody
status: New → Won't Fix
Corey Burger (corey.burger) wrote :

Jono,

Do you not see a conflict of interest with Canonical granting itself rights to Ubuntu for whatever reason? No other company has the right to do that without Canonical stepping in. Even companies that have invested considerable money in Ubuntu, such as Dell, HP, etc. (yes, Dell et al use Ubuntu, but in a descriptive sense, not to launch a minorly related product)

I am going to escalate directly to the technical board because <email address hidden> goes to a Canonical employee, who is then ina conflict of interest.

Jono Bacon (jonobacon) wrote :

Corey: the filed bug here is not whether you see a "conflict of interest": the topic is whether "Ubuntu One" infringes the Trademark Policy, which is doesn't. "Ubuntu One" is a commercial service, and as per the published policy at http://www.ubuntu.com/aboutus/trademarkpolicy :

----

Permission from us is necessary to use any of the Trademarks under any circumstances other than those specifically permitted above. These include:

 * Any commercial use.
 * Use on or in relation to a software product that includes or is built on top of a product supplied by us, if there is any commercial intent associated with that product.
 * Use in a domain name or URL.
 * Use for merchandising purposes, e.g. on t-shirts and the like.
 * Use of a name which includes the letters BUNTU in relation to computer hardware or software.
 * Services relating to any of the above.

----

As Elliot recommends, discussion of this topic outside the realm of this bug should be taken elsewhere.

William Grant (wgrant) wrote :

Jono, I don't see your point - Ubuntu One falls afoul of most of those points, and "Permission from us" is the part that is a conflict of interest. Canonical cannot impartially decide to grant itself the ability to use the trademark.

William Grant (wgrant) wrote :

I am also pretty sure that the conflict of interest is exactly what Tony had in mind when he filed this bug, so the discussion is in scope of this bug (even if it shouldn't be filed as one).

Jono Bacon (jonobacon) wrote :

William:

"Jono, I don't see your point - Ubuntu One falls afoul of most of those points, and "Permission from us" is the part that is a conflict of interest. Canonical cannot impartially decide to grant itself the ability to use the trademark".

Yes it can, as it is the owner of the Trademark. Canonical is well within its rights to allow any commercial vendor (Canonical or otherwise) use of the Trademark, and the policy is clear in this.

The question as to whether it is reasonable for "Ubuntu One" to have this permission is entirely subjective to your own views, but fundamentally there has been no infringement of the trademark policy.

William Grant (wgrant) wrote :

Canonical is well within its legal rights, yes, but it is by no means impartial. Canonical is also well within its rights to relicense bzr under a proprietary license (contributors entrust Canonical with their copyright), or close off Ubuntu from community developers. But there is obviously an expectation by the rest of the community that Canonical won't do either of those things. The same sort of expectation very probably applies to use of its power in granting trademark exemptions - some rights can be legally exercised, but would violate the trust that the Ubuntu community places in Canonical.

Corey Burger (corey.burger) wrote :

I should have changed the bug report title, because, yes Jono, you are completely correct legally. There are two issues here:

1. Canonical is apparently marketing a service that is only tangently related to Ubuntu and is using the Ubuntu trademark to promote a non-free service
2. Canonical granted itself the right to do so, as owner of the trademark

Both need to be addressed by somebody that is not Canonical, whether that be the Tech Board or the CC

Jono Bacon (jonobacon) wrote :

Ok, thanks for the input chaps. I think its reasonable to consider this specific bug report closed after the discussion. Wider discussion of the topic is more appropriate elsewhere.

Mike Basinger (mike.basinger) wrote :

I would suggest maybe a session at UDS on this. I would encourage people continuing this discussion on the Ubuntu Forums, which serves as a better discussion platform that Launchpad.

Jonathan Jesse (jjesse) wrote :

I agree with the comments that Corey made regarding this bug. From what I've heard Ubuntu One will integrate with Ubuntu Contacts or whatever and will be deeply integrated into the OS. How is this different then Azure and Mesh from Microsoft? Azure is the cloud platform and Mesh is what Ubuntu One is copying.

The question is will not running Ubuntu One degrade the performance of Ubuntu? Also will it be Kubuntu One or Xubuntu One? Or will there be Ubuntu One for KDE?

I would argue for a namechange

William Grant (wgrant) wrote :

I'm not aware of any forum (mailing list, IRC channel, or web forum) in which this discussion is appropriate - there is nothing project-wide AFAICT. All three would be useful.

Matthew East (mdke) wrote :

Actually, I don't really think this is an issue for the Technical Board. It's not a technical aspect of the distribution at all. To the extent that the Ubuntu Community has any way of getting its point across to Canonical, I think this is a discussion suited to the Community Council, because it's essentially a moral and philosophical discussion.

I'm biased though, of course.

On Wed, 2009-05-13 at 08:13 +0000, Matthew East wrote:
> Actually, I don't really think this is an issue for the Technical Board.
> It's not a technical aspect of the distribution at all. To the extent
> that the Ubuntu Community has any way of getting its point across to
> Canonical, I think this is a discussion suited to the Community Council,
> because it's essentially a moral and philosophical discussion.
>
> I'm biased though, of course.

I fully agree with you - it doesn't seem like a TB matter. It was
suggested that the TB was appropriate for contesting the inclusion of
the Ubuntu One client by default (not that it has happened yet), but the
CC certainly seems more appropriate for the trademark issue. The
trademark policy even mentions that the CC is the arbitrator in some
circumstances.

--
William Grant

Why must people work so hard to make other lives harder?

UbuntuOne is a service -for Ubuntu-.

Matt Lee (mattl) wrote :

One (no pun intended) could also wonder why a free software project like Ubuntu is creating further proprietary web applications. We have already seen that much of Launchpad, including the code-hosting part, will now not be released as free software, and now free software users are being encouraged to sign up for a data silo.

Why is Ubuntu One (and Launchpad for that matter) not being released in a way that would adhere to the Franklin Street Statement? http://autonomo.us/2008/07/franklin-street-statement/

Services like http://identi.ca and http://libre.fm have shown that free software users will embrace free network services with abundance.

Matt Lee
Founder, Libre.fm
http://libre.fm/

Paul Sladen (sladen) wrote :

Needs Info + raised at:

  https://wiki.ubuntu.com/CommunityCouncilAgenda

on the basis that incorporation of the complete mark "Ubuntu" causes confusion.

Changed in ubunet:
status: Won't Fix → Incomplete
Paul Sladen (sladen) on 2009-05-13
summary: - "Ubuntu One" name infringes on Ubuntu trademark policy and creates
- confusion
+ "Ubuntu One" name creates confusion
Zubin (zparihar) wrote :

Rename it to UbuOne

I have a question of precedent:

Has Canonical previously granted (or refused) a commercial license to the Ubuntu trademark for any other non-Canonical commercial services?

hills (hills) wrote :

First thing that I thought when I saw "Ubuntu One" name was that one another flavor of Ubuntu was developed, just like "Ubunt Studio", "Ubuntu JeOS", "Ubuntu MID Edition", "Ubuntu Netbook Remix" and the like. This name is presumably really confusing.

Tom Arnold (g0tt) wrote :

I still think this is a valid bug. It may not be technical, but it sure it a logical bug.

Or just change the Ubuntu promise to:
Ubuntu will always be free of charge ( unless it has One, Two, Premium, Advanced etc. attached to the name.)

Let's be honest.

xconsole (sudheera-xconsole) wrote :

"Ubuntu One" name creates confusion.??
If you take a few seconds and read the description on the web page you would understand it's an online storage service for ubuntu systems.

Also the trademark owner has the right to use the trademark for their products and services, so there's no violation of trademark policy here.

------

BTW for all the people who are trying to make this a Free Software vs. proprietary software issue, pls don't try to create confusion trying to promote your own agenda.

Although it would be nice to have the source code to all those great web-apps that are being used in some of the popular services around the Internet (so you can host your own service?), but for the people who are using the hosted (on other people's HW/SW) services it doesn't ensure any of the freedoms that Free Software provides.

It's one thing to demand for Free Software drivers for a piece of hardware you bought but demanding for the source code for an online service you are using just don't make sense.

** Only thing I care about about is that Ubuntu won't force this on everybody and I can easily pull everything from this back to my web-dav based backup server if I'm not satisfied with the service.

benholroyd (ben-holroyd-1) wrote :

ive started a discussion on ubuntu forums

http://ubuntuforums.org/showthread.php?t=1158876

Ubuntu is free and always will be free. UBUNTU, that is. A fully functioning OS, free of charge. Ubuntu One is an optional service provided by Canonical. In no way is it mandatory or tied into the OS in such a way as to cripple your experience should you opt not to use it. lets not get ridiculous people.

Your fluffy ideals do not pay the salaries of Canonicals hard working employees.

jens (jens-joseph) wrote :

If it should be really a cloud service, what's thinking about "Canonical Cloud" (or shorter "CC")

visibility: public → private
William Grant (wgrant) on 2009-05-15
visibility: private → public
Changed in ubunet:
status: Incomplete → New
Martin Albisetti (beuno) on 2009-05-18
Changed in ubunet:
status: New → Incomplete
24 comments hidden view all 104 comments

launchpad = NASA trademark ????

Raybuntu (raybuntu) wrote :

Canonical requires that we use Ubuntu instead of Windows because it's free software, but they don't believe in free software. I really feel screwed!!!!! We want free (as in freedom) software!! Open UbuntuOne (and the parts of Lauchpad that will not be opened) and you'll be a good example to the community! You have a chance to make the right decision, don't screw it up ;)

Matthew East (mdke) wrote :

Please could those lobbying for Ubuntu One to be free software note that that is *not* what this bug is about. Off-topic comments will cause confusion and dilute the real message of this bug.

Thank you.

Brian Burger (bburger) wrote :

Further to Matt's comment, the bug report on UbuntuOne's licensing problems is over here:

https://bugs.launchpad.net/ubunet/+bug/375272

They really are seperate issues, let's try to keep the bug reports seperate too - thanks!

misGnomer (petrit) wrote :

I would respectfully disagree with Matthew East's assessment above (comment #67) in the sense that the two issues — either open-sourcing Ubuntu One or simply renaming it to avoid confusion over the established Ubuntu Philosophy and trademark — are both being debated as "bug fix solutions" to this >>"Ubuntu One" name creates confusion<< problem which is unfortunately causing both confusion and some divisions within the Ubuntu community.

The "Ubuntu One" thread in the forums' Community Cafe section exhibits some of the pro and/or con argumentation, or sometimes lack thereof.

http://ubuntuforums.org/showthread.php?t=1163493

I hope both sides of the argument will be cordially (I wouldn't expect anything less) but also thoroughly debated at the upcoming Jaunty UDS.

Of course in the end everyone agrees that the trademark owners, Canonical Ltd., have the right to proceed in any way they choose to and that the ordinary members of the community will likewise need to assess the situation based on possible changes in future direction.

Niels Egberts (nielsegberts) wrote :

As a user I like the fact the Ubuntu in the name, it suggests that it will work wonderful with my OS. And as long as the client is opensource and there is no a vendor lock-in, I'm happy.

There is offcourse the Ubuntu promise, but I'm fine with it when it only applies to the operating system.

David D Lowe (flimm) wrote :

Dear Mark Shuttleworth,

as always, you're handling controversy with tact and patience. I was proud to have you as the SABDFL when Launchpad's licensing and Firefox's EULA were issues, I think you handled them well. According to the Ubuntu Code of Conduct, you're expected to be perfect and so far you have been (as far as Ubuntu is concerned, IMHO). I trust you to make the right decision concerning Ubuntu One, even if it's one I don't like.

I have read your comment in this bug report and I still have a few questions:
Do you consider Ubuntu One a part of Ubuntu?
Do you feel that the name "Ubuntu One" ties the product to Ubuntu intimately?
Do you feel that community is the focus of Ubuntu?
Do you feel that the community is or will be as significantly involved in Ubuntu One as in Ubuntu?
Do you feel that Ubuntu One fully meets the Ubuntu philosophy and the Ubuntu spirit, without resorting to the special rights Canonical has in owning the trademark?

You don't have to give simple yes or no answers to these questions, I'm not trying to trick you into anything here. I'm trying to understand exactly how this bug is (or is going to be) closed.
If I were to answer the questions, I'd say no, yes, yes, no and no, but I'm not the daddy, am I? ;)

Yours, etc

José Tomás Atria (jtatria) wrote :
Download full text (3.4 KiB)

Mark:

I'm not necessarily advocating a fundamentalist position in either direction. I don't think that you should derive that from the tone of my message, and I apologize if my use of language convened that idea.

I agree with you, as I believe that the most interesting solutions are usually the innovative ones, and sometimes this entails a new look to a debate to incorporate a nuanced middle ground that leaves every one happy.

I too believe that this nuanced solutions, and the possibility of having this discussions openly is what makes Ubuntu a great community to be part of (Having our own SABDFL participating in this discussions is invaluable).

BUT, the problem, and the whole point of my previous comment, to put it in your terms, is that the nuanced solution that was reached to the delicate problem of the relation between Canonical and Ubuntu was, to a great extent, the Trademark Policy, and its relation to the Ubuntu promise and philosophy.

And this solution was in the form of a promise by Canonical to use the name ubuntu for certain things only, and specifically, not for things that are not ubuntu, are not part of ubuntu, and have clear commercial intent (which canonical has all the right to produce and develop, of course).

In naming your cloud computing service "Ubuntu One", you broke that promise. We can find an innovative, interesting, nuanced middle ground solution for the future relation of Canonical and Ubuntu (again, as we had already done so with the tm policy), but before that, there's a decision to be taken, and this decision is of a binary, no middle ground nature: keep the promise by renaming the service, or declare the promise null and void and negotiate a new deal between canonical and ubuntu, all future nuances and middle ground solutions notwithstanding.

Since you are the daddy (ok, not the best choice of words, I retract), this decision is probably yours only, but bear in mind that the trust of the community in the free nature of the Ubuntu operating system rests in nothing more than a similar promise.

Apart from that, I endorse what Matthew East said in his comment (https://bugs.launchpad.net/ubunet/+bug/375345/comments/62), particularly

Matthew East wrote on 2009-05-17:
> I think that some consultation should have taken place with the Community Council about the potential ramifications
> of the name of the project prior to its beta release. It must have been foreseeable that it would cause offence in some
> quarters. Had the issue been raised earlier with the Community Council, issues would have been avoided, because
> even if the Council had decided that the name is acceptable, it could have issued a statement explaining its reasons,
> and I think the Ubuntu community would have appreciated the consultation. Or, if a name change had been the
> conclusion, it could have been put in place prior to the public beta. As it is, the Community Council will be discussing
> the issue somewhat after the event, and any change of name will be much more difficult now that the name is "out
> there" in the technology press. I still think it's the right choice though, myself.

Specifically, if the council had decided tha...

Read more...

michael thompson (michaeldt) wrote :

I feel I must correct something which a lot of people seem to be missing.

"And this solution was in the form of a promise by Canonical to use the name ubuntu for certain things only, and specifically, not for things that are not ubuntu, are not part of ubuntu, and have clear commercial intent (which canonical has all the right to produce and develop, of course)."

The trademark policy DOES allow for commercial use of the Ubuntu trademark. It's under the section titled:

Restricted use that requires a trademark license

Please, stop saying that they have violated their own policy. The policy clearly states that commercial use may be permitted in certain circumstances, i.e you need a licence.

"Permission from us is necessary to use any of the Trademarks under any circumstances other than those specifically permitted above. These include:

    * Any commercial use."

José Tomás Atria (jtatria) wrote :

@michael thompson:
that's a technicality, I have already agreed that it is absurd to say that canonical has violated its own license. I have repeatedly said that this is not a legal issue. Canonical OWNS the trademark, they have all the legal right to use it for whatever they see fit, or license it to whomever they see fit.

They also have the legal right to drop all GPL licensed code and turn ubuntu into a propietary OS, mind you.

This is not a court of law.

the issue is:
if its called Ubuntu,
(everyone would logically think that) it is part of ubuntu.
ubuntu must conform to the ubuntu philosophy,
ubuntu one does not.
stop calling it ubuntu one, or make it part of ubuntu properly (ie, open source it, etc etc).

or redefine what "ubuntu" means, in the context of free software, which means redefining what the "ubuntu community" is.

michael thompson (michaeldt) wrote :

@José Tomás Atria

With all due respect, you misread my comment. I was not commenting on any 'legal' issues. I was simply pointing out that there is a trademark policy which is shown online and which clearly allows commercial use. Whether or not you agree with what Canonical has done is irrelevant.

Your comment said:

"BUT, the problem, and the whole point of my previous comment, to put it in your terms, is that the nuanced solution that was reached to the delicate problem of the relation between Canonical and Ubuntu was, to a great extent, the Trademark Policy, and its relation to the Ubuntu promise and philosophy.

And this solution was in the form of a promise by Canonical to use the name ubuntu for certain things only, and specifically, not for things that are not ubuntu, are not part of ubuntu, and have clear commercial intent (which canonical has all the right to produce and develop, of course)."

However, this is not correct. The policy does allow for commercial use. Again whether or not you agree with this is a different issue. But the fact remains, it does allow it.

The problem is that Canonical are being accused of breaching the policy when that is not the case. The second problem is that a lot of people are reading these comments and then simply repeating them without checking whether they are in fact correct. Hence, many people are effectively slandering Canonical through their own ignorance. And continued usage of this statement here is only making things worse.

Again, the legality of all this is not the issue. The policy does allow commercial use and thus Canonical have not violated their own policy and as such have not "broken their promise," as you put it, in this respect.

João Pinto (joaopinto) wrote :

@michael thompson,
José Tomás may have used the wrong words when he mentioning "trademark", but if you read the entire comment you will understand that is intent was to refer to the Ubuntu philosophy (!= trademark).

The reference documentation for this bug is:
http://www.ubuntu.com/community/ubuntustory/philosophy
AND NOT http://www.ubuntu.com/aboutus/trademarkpolicy

I would also recommend you to read the http://www.ubuntu.com/community/conduct , you may find of special interest the "Be respectful." section.

Thanks

michael thompson (michaeldt) wrote :

@João Pinto

I don't see how to interpret that comment any other way. If you read the paragraphs I was refering to, the trademark policy was explicitly mentioned. If the reference was to something else then quite frankly the mention of the trademark policy is not needed.

With regards to your final comment:

"I would also recommend you to read the http://www.ubuntu.com/community/conduct , you may find of special interest the "Be respectful." section."

your attempt at attacking me personally adds nothing to this debate. Thanks.

Art Gibbens (art-gibbens) wrote :

Both individuals and organizations may have the right to do something. However, that does not make it the right thing to do.

Frankly, I'm a drive-by observer in this whole affair and it doesn't affect me in any way - didn't even know there was this discussion an hour ago.

Power corrupts and absolute power corrupts absolutely. Any organization can become self-serving if the vigilant give up.

And as painful as it may be to walk away, sometimes it is the only recourse - and in the end everyone involved loses.

Been there, done that.

thebrotherofasis (libardoab) wrote :

Well, as I member of the Ubuntu community, I don't have any complaints to see Canonical using Ubuntu's name to offer a product of their own. I don't feel offended at all, for I feel Canonical as actually one of the most valuable members of the Ubuntu Community.

I feel no abuse of power, nor think they want to take advantage of the Community.

On the contrary, I feel grateful to have such a honest and commited company behind the OS that I use and that I promote using.

I don't see why people get offended as a community to see Canonical using their name. I feel Canonical is part of our community, and I agree with Mark in that even if diverse, both really share our values of freedom.

Contrary to those who disagree with Canonical using Ubuntu's name to offer a commercial service, I think that if Canonical can find of any use using Ubuntu's name... well, serve yourself. The more you (Canonical) can grow commercially, the more resources they will have to continue contributing to the development of Ubuntu.

Ubuntu needs Canonical, and I trust them and thank them for what they do. They're good guys.

Let's not let our fears against dicatorships and abuse of power fold our eyes and prevent us from seeing that there can be people, who in spite of being in power, work for the good of all.

I believe in Canonical, I respect the company, and hope they can continue growing financially and supporting us, the Ubuntu Community.

It's like they say: you can't just live out of love... with an empty wallet. Let's be realistic, and accept the possibility that both worlds need each other, and can coexist and grow at the same time.

Good luck with this Mark, and Canonical.

I feel that I will agree with thebrotherofasis. Canonical has done a wonderful job with Ubuntu, and Mark really is the daddy of it all. Because of the wonderful philosophy of open-source software, one could always fork Ubuntu into another OS, so if Canonical went raving mad and started entering code that would eat our babies, the entire community could just switch support over to Linux Mint or something. Just think of Firefox and Iceweasel.

I support Mark, and I really wonder what'll happen when he's gone. How do you replace him?

Dan Kegel (dank) wrote :

"Foo One" is a brand that has been tried before; see
"Sun One" http://en.wikipedia.org/wiki/Sun_ONE
and "Netscape One"
http://www.prnewswire.com/cgi-bin/stories.pl?ACCT=104&STORY=/www/story/24294

In both cases, it sank without a trace. My guess is
that marketing types who have an inflated idea of
their company's importance are drawn to the "Foo One"
brand idea. They soon find that the rest of the world
finds the name stuck-up rather than attractive.

Leave this brand idea to Air Force One and Big Red One. It makes sense there.

I believe that a Community Council meeting was held this morning (last week's was postponed) and this subject was on the agenda. I am unable to find the log however.

I've looked here: https://wiki.ubuntu.com/MeetingLogs/CC and from there here:
http://irclogs.ubuntu.com/2009/05/ and then to: http://irclogs.ubuntu.com/2009/05/25/

If someone could post a link to the meeting log I think that would be useful and I would be grateful.

Paul Sladen (sladen) wrote :

Just to keep up to date:

Community Council meeting on Ubuntu One:

http://irclogs.ubuntu.com/2009/06/02/%23ubuntu-meeting.html

Starts @ 22:52 sladen [TOPIC] Ubuntu One. Brand issues - followup.

> Just to keep up to date:
> Community Council meeting on Ubuntu One:
> http://irclogs.ubuntu.com/2009/06/02/%23ubuntu-meeting.html

Once more, they've put it off. I believe that the whole conversation
can be "summarized" (in my point of view) in these few lines:
23:12 sabdfl there's no upside to a naming contest - the name is
settled. what would be useful is a broader discussion of boundaries in
the area of services rendered from the cloud to the desktop
...
23:14 mdke what concerns me most is sabdfl's "the name is settled" statement
...
23:15 sabdfl mdke: we've had several weeks of discussions on the
bugtracker, and a CC meeting on the topic, and there hasn't been an
argument that I warrant sufficiently compelling to change course on
...
23:16 sabdfl mako, mdke, i understand that you feel this way. it was
an open question when we started the discussion, there are no new
arguments today
(and the "U1" and u1.ubuntu.com name as default)

However, there is the "U1" naming suggestion. It is one of the most
elegant and "doable" suggestions, the discussion could proceed if Mark
would accept the idea of changing the name first.

There have been dozens of suggestions and arguments, I doubt none of
them are accepted. How many users, contributors and members should
complain in order to state this as "enough" reason to change the name?
Most dictators in the history tried to please the people so they don't
rebel. :)

Moreover, if the Ubuntu One is accepted, there will be people
complaining about it, when for example the trademark team complains
about the use of *buntu on some product or website. Yes, I know
Canonical has every right to do this, but it's not included with the
moral handbook, the way I was "raised" in the open source community.

If this goes through, what's the next step? Ubuntu CE (Commercial
Edition) with adobe flash, mp3 and dvd playback pre-installed? That
surely doesn't seem to break the "Ubuntu" promise, since it would be
"Ubuntu CE", right? Then the free version of Ubuntu would fade away
and we'd get stuck with an unstable Ubuntu and a stable paid version,
pretty much like elive developers do. I know I'm exagerating, but
would such actions be doable and expected in the spirit of "Ubuntu
anything"?

Tom Arnold (g0tt) wrote :

Maybe I will come across as someone with "a pitchfork and regrets in the morning", but I still don't get a few decisions.

I can see there are a few issues here.

1. The name: It obviously creates confusion for some people and it will most certainly be ammunition for all the Ubuntu/Canonical bashers. Which the community has to deal/live with.
2. The commercial side. I don't see the big issue other than with the current name it kind of contradicts the Ubuntu promise (maybe only if you don't look too closely but still ..)
3. The closed source nature of the server side. I don't really get why it has to be closed source. If for example file sharing with friends only works if you login through Canonicals login servers than the solution with the most users will be the most popular. It will be hard for competitors to use the code and offer a similar experience. Or is the login and sharing federated?
And anyways I think Mandriva has its own solution. Novell/Red Hat are unlikely to offer it. Fedora even more so. So why exactly does it have to be closed? Understandable reasoning for that decision would be cool.
Debian or some other big FOSS project might get a few EC2 hosts for free to give to devs. Where is the harm in that?

Landscape being closed I can understand, U1 not so much.

BTW: I read all the IRC logs and liked the "Would you think KDE One is a service from Nokia?" question, which as far as I can see was dodged a few times. It might not be 100% applicable here, because KDE owns its own trademark and Nokia "only" provides Qt + a few devs (or just Aaron IDK) but an answer would have been nice nonetheless.

Elliot Murphy (statik) wrote :

Since the name is not changing, setting once more to wontfix.

Changed in ubunet:
assignee: nobody → Elliot Murphy (statik)
status: Incomplete → Won't Fix
Vanishing (vanishing) wrote :

Is this even a bug?
I don't think the name "Ubuntu One" creates any confusion...
+1 for won't fix.

Paul Sladen (sladen) wrote :

Politely revert "Won't Fix;, it's listed for the next CC (courtesy of Silbs):

  https://wiki.ubuntu.com/CommunityCouncilAgenda#General%20Agenda%20Items%20and%20Proposals

Changed in ubunet:
status: Won't Fix → Incomplete
Paul Sladen (sladen) wrote :

Politely revert "Won't Fix", it's listed for the next CC (courtesy of Silbs):

  https://wiki.ubuntu.com/CommunityCouncilAgenda#General%20Agenda%20Items%20and%20Proposals

Paul Sladen (sladen) wrote :

Additionally assign to 'Ubuntu' as this is where the concerns originated.

Changed in ubuntu:
importance: Undecided → Medium
status: New → Confirmed
Savvas Radevic (medigeek) wrote :

> Is this even a bug?

It concerns a project (ubunet) and its naming of a program that is
part of it (ubuntu one). I believe it is correctly reported as a bug.
:)

Mark Shuttleworth (sabdfl) wrote :

The issue from Silbs is the domain move to one.ubuntu.com, which is
orthogonal.

Mark

Paul Sladen (sladen) wrote :

Mark: thanks for that clarification; I've restored the previously overwritten agenda item that /was/ covering those issues.

  https://wiki.ubuntu.com/CommunityCouncilAgenda?action=diff&rev2=1387&rev1=1386

Jeremy Bicha (jbicha) wrote :

I strongly believe that there is a significant problem with the open-source client being named ubuntuone-client. I think that Mark Shuttleworth with good reason wants a way for Ubuntu to make money. If Fedora were to integrate Ubuntu One, Canonical could gain additional customers and funding but I highly doubt that Fedora would integrate a Ubuntu product so obviously into their distro...for the same reason that Ubuntu likely wouldn't have "Fedora Movie Editor" by default (I suppose Fedora could rename their version of Ubuntu One as Fedora One but I think people wouldn't be happy...) but Fedora & Ubuntu do borrow technology from each other.

Suggestion: Call the open-source stuff something more generic...for instance u1 or ubunet. Continue to call the service provided by default in ubuntu-desktop Ubuntu One (like file-roller is Archive Manager). Consider how Fedora or Mint or whoever can provide the client with Ubuntu as a provider.

I think something profound is happening here.

The views expressed in this thread illustrate a fundamental redefining of the relationship between a business and its customers.

By intent or not, Mr. Shuttleworth has created a company with a truely symbiotic relationship to its customers. This issue rises from a clash between the traditional commerce-centric view and this developing symbiotic view where any party that significantly effects the success of the other must be considered least a conflict cause both to fail.

Canonical would cease to exist without the Ubuntu Community and the Ubuntru Community would morph into another Linux distro (U-No?) if Canonical failed.

The decision to create Ubuntu One and use that name feels like one promoted by commerce-centric thinking where the vast majority of Canonical customers -- The Ubuntu Community -- are not really thought of as customers since we don't produce direct revenue, but rather as a massive public relations campaign. The "free" TV programming whose real business purpose is to sell the products in the commercials?

On the flip side of this inseparable relationship, I have no doubt that Ubuntu could not have risen to its nearly dominant market position in the community of Linux distros without the hard work that the drive for commercial success has brought.

Ubuntu One has caused many in the Ubuntu Community to feel betrayed by our leaders. Rules of behavior were set down by those leaders and then ignored by them when they became an obstacle to profits.

The pact in its simplest form is...

... Ubuntu, and anything bearing the text "ubuntu" or close variation of it, is free.

... Canonical and anything bearing the text "canonical" or close variation of it, is commercial.

To keep credit where it is due, my own submission to the name game is...
... "Canonical One"

With the tag line...
... "from the makers of Ubuntu"

Robert

Elliot Murphy (statik) on 2009-08-15
Changed in ubuntu:
status: Confirmed → Invalid
Changed in ubunet:
status: Incomplete → Won't Fix
Paul Sladen (sladen) on 2009-08-15
Changed in ubuntu:
status: Invalid → Confirmed
Paul Sladen (sladen) wrote :

Set to "Needs info"... if after 60 days, no comments are made, it'll be closed automatically.

Changed in ubunet:
status: Won't Fix → Incomplete
Dan Kegel (dank) wrote :

Paul, I'm not a fan of the name, but at this point I think you're beating a dead horse...

Paul Sladen (sladen) wrote :

Dan: I don't recall opening this bug report.... nor do I recall commenting on it in a way that is either for, or against. Other people volunteered their time to Improve Ubuntu/Ubuntu One and did so. In my prior comments above, I have not (I believe) attempted to pass any judgment on its value, nor have I wished to.

What I *did* [pro-actively] do was to forward it to a more suitable forum---this is bug report covering a social issue, not a technical one; social issues are not generally solvable with technical solutions, and bug trackers are primarily suited to technical issues. I was finding the status fight unpleasant to watch from across the street three months ago, and the status-quo during that time has remained sufficient to break the cycle of back-and-forth Confirmed/Won't Fix.

Dan: When people are upset, I can bribe them with ice-cream; but I'm stuck on how to make everyone here happy (including developers with this damned report stuck in their bug lists). What would you (constructively) recommend doing in a way that does not seek to pass judgment on its merits?

(Sadly, the worsening global economic downturn has affected the supply of expired steeds and lead to a shortage!).

Matthew East (mdke) wrote :

Paul: I think Dan is right, the bug should be closed as Won't Fix. The Community Council has discussed the issue and although I was in the minority on the decision and wasn't happy with the process, the ultimate decision is that the name stays and there is no possibility of it staying. Out of respect to the project developers, I'd suggest the bug be put to bed.

Paul Sladen (sladen) wrote :

Matthew: Indeed, if you (as one of the proponents of the issue) are willing and comfortable with closing the bug now, then I would recommend doing so---it would solve an impasse in the way that corporate closure cannot; and the item can finally be removed from the CC agenda.

José Tomás Atria (jtatria) wrote :

I just wanted to chip in with a +1 to Matthew. I was (am?) one of the
more vocal critics of the name decision, and stated my position in
very strong terms above (something i later apologised for), but I too
think that the whole point of the bug report was to submit the issue
to the sanction of the community council. Since the CC discussed it
and reached a solution, even one that i personally don't agree with, i
think the bug report should be closed.

You can't win 'em all, and i think that community is very much about
accepting things even when they don't go your way.

just my two cents...

On Sat, Aug 15, 2009 at 11:15 AM, Paul Sladen<email address hidden> wrote:
> Matthew: Indeed, if you (as one of the proponents of the issue) are
> willing and comfortable with closing the bug now, then I would recommend
> doing so---it would solve an impasse in the way that corporate closure
> cannot; and the item can finally be removed from the CC agenda.
>
> --
> "Ubuntu One" name creates confusion
> https://bugs.launchpad.net/bugs/375345
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
entia non sunt multiplicanda praeter necessitatem

kingu (comradekingu) wrote :
Download full text (4.3 KiB)

Take suggestions and put up a vote in the forums.

2009/8/15 José Tomás Atria <email address hidden>

> I just wanted to chip in with a +1 to Matthew. I was (am?) one of the
> more vocal critics of the name decision, and stated my position in
> very strong terms above (something i later apologised for), but I too
> think that the whole point of the bug report was to submit the issue
> to the sanction of the community council. Since the CC discussed it
> and reached a solution, even one that i personally don't agree with, i
> think the bug report should be closed.
>
> You can't win 'em all, and i think that community is very much about
> accepting things even when they don't go your way.
>
> just my two cents...
>
> On Sat, Aug 15, 2009 at 11:15 AM, Paul Sladen<email address hidden>
> wrote:
> > Matthew: Indeed, if you (as one of the proponents of the issue) are
> > willing and comfortable with closing the bug now, then I would recommend
> > doing so---it would solve an impasse in the way that corporate closure
> > cannot; and the item can finally be removed from the CC agenda.
> >
> > --
> > "Ubuntu One" name creates confusion
> > https://bugs.launchpad.net/bugs/375345
> > You received this bug notification because you are a direct subscriber
> > of the bug.
> >
>
>
> --
> entia non sunt multiplicanda praeter necessitatem
>
> --
> "Ubuntu One" name creates confusion
> https://bugs.launchpad.net/bugs/375345
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Ubunet: Incomplete
> Status in Ubuntu: Confirmed
>
> Bug description:
> The usage of the word Ubuntu in the context of "Ubuntu One" is inconsistent
> with the Trademark Policy outlined at
> http://www.ubuntu.com/aboutus/trademarkpolicy
>
> Specifically of note are the following:
>
> "The objective of the Ubuntu trademark policy is to encourage widespread
> use of the Ubuntu trademarks by the Ubuntu community while controlling that
> use in order to avoid confusion on the part of Ubuntu users and the general
> public, to maintain the value of the image and reputation of the trademarks
> and to protect them from inappropriate or unauthorised use."
> The danger of confusion among users and the general public about whether
> this new service is part of or associated with Ubuntu is extremely high.
>
> "there is no commercial intent behind the use"
> The service has clear and stated commercial intent.
>
> "what you are referring to is in fact Ubuntu. If someone is confused into
> thinking that what isn't Ubuntu is in fact Ubuntu, you are probably doing
> something wrong"
> The service is not Ubuntu and has no association with Ubuntu as a product
> or community. It merely runs on and works with Ubuntu, on equal footing
> with other applications like Apache, Firefox, or an Ubuntu user's blog.
>
> "there is no suggestion (through words or appearance) that your project is
> approved, sponsored, or affiliated with Ubuntu or its related projects
> unless it actually has been approved by and is accountable to the Ubuntu
> Community Council"
> I am not aware of any such approval or even discussion by the Community
> Council at this time.
>
> "If you are p...

Read more...

Matthew East (mdke) wrote :

I've closed the Ubuntu task as per comments 100-102. I don't seem to have permission to mark the ubunet task as "Won't Fix", but perhaps someone else can take care of that.

Changed in ubuntu:
status: Confirmed → Won't Fix
Rodney Dawes (dobey) on 2009-08-15
Changed in ubunet:
status: Incomplete → Won't Fix
Displaying first 40 and last 40 comments. View all 104 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers