Wrapper check for installation is incomplete

Bug #853307 reported by Michael Terry on 2011-09-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntuone-installer
Undecided
Unassigned

Bug Description

The ubuntuone-installer wrapper script only checks for whether ubuntuone-control-panel-gtk is installed.

But imagine the case of Deja Dup, who needs that package and also ubuntuone-couch. And a user that upgrades from Ubuntu 11.04 to 11.10. They will have the control panel, but not the couch package. ubuntuone-installer will install the couch package if it were to run, but it won't because it thinks it is done when it sees that the control panel is intalled.

A solution is to either make the check more robust or to maybe add a --force-install option that Deja Dup could use. For now, I'm going to work around this with my own wrapper script. But it seems like a bug.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers