Squid service startup hides errors

Bug #985004 reported by dobey on 2012-04-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntuone-dev-tools
Status tracked in Trunk
Stable-4-0
Undecided
Unassigned
Trunk
High
Manuel de la Peña
ubuntuone-dev-tools (Ubuntu)
Undecided
Unassigned

Bug Description

Currently, if the squid service fails to start when tests require it, any errors are hidden, and the test fails later. If any error occurs we should print the errors and exit immediately, so that problems can be debugged and fixed.

Related branches

dobey (dobey) on 2012-06-05
Changed in ubuntuone-dev-tools (Ubuntu):
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-dev-tools - 3.99.0-0ubuntu1

---------------
ubuntuone-dev-tools (3.99.0-0ubuntu1) quantal; urgency=low

  * New upstream release.
    - Expose squid startup errors when it fails. (LP: #985004)
    - Default to gi/gtk3 reactors and fallback to glib/gtk2 on Linux.
    - Allow using domain sockets instead of TCP in tests. (LP: #988257)
    - Clean up ServerTestCase properly to avoid dirty reactor. (LP: #1002834)
  * debian/watch:
    - Update watch file to use stable-4-0 series for Quantal.
 -- Rodney Dawes <email address hidden> Tue, 05 Jun 2012 13:17:20 -0400

Changed in ubuntuone-dev-tools (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers