[FFE] Integrate the Qt SSO dialog for authentication

Bug #933576 reported by Natalia Bidart on 2012-02-16
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu One Control Panel
Status tracked in Trunk
Stable-3-0
Undecided
Unassigned
Trunk
High
Natalia Bidart
Ubuntu Single Sign On Client
Status tracked in Trunk
Stable-3-0
Undecided
Unassigned
Trunk
High
Natalia Bidart
ubuntu-sso-client (Ubuntu)
High
Natalia Bidart
Nominated for Precise by Joshua Hoover
ubuntuone-control-panel (Ubuntu)
High
Natalia Bidart
Nominated for Precise by Joshua Hoover

Bug Description

The current authentication screen in the Qt control panel lacks the following:

- an explanation about what Ubuntu One is, and why a user would benefit from using it
- the possibility to create a new account

Screenshots of the current initial screen and the to-be-added screen are attached.

Related branches

Changed in ubuntuone-control-panel:
status: New → Triaged
importance: Undecided → High
assignee: nobody → Natalia Bidart (nataliabidart)
Natalia Bidart (nataliabidart) wrote :
description: updated
Changed in ubuntuone-control-panel:
milestone: none → 2.99.90
tags: added: u1-ffe
Martin Pitt (pitti) wrote :

In Ubuntu we don't use the Qt control panel by default yet (switching to that would be a separate, and more involved FFE/UIFE), so I leave the decision to the Kubuntu folks.

Natalia Bidart (nataliabidart) wrote :

> When would this be done by, if approved?

Hello Scott!

This work will be done before the Beta freeze on March, 1st.

Thanks!

tags: added: u1-fe
Natalia Bidart (nataliabidart) wrote :

I correct myself from the comment above, since BetaFreeze is today.

This bug would be ready and QA' before the Beta 2 milestone.

Also, please note that ubuntu-sso-client will also be affected, since we need to move one "wizard page" from it to the controlpanel.

Changed in ubuntuone-control-panel (Ubuntu):
assignee: nobody → Natalia Bidart (nataliabidart)
importance: Undecided → High
milestone: none → ubuntu-12.04-beta-2
Changed in ubuntu-sso-client (Ubuntu):
assignee: nobody → Natalia Bidart (nataliabidart)
importance: Undecided → High
milestone: none → ubuntu-12.04-beta-2
Martin Pitt (pitti) wrote :

Does this mean you want to move ubuntuone-sso-client to Qt as well?

Unlike ubuntuone-control-panel, which could be installed through ubuntuone-installer, we need to have ubuntuone-sso-client in the default installation. But right now we are still 10 MB oversized, and only have savings accounted for 5 MB (firefox/tbird) and potentially another 4.5 from Python3. So if ubuntuone-sso-client will pull in python-qt, this needs to wait.

Natalia Bidart (nataliabidart) wrote :

Hello Martin!

So, the short answer for "does this mean you want to move ubuntuone-sso-client to Qt as well?" is "no" :-).

Longer answer: we do have now a ubuntu-sso-client-qt package, which provides a Qt UI for generic SSO login/registration, but is not required in the default install. The desktop SSO DBus service provides methods where the caller can request using another UI, but it defaults to the GTK+ UI, which we're distributing in the ubuntu-sso-client-gtk package and that has been migrated to GI bindings.

So, app clients of ubuntu-sso-client will get the GTK+ UI by default, unless explicitly specified by the caller. And in the default install is enough to have ubuntu-sso-client-gtk as dependency (which I already asked Seb and Ken to pull in from the desktop seed).

If you need any other clarification, please ask. Thanks!

Martin Pitt (pitti) wrote :

Thanks Natalia, this seems fine then.

Changed in ubuntu-sso-client (Ubuntu):
status: New → Confirmed
Changed in ubuntuone-control-panel (Ubuntu):
status: New → Confirmed
tags: removed: u1-ffe
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-sso-client - 2.99.90-0ubuntu1

---------------
ubuntu-sso-client (2.99.90-0ubuntu1) precise; urgency=low

  * New upstream release:
    [ Diego Sarmentero <email address hidden> ]
      - Hide the errors label on refresh captcha (LP: #947202).
      - Changed the name of the function assigned to the lambda that is called
        on passwordChanged signal from reset_password_page (LP: #945080).
      - Made on_user_validated also emit stopProcessing so callers can hide
        any processing overlay they are showing (LP: #945094).
      - Fixed: Qt UI: there is not loading overvaly while validating an
        email address (LP: #944767).
      - Fixed: Qt UI: clicking on the "Set Up Account" button takes me
        instantly to the verification page, even if there are form errors
        (LP: #934502).
      - Fix: [UIFe] Improve the display of errors in the Qt UI (LP: #938604).
      - Fixed: The header in the pages is above the overlay (LP: #934523).
      - Fixed: [UIFE] The padding of the wizard pages in the Qt UI is not
        correct (LP: #934519).
    [ Manuel de la Pena <email address hidden> ]
      - Ensure that the strings used in sso do not have "ubuntu one" in them
        (LP: #933729).
      - Ensure that the strings used are the ones provided by design
        (LP: #937905).
      - Added the dialog that will be used to show that a certificate has issues
        (LP: #933729).
    [ Natalia B. Bidart <email address hidden> ]
      - Add proper titles and subtitles for the Login and Forgot password
        pages (LP: #945061).
      - Made UI modules to setup the gui logging logger (LP: #947469).
      - Fallback to the GTK+ UI when the specified ui_executable does
        not exist (LP: #939821).
      - Move the 'choose sign in page' to client code (U1 control panel
        in this case) (LP: #933576).
      - Do not mask ImportError by importing inside a function (LP: #939173).
      - No more strings coming up from the Designer ui files (LP: #938626).
    [ Roberto Alsina <email address hidden> ]
      - Made the network detection code return ONLINE if NM is not available
        (but still UNKNOWN if it's available and fails) (LP: #939703).
  * debian/control:
    - Updated Standards-Version to 3.9.93.
  * debian/watch:
    - Updated to fetch latest milestone.
  * Removed patches which were included upstream.
 -- Natalia Bidart (nessita) <email address hidden> Tue, 06 Mar 2012 15:57:56 -0300

Changed in ubuntu-sso-client (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-control-panel - 2.99.90-0ubuntu1

---------------
ubuntuone-control-panel (2.99.90-0ubuntu1) precise; urgency=low

  * New upstream release:
    [ Natalia B. Bidart <email address hidden> ]
      - Changed the initial signin page so both login and register options
        are shown, and when clicked, the user is presented with either the Qt
        login dialog, or the Qt registration dialog (LP: #933576).
      - 'Apply these settings' button should be at the bottom right corner
        in the Settings tab (LP: #944120).
      - No more strings coming up from the Designer ui files (LP: #938626).
      - Make gettext return unicode so we can format strings
        with unicode variables (LP: #937809).
    [ Roberto Alsina <email address hidden> ]
      - Added a barebones manpage for ubuntuone-control-panel-qt
        (LP: #933021).
      - Preserved the scrollbar position when clearing/filling the folder
        list (LP: #942355).
      - Added keyboard shortcuts for quitting the control panel
        (LP: #900753).
      - Cleanup the ubuntuone-control-panel-qt script moving all logic into
        the main module (LP: #938102).
      - Parse Qt options correctly (LP: #910834).
      - Migrated to argparse when parsin command line options.
    [ Rodney Dawes <email address hidden> ]
      - Remove the GTK+ 2.x control panel (LP: #934270).
      - Pass ubuntuone-installer as app name to QApplication to avoid
        duplication (LP: #939691).
  * debian/control:
    - Bumped dependencies on ubuntu-sso-client to 2.99.90, on
      ubuntuone-client to 2.99.90, and on ubuntuone-installer to 2.99.90.
    - Converted ubuntuone-control-panel-gtk into a transitional package that
      depends on ubuntuone-control-panel-qt.
    - Made ubuntuone-control-panel suggests ubuntuone-control-panel-gui
      instead of recommending it, to avid seeding the Qt control panel to the
      default install.
    - Updated Standards-Version to 3.9.3.
  * debian/ubuntuone-control-panel-qt.install:
    - Install the new manpage provided by upstream.
  * debian/patches/fix-948970.patch:
    - Apply patch from upstream to have the new manpage being detected by
      disutils-extra and thus it gets installed in the expected location
      (LP: #948970).
  * debian/watch:
    - Updated to fetch latest milestone.
  * Removed debian/ubuntuone-control-panel-gtk.install since
    ubuntuone-control-panel-gtk is now a transitional package.
  * Removed patches which were included upstream.
 -- Natalia Bidart (nessita) <email address hidden> Wed, 07 Mar 2012 17:37:47 -0300

Changed in ubuntuone-control-panel (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers